Bug 367731 - anaconda fails on Via VPSD motherboard
anaconda fails on Via VPSD motherboard
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 374111 407221 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 19:09 EST by Tom Wood
Modified: 2008-03-30 15:01 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 11:40:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Wood 2007-11-05 19:09:04 EST
Description of problem: anaconda fails with "install exited abnormally [1/1]"

Version-Release number of selected component (if applicable): anaconda 11.3.0.50


How reproducible: Every time


Steps to Reproduce:
1. Boot machine from F8 RC3 DVD downloaded via Bittorrent and verified OK.
2. Pick any option presented except boot from local drive or memtest.
3. Watch kernel boot perfectly fine.
4. Answer language preference questions (if choosing rescue), otherwise, skip
the DVD test (already ran it once and we're good) and sit back and watch the show. 
4. Watch as
"Running anaconda 11.3.0.50, the Fedora system installer - please wait..." is
instantaneously followed by
"install exited abnormally [1/1]", followed by the orderly shutdown process that
follows.

Actual results: No love.


Expected results: anaconda to proceed normally.


Additional info: Machine is a Via VPSD motherboard with an onboard Via C3
Samuel2 800 MHz processor and PLE133 chipset.  This machine runs F7, Ubuntu
6.10/7.04, DamnSmallLinux 4  flawlessly.
Comment 1 Jeremy Katz 2007-11-06 00:42:48 EST
Any errors on tty3 or tty4?
Comment 2 Brian Gerst 2007-11-09 22:07:01 EST
I am seeing this problem on am AMD K6-2 system.  There are no errors on tty3 or
tty4.  The last line on tty3 is "Running anaconda script /usr/bin/anaconda".  My
best guess is that anaconda was built with a compiler setting that is
incompatible with older cpus (uses unsupported instructions).
Comment 3 Keith G. Robertson-Turner 2007-11-10 22:02:53 EST
Confirmed here too, on VIA EPIA C3 533Mhz system, with F7 running perfectly.
Exactly the same error with Anaconda attempting to install F8 from i386 DVD. No
other errors on the other ttys.
Comment 4 Tom Wood 2007-11-10 22:07:17 EST
I also see nothing useful in terms of error messages on tty3 or tty4.  anaconda
doesn't leave any debugging information at this point.  Any way to get anaconda
to  tell us what it doesn't like?

Comment 5 Keith G. Robertson-Turner 2007-11-11 01:32:29 EST
I just noticed the op states his system is F8t3, but the bug is filed against
F8. My confirmation is for F8 final.
Comment 6 Keith G. Robertson-Turner 2007-11-12 00:06:39 EST
I have a feeling that this is not really an Anaconda bug, but is actually to do
with the kernel or glibc.

I've been messing around with the various test releases, and F8t1 produces this
error when booting the i386 install DVD:

[quote]
This kernel requires the following features not present on the CPU:
0:15

Unable to boot - please use a kernel appropriate for your CPU.
[/quote]

My understanding is that the C3 is classed as i586, is this correct? So there
should be no issue with an i386 kernel, unless the P4 optimisations that I read
about on the "hardware requirements" page of the Wiki means that basically
anything not 100% i686 compatible is unsupported.

Can someone confirm whether or not the kernel shipped on the F8 i386 install DVD
should (theoretically) work with the VIA C3?

I found this link on the LKML that may be relevant(ish):

http://lkml.org/lkml/2007/5/17/119

Additionally, the file responsible for this error code is
/include/asm-i386/cpufeature.h, and error "15" is:

#define X86_FEATURE_CMOV (0*32+15) /* CMOV instruction (FCMOVCC and FCOMI too if
FPU present) */

A quick search turned up the following old Debian bug report that might shed
some light on the issue, also suggesting this may even be a glibc problem:

http://lists.debian.org/debian-glibc/2003/01/msg00367.html

Apparently the VIA C3 does not support the CMOV instruction, but the kernel
and/or glibc as shipped requires it. Is this correct? Is this part of the i386
config?

Googling for "CMOV VIA" turns up a lot of info.

So is this really an Anaconda issue, or is it the kernel or glibc?

I bet rebuilding with the -march=c3 -mtune=c3 flag would make this issue disappear.

How about a "VIA respin" or at least an -mtune=i586 rather than P4 or i686?
Comment 7 Brian Gerst 2007-11-12 08:10:42 EST
Disassembling the libc-2.7.so in the stage2.img image, I see tons of cmovxx
instructions, which are not supported by the C3 and K6 cpus.

model name      : AMD-K6(tm) 3D processor
flags           : fpu vme de pse tsc msr cx8 pge mmx syscall 3dnow k6_mtrr up
Comment 8 Keith G. Robertson-Turner 2007-11-12 12:37:07 EST
So is that it?

VIA and K6 systems are unsupported.

The end.

This is a change from Fedora 7.

Is there an official postion from Red Hat/Fedora on this matter?
Comment 9 Chris Lumens 2007-11-12 12:42:33 EST
*** Bug 374111 has been marked as a duplicate of this bug. ***
Comment 10 Jerry Vonau 2007-11-12 13:17:53 EST
I brought this up a month ago. No response then..

https://www.redhat.com/archives/anaconda-devel-list/2007-October/msg00002.html

Comment 11 Robert 'Bob' Jensen 2007-11-12 13:38:24 EST
(In reply to comment #10)
> I brought this up a month ago. No response then..
> 
> https://www.redhat.com/archives/anaconda-devel-list/2007-October/msg00002.html
> 
> 

Jerry,

Next time always file a bug report.


Comment 12 Chris Lumens 2007-11-12 14:57:30 EST
Rawhide trees built with anaconda-11.4.0.1 (so, not tomorrow's Rawhide but a
future one) will have a potential fix for this.  We'll have to force the i386
versions of glibc and openssl when building the stage2.img.  Please test with
one of these versions and let us know if it works for you.  If so, we can then
investigate building a special stage2 image for F8.
Comment 13 Keith G. Robertson-Turner 2007-11-12 16:58:57 EST
Excellent, thanks!

Where does Rawhide live nowadays? It's been a while since I was involved in
packaging, and everything has moved since then. Is what used to be Rawhide now
koji.fedoraproject.org?
Comment 14 Keith G. Robertson-Turner 2007-11-12 17:03:07 EST
Scratch that, I've found it:

{mirror}/pub/fedora/linux/development/
Comment 15 Tom Wood 2007-11-15 10:44:45 EST
Chris, exactly what would you like tested?  Is there a respin of the rescue CD
that can be used for an installation test?
Comment 16 Chris Lumens 2007-11-15 17:55:35 EST
Tom - if it would be possible for you to test installation of Rawhide using
tomorrow's tree (at least, I hope we have a tree tomorrow and that anaconda is
working a little better) then we can see if this is working.  I know we are
working on a new boot.iso to fix up a couple other issues so if you are willing
to wait longer, you can spare yourself the trouble of trying Rawhide and use our
updated boot image instead.
Comment 17 Federico Simoncelli 2007-11-18 14:40:39 EST
Same problem here, VIA EPIA not able to run anaconda: "install exited abnormally
[1/1]".
I just downloaded {mirror}/development/i386/os/images/stage2.img (updated to
2007-Nov-14 05:48:10) but i still see a lot of cmov instructions.
Is there an updated one somewhere else?
Just replacing the old stage2 with the new one is enough?
Comment 18 Brian Gerst 2007-11-18 19:50:07 EST
The stage2 from today's (Nov 18th) rawhide appears to be working.
Comment 19 Chris Lumens 2007-11-19 11:40:44 EST
Thanks for the testing.  We'll see about pulling this fix in should an updated
boot.iso be made.
Comment 20 Keith G. Robertson-Turner 2007-11-19 16:40:14 EST
What is the procedure for rebuilding the rescue cd using the stage2.img from
rawhide?

I tried:

sudo mount -t iso9660 Fedora-8-i386-rescuecd.iso /mnt/iso -o loop

mkdir newiso

rsync -av --progress /mnt/iso/ newiso

cd newiso/images

rm -f stage2.img

wget  {mirror}/pub/fedora/linux/development/i386/os/images/stage2.img

cd ..

sudo mkisofs -o ~/Desktop/image.iso -V 'Fedora 8 i386 Rescue' -b
isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4
-boot-info-table -R -J -V -T .

But when I boot from this disc it asks for the "location of the rescue image"?
Comment 21 Federico Simoncelli 2007-11-19 18:26:57 EST
(In reply to comment #20)
> What is the procedure for rebuilding the rescue cd using the stage2.img from
> rawhide?
> But when I boot from this disc it asks for the "location of the rescue image"?

Hi, I had the same problem.
You have to download and replace also images/minstg2.img, isolinux/initrd.img
and isolinux/vmlinuz.
Comment 22 Atanas Georgiev 2007-11-20 01:02:08 EST
I have an EPIA mini-itx board with a VIA C3 CPU and I ran into the same problem
when trying to install Fedora 8.

I followed Chris' suggestion (comment 12) and tried Rawhide from 2007-11-18. Ana
conda was able to get past the problematic stage of the install (it wasn't able
to switch to graphics mode, but I guess that's a smaller problem and subject to
a different bug report).  I did not pursue actual installation (this machine is
intended for a small server and needs to be relatively stable) but it looks like
 this bug is no longer apparent.

Looking forward to the official release of the new boot images.
Comment 23 Martin Jürgens 2007-12-03 01:25:09 EST
*** Bug 407221 has been marked as a duplicate of this bug. ***
Comment 24 Keith G. Robertson-Turner 2007-12-11 00:03:20 EST
For all VIA or K6 owners waiting to install Fedora 8, Merry Christmas:

http://pilot.genomicscenter.nl/revisor/f8-i386-respin/iso/

Tested and verified. Uses Anaconda backport from Rawhide.

Thanks to Jeroen van Meeuwen and Bob Jensen at Fedora Unity.
Comment 25 Jeroen van Meeuwen 2007-12-11 05:31:13 EST
Please do not treat this URL as a steady one, as this was a pre-release for the
Fedora Unity Re-Spin, which is to be announced on all relevant mailing lists,
IRC, WWW and fora. For the time being, the iso's move to (as I need to do
another respin to attempt solving the yum depsolving loop):

http://pilot.genomicscenter.nl/revisor/20071209
Comment 26 Chris Lumens 2007-12-11 10:26:21 EST
Thanks for testing this and coming up with the respin.
Comment 27 Jerry Vonau 2007-12-11 12:29:10 EST
How about a 586 rescue disk? That would be nice, to be able to use any mirror
while using the cd's stage2 for the install. 
Comment 28 Steve Tanimoto 2008-02-06 22:18:21 EST
Hi. I just tried to do an upgrade of my FC 5/FC 6 (some things give me a
"floating point exception" after that upgrade) installation to FC 8 using the
respin ISOs as of yesterday. My system has an AMD K6-2 processor and the
standard ISO for FC 8 did the "install exited abnormally" thing mentioned above.
  The respin seemed be going well until I got the following error.

anaconda 11.3.0.50 exception report
Traceback (most recent call first):
  File "/usr/lib/booty/bootloaderInfo.py",
line 759, in writeGrub
    f.write('#           root %s\n' %
self.grubbyPartitionName(bootDevs[0]))
  File "/usr/lib/booty/bootloaderInfo.py",
line 1191, in write
    justConfig | (not self.useGrubVal))
  File "/usr/lib/anaconda/bootloader.py",
line 193, in writeBootloader
    justConfigFile, anaconda.intf)
  File "/usr/lib/anaconda/dispatch.py",
line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py",
line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line
609, in run
    anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda", line 952, in
<module>
    anaconda.intf.run(anaconda)
IndexError: list index out of range


I am doing a hard-disk install (actually upgrade) using a rescue CD made from
the respin rescue CD's ISO and from the five ISO files for CD1 through CD5 of
the i386 respin release.

When the install/upgrade process asked me where to install the new loader I
selected the master boot record. (I don't remember what the other choices were.
There may have been a problem reported at that point in the install about being
able to install the new loader.)

I don't know if this bug should be reopened.  But anaconda is not exiting
gracefully here, and I'm not sure what to try next in order to upgrade my system
to FC 8.

Thanks.
--Steve


Comment 29 Steve Tanimoto 2008-02-07 01:33:18 EST
I've about decided to give up on the "upgrade" path and do a fresh install.
Perhaps my situation is unusual in that I had two installations of FC 5.  The
usable, active one was part-way upgraded to FC6 via "yum -y update".  The result
was less than satisfactory because many of the upgraded apps (including yum
itself) would immediately abort with "floating point exception").  The other
installation was on a SATA drive under LVM management.  That installation
couldn't boot directly due to a limitation of the motherboard or bios accessing
a SATA/LVM drive for booting, and I hadn't bothered to set up a chained booting
arrangement from the IDE drive.  For some reason when I tried to use the FC8
rescue disk to upgrade Linux, it would only see the FC5 installation on the SATA
drive.  In spite of my bug report above, it seems to have actually completed the
upgrade to FC8 of that installation.  But that is not the installation with all
my settings that I wanted to upgrade.  I tried unplugging the SATA drive and
then starting the install-upgrade process again, but then the installer couldn't
find ANY Linux systems that it could upgrade.  I assume it has some issues with
my main FC5/6 installation -- probably partition or volume labels. It says it
needs to do a fresh install and prompts me to go ahead an repartition the IDE
drive.  After backing up lots of files and settings, I plan to do that.
 I am trying to keep this particular system going because it is relatively low
power and quiet.  Since I run it constantly (it's a web server, etc), these are
more important to me than performance.

In any case, I'd like to thank Jeroen and Bob and Fedora Unity for providing the
respins that will work with the AMD K6-2.
Comment 30 Philippe Leclercq 2008-02-24 15:07:22 EST
Hi,

I just tried the latest Fedora 8 re-spin DVD ( 20080204 ) but unfortunately it
seems that the bug fix has not been added. Please let me know if this shouls be
the case or not.
Could you also let me know if the anaconda release for Fedora 9 will support
i586 and AMD/K6 chipset ?

Many thanks for your feedback.

--Phil
Comment 31 Jeroen van Meeuwen 2008-03-30 13:33:34 EDT
Fixed in anaconda-11.3.0.50-6, -8 and -9
Comment 32 Jerry Vonau 2008-03-30 15:01:55 EDT
The rpms and srpms are available where?

Note You need to log in before you can comment on or make changes to this bug.