Bug 400791 - Failure to open files in new frames
Failure to open files in new frames
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
8
athlon Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 06:46 EST by Keith Dixon
Modified: 2009-01-09 00:21 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:21:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Dixon 2007-11-27 06:46:27 EST
Description of problem:
New frames are unusable.  I have had many problems with them but I hope the
"Steps to Reproduce" will demonstrate just one specific behaviour.

Version-Release number of selected component (if applicable):
xemacs-common-21.5.28-5.fc8
xemacs-packages-base-20070427-1.fc8
xemacs-packages-extra-20070427-1.fc8
xemacs-21.5.28-5.fc8


How reproducible:
Almost always

Steps to Reproduce:
1.
Start XEmacs, with the distribution init.el, using
Applications->Programming->XEmacs Text Editor

2.
C-x C-f
   Mini Buffer: Find File: ~/
RET
   Home directory, /home/someuser, is displayed in the buffer someuser.
M-x find-file-at-point RET
   Mini Buffer: Find file or URL: ~/somefile
RET
   File is displayed in a buffer.
Buffers->someuser
   Home directory, /home/someuser, is displayed.
File->New Frame
   New frame appears displaying home directory.
Move mouse to new frame.
M-x find-file-at-point RET
   Mini Buffer: Find file or URL: ~/somefile
RET
   Mini Buffer: Buffer is read-only:#<buffer "someuser">

3.
  
Actual results:
The mini buffer displays the "Buffer is read-only" error and subsequent
behaviour of the editor is unpredictable.

Expected results:
The file, somefile, should be displayed in a buffer in the new frame.


Additional info:
Subsequent operations sometimes elicit the response
   Minibuffer: dired-subdir-alist seems to be mangled

xemacs -vanilla seems not to have this problem.

problem is not present in F7
 XEmacs Beta Version version 21.5.28 of May 2007
Comment 1 Ville Skyttä 2007-11-27 12:25:05 EST
By "the distribution init.el", do you mean /etc/skel/.xemacs/init.el copied
as-is to ~/.xemacs/init.el?

Unfortunately, I cannot reproduce the behaviour you see, the test case works for
me as expected on x86_64 F8 with out of the box configs.  If xemacs -vanilla
doesn't have the problem, it must be something in the init files.  Could you
check if it's something in your ~/.xemacs/init.el, or ~/.xemacs/custom.el (just
move them somewhere out of the way temporarily while testing things)?

Does "rpm -V xemacs xemacs-common xemacs-packages-base xemacs-packages-extra"
output anything?
Comment 2 Keith Dixon 2007-11-27 14:25:33 EST
1) Yes. Initially, I had the problem with my own ~/.xemacs/init.el file so I
reinstated the original, which does nothing, and there was no difference.  I
have also tried with:-
System->Preferences->Look and Feel->Windows
  Select windows when the mouse moves over them
checked and unchecked without success as I still have the problem reported in
Bugzilla Bug 244190.

2) xemacs -vanilla also omits a few other things at startup, if I recall.
I have also tried without a ~/.xemacs/custom.el without success.

3)"rpm -V xemacs xemacs-common xemacs-packages-base xemacs-packages-extra"
reports nothing.

I get the same behaviour if I open a new frame by clicking the "Info" button and
then try to open a file by hitting return with the cursor on a filename in the
home directory buffer in the original frame.  In fact I get into a real mess if
I do that and have to kill the editor. 
Comment 3 Ville Skyttä 2007-11-27 15:10:01 EST
I can't reproduce the problem with the Info button recipe either.  FWIW, I run
KDE.  Does the problem occur also with xemacs -q?
Comment 4 Keith Dixon 2007-11-27 15:51:07 EST
Curiouser and curiouser... xemacs -q seems to work fine, and that just omits the
init file.  Yes, it may well be a Gnome specific issue.
Comment 5 Keith Dixon 2007-11-27 16:11:29 EST
I tried xemacs -q again but hit the "Load init files" button.  The problem then
returns.  Tomorrow, I will try commenting out the lines in the init file and
reinstating them one at a time to see if I can identify which line is causing
the problem.
Comment 6 Keith Dixon 2007-11-28 01:38:23 EST
This, I do not understand.  With the distribution init file, invoking xemacs
from the Applications menu has the problem, but, invoking from the command line
as xemacs -q and then hitting "Load init files", it works fine.
Comment 7 Keith Dixon 2007-11-28 05:02:32 EST
I was too hasty.  Invoking from the command line as xemacs -q and then hitting
"Load init files" with the distribution init file does eventually fail after
opening files in both frames.  The first open in a new frame as per "Steps to
reproduce" does work but then, if I go back to the original frame and open a
file by hitting return with the cursor on a filename, I get "dired-subdir-alist
seems to be mangled" and I have to kill the editor.
Comment 8 Bug Zapper 2008-11-26 03:43:11 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-01-09 00:21:21 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.