Bug 244190 - Question dialog ineffective
Question dialog ineffective
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
: 426468 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 09:29 EDT by Keith Dixon
Modified: 2008-06-16 21:35 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 21:35:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Dixon 2007-06-14 09:29:18 EDT
Description of problem:
In the previous version of the package, I reported a bug to xemacs.org relating
to the "Question" dialog which asks "Buffer buffername modified: kill anyway?"
and shows buttons Yes, No and Cancel when attempting to delete a buffer
containing unsaved changes.  This dialog had no effect if any of the buttons
were selected but crashed xemacs when the dialog window was dismissed.  This
later behaviour is fixed in the current version but the buttons still have no
effect; so I cannot kill the buffer discarding the changes.

Version-Release number of selected component (if applicable):
xemacs-21.5.28-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. Start Xemacs and visit a file
2. modify the buffer
3. select Buffers->Delete Buffer buffername
4. select Yes in Question dialog
  
Actual results:


Expected results:


Additional info:
Comment 1 Ville Skyttä 2007-06-14 16:19:08 EDT
I cannot reproduce; the sequence:

$ xemacs foo
[hit enter to modify the buffer]
Buffers->Delete Buffer foo
Yes

...results in the buffer being deleted as expected, and me finding myself in a
scratch buffer.  This is FC7 x86_64 KDE.
Comment 2 Keith Dixon 2007-06-15 02:43:28 EDT
I tried it again and the problem is still there.  I opened the file from within
XEmacs using 'find-file-at-point mapped to the F3 key.  Is the Athena widget set
version different? Mine is reporting as:-

neXtaw-0.15.1-10.fc6
Comment 3 Keith Dixon 2007-06-15 02:44:52 EDT
Sorry, forgot, I am using Gnome.
Comment 4 Ville Skyttä 2007-06-15 12:03:56 EDT
I have the same neXtaw version, and can't reproduce in KDE nor GNOME.  Could you
try reproducing while running XEmacs with "xemacs -vanilla"?
Comment 5 Keith Dixon 2007-06-15 14:35:52 EDT
It does not work in xemacs -vanilla either. In addition, the OK and Cancel
buttons in the Find File dialog, selected by File->Open..., do not work. 
However, selecting a file in the dialog by mouse and then hitting return does work. 

I do not know if it is relevant but I have changed
/apps/metacity/general/focus_mode from sloppy to mouse.
Comment 6 Ville Skyttä 2007-06-19 11:45:39 EDT
It most likely is relevant - I managed to reproduce.

With /apps/metacity/general/focus_mode = mouse, the buttons do nothing.  With
/apps/metacity/general/focus_mode = click, they work as expected.  In KDE, they
appear to always work no matter which focus mode is in effect.

Cc'ing metacity maintainer, any ideas?
Comment 7 Keith Dixon 2007-06-19 15:02:24 EDT
I have already reported a bug relating to metacity, Bugzilla Bug 243761.  I
could even be related if there is an underlying race condition.  That could
explain why some people see it and others do not.  My machine is a venerable
650MHz Athlon.  Most peoples machines are much faster.  I had what I am
convinced was a race condition problem in the kernel under FC5 which prevented
my speedtouch modem from loading its firmware (Bugzilla No. 187299).  That was
never identified but just went away in FC6.
Comment 8 Tom Browder 2007-07-10 15:56:37 EDT
I'm still having this problem.  I have changed
/apps/metacity/general/focus_mode to 'click' to no avail.  I have tried setting 
window preference, focus follows mouse, both on and off to no avail.
Comment 9 Ville Skyttä 2007-12-21 12:49:57 EST
*** Bug 426468 has been marked as a duplicate of this bug. ***
Comment 10 Fabrice Bellet 2008-01-17 12:52:09 EST
The problem is still in Fedora 8, and the workaround described in comment #c6
works for me (focus_mode set to 'click' instead of 'sloppy').
Comment 11 Bug Zapper 2008-05-14 09:04:55 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2008-06-16 21:35:22 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.