Bug 400891 - [te_IN] upon joined charecter the halant was not rendering properly in te-IN
[te_IN] upon joined charecter the halant was not rendering properly in te-IN
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: fonts-indic (Show other bugs)
5.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Rahul Bhalerao
: i18n
Depends On:
Blocks: 429901
  Show dependency treegraph
 
Reported: 2007-11-27 07:52 EST by Krishna Babu K
Modified: 2013-04-12 15:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-01 05:41:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
html file. (381 bytes, text/html)
2007-11-27 07:52 EST, Krishna Babu K
no flags Details
te-IN redering problem. (3.40 KB, image/jpeg)
2007-11-27 07:59 EST, Krishna Babu K
no flags Details

  None (edit)
Description Krishna Babu K 2007-11-27 07:52:54 EST
Description of problem:


Version-Release number of selected component (if applicable):

Gedit 2.16.0

How reproducible:
maintain SCIM in RAWCODE.And provide the code se

Steps to Reproduce:
1.open Gedit 2.16.0
2.Maintain SCIM in RAWCODE.
3.And give the follwing code sequences 0c38+0c4d+0c1f+oc4d

  
Actual results:

స్ట్  

Expected results:

will give in the attachement.

Additional info:
Comment 1 Krishna Babu K 2007-11-27 07:52:54 EST
Created attachment 269701 [details]
html file.
Comment 2 Krishna Babu K 2007-11-27 07:59:41 EST
Created attachment 269711 [details]
te-IN redering problem.
Comment 3 Jens Petersen 2008-03-04 06:07:43 EST
Not yet fixed in fedora.

Krishna, could you file a fedora - there doesn't seem to be  one yet?
Comment 6 Krishna Babu K 2008-06-25 08:13:22 EDT
Hi,

I came to know, this problem can be resolved with the support of
ZWJ(ZeroWidthJoiner). But there is no key stroke was map for ZWJ 
in te-inscript key map. For that recently i have raised a bug with 
fedora. Refno(#451203).

Thanks,
krishna.
Comment 7 Rahul Bhalerao 2008-08-01 05:41:34 EDT
As said by Krishna in above comment this is not a font bug. Thus closing this one.
Comment 8 Padmanabhan V. K. 2009-01-26 17:29:41 EST
Using ZWJ as in bug 451203 for the combination "U+0c2f U+0c4d U+0c30 U+0c4d", pango uses the character sequence "U+0c2f U+0c4d U+0c30 U+0c4d U+200d" as is instead of the reordered sequence "U+0c2f U+0c30 U+0c4d U+0c4d." With the former sequence the glyphs added are "U+0c2f+halanth below-base-U+0c30 U+200d" whereas with the latter we get "U+0c2f below-base-U+0c30 U+0c4d" followed by substitution of below-base-U+0c30 with a wider glyph due to the context of U+0c2f. Now the rendering of "U+0c2f wide-below-base-U+0c30 U+0c4d" can be fixed as suggested in bug 476427 to get "U+0c2f+halanth wide-below-base-U+0c30" which isn't possible with ZWJ.

Note You need to log in before you can comment on or make changes to this bug.