Bug 429901 - [te_IN] upon joined character the halant was not rendering properly in te-IN
[te_IN] upon joined character the halant was not rendering properly in te-IN
Product: Fedora
Classification: Fedora
Component: lohit-fonts (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Rahul Bhalerao
Fedora Extras Quality Assurance
: i18n
Depends On: 400891
  Show dependency treegraph
Reported: 2008-01-23 13:29 EST by Rahul Bhalerao
Modified: 2009-01-26 17:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-09-11 00:43:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rahul Bhalerao 2008-01-23 13:29:39 EST
+++ This bug was initially created as a clone of Bug #400891 +++

Description of problem:

Version-Release number of selected component (if applicable):

Gedit 2.16.0

How reproducible:
maintain SCIM in RAWCODE.And provide the code se

Steps to Reproduce:
1.open Gedit 2.16.0
2.Maintain SCIM in RAWCODE.
3.And give the follwing code sequences 0c38+0c4d+0c1f+oc4d

Actual results:


Expected results:

will give in the attachement.

Additional info:

-- Additional comment from kkrothap@redhat.com on 2007-11-27 07:52 EST --
Created an attachment (id=269701)
html file.

-- Additional comment from kkrothap@redhat.com on 2007-11-27 07:59 EST --
Created an attachment (id=269711)
te-IN redering problem.
Comment 1 Bug Zapper 2008-05-14 00:51:24 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 2 Tony Fu 2008-09-09 23:10:14 EDT
requested by Jens Petersen (#27995)
Comment 3 Rahul Bhalerao 2008-09-11 00:43:34 EDT
The duplicate bug has been already closed as NOTABUG.
Comment 4 Padmanabhan V. K. 2009-01-26 17:29:41 EST
Using ZWJ as in bug 451203 for the combination "U+0c2f U+0c4d U+0c30 U+0c4d", pango uses the character sequence "U+0c2f U+0c4d U+0c30 U+0c4d U+200d" as is instead of the reordered sequence "U+0c2f U+0c30 U+0c4d U+0c4d." With the former sequence the glyphs added are "U+0c2f+halanth below-base-U+0c30 U+200d" whereas with the latter we get "U+0c2f below-base-U+0c30 U+0c4d" followed by substitution of below-base-U+0c30 with a wider glyph due to the context of U+0c2f. Now the rendering of "U+0c2f wide-below-base-U+0c30 U+0c4d" can be fixed as suggested in bug 476427 to get "U+0c2f+halanth wide-below-base-U+0c30" which isn't possible with ZWJ.

Note You need to log in before you can comment on or make changes to this bug.