Bug 401781 - DHCP_HOSTNAME not honored
DHCP_HOSTNAME not honored
Status: CLOSED DUPLICATE of bug 385211
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-27 16:17 EST by Trever Adams
Modified: 2007-12-04 19:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 11:35:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trever Adams 2007-11-27 16:17:01 EST
Description of problem:
It is very important that machines can give their name to the DHCP server and
still get the DNS information from the server. This worked until some time in
f8-devel cycle. It still doesn't work.

Now, you can get Network Manager to give its name to the DHCP server ONLY if you
tell it not to get DNS information. This is broken. I do not need fixed IP
addresses for machines, but I do rely on fixed DNS names.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.5.svn3030.fc8


How reproducible:
Every time

Steps to Reproduce:
1. Give machine optional DNS name
2. Select obtain DNS information
3. Watch it not work.
4. Uncheck select DNS information, /etc/resolve.conf is not ubdated, but DNS
name is sent to DHCP server

Expected results:
This should have worked with obtain DNS information checked.

Additional info:
I am not sure if there used to be a check box for using the DNS name and one for
obtaining information. But it worked through test1 or test2 of f8 I think.
Comment 1 Dan Williams 2007-12-03 10:29:40 EST
Are you editing this via system-config-network?

Also, does setting the hostname in /etc/dhclient.conf work for you?
Comment 2 Dan Williams 2007-12-03 11:35:30 EST

*** This bug has been marked as a duplicate of 385211 ***
Comment 3 Trever Adams 2007-12-03 19:25:06 EST
send host-name "aragorn";  # temporary RHL ifup addition

So, it appears to be in there. Yes, I am using system-config-network.
Comment 4 Trever Adams 2007-12-03 19:30:42 EST
Sorry, I caught myself. I was using tab completion. Yes, as dhclient.conf it
works. As dhclient-ethx.conf it doesn't work.
Comment 5 Dan Williams 2007-12-04 09:45:05 EST
yeah, dhclient-ethX.conf won't work because the default dhclient config file is
/etc/dhclient.conf, unless it's told otherwise.  If there's a need I could
change NetworkManager to attach the interface name to the config file if people
need to differentiate between interfaces.
Comment 6 Trever Adams 2007-12-04 19:26:41 EST
No, I am not interested in that. The dhclient-ethx.conf was created by an old
version of NetworkManager. I do not care how, as long as it works properly.

Note You need to log in before you can comment on or make changes to this bug.