Bug 385211 - NetworkManager fails to honor send-hostname for DHCP
NetworkManager fails to honor send-hostname for DHCP
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
: 401781 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 13:34 EST by Michael Cronenworth
Modified: 2008-09-29 22:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 22:49:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2007-11-15 13:34:15 EST
Description of problem: My network uses a Fedora 6 machine as a DHCP and DNS
server. The DHCP server will hand out an address and send the hostname to the
DNS server so that I can ping the name and get the dynamic IP if it changes.
This worked great under Fedora 7. After I loaded F8 this stopped working.
NetworkManager does not send any hostname to the DHCP server. Somehow it is not
reading the /etc/dhclient-eth0.conf file.

If I disable the NetworkManager service and issue a "service network restart"
command, the hostname is sent and everything works normally. If I start
NetworkManager right after that, the hostname is not sent and my network is
screwed up again.


Version-Release number of selected component (if applicable): 0.7.0-0.5.svn3030.fc8


How reproducible: Always


Steps to Reproduce:
1. Set send host-name "hostname"; in /etc/dhclient-eth0.conf file.
2. Start NetworkManager, no hostname sent.
3. Stop NetworkManager, restart network service, hostname is sent.
  
Actual results: No hostname propagated to DNS server.


Expected results: Hostname pingable via DNS server.


Additional info: Other people have reported this as an issue, too, and I am
seeing the same thing on a clean Fedora 8 system on my same network.
https://www.redhat.com/archives/fedora-list/2007-November/msg02156.html
Comment 1 Christian Nolte 2007-11-26 05:10:48 EST
Just a me too to get things going ;-)
Comment 2 Christian Nolte 2007-11-26 05:23:33 EST
BTW: I just tried a workaround mentioned in the gentoo wiki:

http://gentoo-wiki.com/NetworkManager#Gnome_Specifics

This did not work for me.
Comment 3 Dan Williams 2007-12-03 10:28:19 EST
Does it work if you use /etc/dhclient.conf?  That is the default dhclient config
file location.
Comment 4 Michael Cronenworth 2007-12-03 10:36:32 EST
Yes, it now works. Ugh, I should have done that sooner.

Depending on what is desirable behavior, you may wish to fix the
system-config-network packages since it was writing my desired hostname to the
interface specific file. Is this desirable or should NetworkManager be changed
back to read the interface-specific files?
Comment 5 Dan Williams 2007-12-03 11:14:01 EST
NetworkManager will be changed to allow specifying the DHCP hostname and will
hand that off to dhclient as appropriate.  Thanks for reporting that the
workaround worked for you!
Comment 6 Dan Williams 2007-12-03 11:35:31 EST
*** Bug 401781 has been marked as a duplicate of this bug. ***
Comment 7 Trever Adams 2007-12-03 19:29:32 EST
Bug 401781 may not be a duplicate because following the directions here does not
work for me even when placed in dhclient.conf.
Comment 8 Trever Adams 2007-12-03 19:31:03 EST
Sorry, I caught myself. I was using tab completion. Yes, as dhclient.conf it
works. As dhclient-ethx.conf it doesn't work.
Comment 9 Ray Van Dolson 2008-01-23 17:57:29 EST
(In reply to comment #5)
> NetworkManager will be changed to allow specifying the DHCP hostname and will
> hand that off to dhclient as appropriate.  Thanks for reporting that the
> workaround worked for you!

I realize this bug is old.  Has this feature been added?  How would one properly
configure it?

(Will check rawhide)
Comment 10 Dan Williams 2008-01-23 18:34:45 EST
Not yet, but you can get this functionality by adding the necessary bits to
/etc/dhclient.conf in the interim.
Comment 11 Trever Adams 2008-07-07 10:33:27 EDT
As I noted in my bug #401781, this was a regression in F7 or F8. We are now in
F9 and this bug still exists. Is this going to be fixed as promised? Has this
been forgotten about?
Comment 12 Michael Cronenworth 2008-07-07 10:48:12 EDT
Why was this bug closed? Is there a more appropriate bug opened that requests
hostname support in NetworkManager? Can you (Dan) please link us to it? Should I
(or Trever) open a new bug requesting such? It has been far too long for such a
simple feature to go missing from *two* Fedora versions and multiple
NetworkManager versions.
Comment 13 Dan Williams 2008-07-07 12:15:13 EDT
It was closed because a workaround existed (editing the dhclient config file). 
However, I have added support for honoring DHCP_HOSTNAME upstream, and it will
appear in a future update to NetworkManager.  Thus, reopening the bug.
Comment 14 Alexey Kuznetsov 2008-09-28 05:31:42 EDT
*** Bug 443815 has been marked as a duplicate of this bug. ***
Comment 15 Dan Williams 2008-09-29 22:49:14 EDT
This is now supported in svn4022 and later in f8-updates.

Note You need to log in before you can comment on or make changes to this bug.