Bug 40223 - Install boot.img floppy gives Boot Failed error
Install boot.img floppy gives Boot Failed error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-11 07:25 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-11 07:25:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18)
Gecko/20001108 Netscape6/6.0

Description of problem:
Having created an install floppy using rawrite and boot.img, the installer
always returns "Boot failed: please change disks and press a key to continue".

How reproducible:
Always

Steps to Reproduce:
1. Requires specific computer
2. Boot with floppy created using rawrite and boot.img
3.
	

Actual Results:  The initial 'welcome' screen appears. Which ever selection
is made the result is the message "Loading vmlinuz...", followed by the
"Boot failed:" message.



Expected Results:  If I boot a 7.0 install disk, there appears to be
another step which
does not occur on 7.1. In that case the system reports "Loading
initrd.img..." before the "Loading vmlinuz...".

Additional info:

The hardware is a Digital Celebris GL 5133ST with 32MB RAM, 1GB SCSI disk
and CDROM. The same boot floppy works on other PC's. The 7.0 floppy
works on the problem PC.
Comment 1 Brent Fox 2001-05-11 14:38:13 EDT
This bug could be related to bug #37592, but this problem seems to happen much
earlier than that one.  Does this boot disk work on other machines?
Comment 2 Need Real Name 2001-05-12 02:45:44 EDT
On the problem machine, the installer does not get as far as detecting hardware
of any kind, so it is different to #37592. I've tried the same floppy on three other
machines (one IDE based, one with SCSI U2W on a Supermicro motherboard, and one
with an Adaptec 2940 card) and the floppy works correctly. However on these
machines the floppy does perform the 'Loading initrd.img' step, and does not on
the problem machine. Also having had the 7.0 floppy work, it seems unlikely that
it is a hardware problem with the floppy drive.
Comment 3 Brent Fox 2001-05-14 14:53:21 EDT
This sounds like a kernel issue to me.  There seem to be various problems with
the 2.4 kernel and Digital Celebris machines.  Changing component
Comment 4 Need Real Name 2001-12-08 05:01:40 EST
I have a similar problem with ver. 7.2

After a CD-ROM installation I can't boot with the floppy.
My system was working with the 7.0.

I also try to upgrade 7.0 > 7.2 but I received always the same error"disk 
failed".

My computer hardware:
Pentium 4 1500 MHz
512 RAM
hda Maxtor 20 Gb UDMA5 >> for Win
hdb Maxtor 20 Gb UDMA5 >> for Linux
Motherboard ASUS P4B

For more info please ppmanca@blu.it
Comment 5 Dario Landazuri 2002-02-21 10:13:59 EST
I am having the same problem with a Asus P4B we just got in.  I have a kickstart
disk I made which always gives "Boot failed".  The disk will boot correctly on
other machines in the office.  I tried flashing the BIOS up to the most recent
version, but that hasn't helped.  I can boot a win98/DOS floppy fine.  Any ideas
on this?
Comment 6 Bugzilla owner 2004-09-30 11:38:59 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.