Bug 37592 - Installer exits when beginning to write to disk
Installer exits when beginning to write to disk
Status: CLOSED DUPLICATE of bug 55486
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 49271 51168 52222 53990 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-25 07:21 EDT by Thomas Bjorseth
Modified: 2007-04-18 12:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-20 17:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Bjorseth 2001-04-25 07:21:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


During installation of RH 7.1, the installer stops with an error after 
partitioning disks and selecting packages to install. I have tried both 
text and graphical install, and both normal and expert install without any 
success. I assume the error happens on first read/write attempt to the 
first hard drive.

I get no error messages on any of the virtual consoles that indicates that 
there is a problem. The installer correctly detects all my drives with the 
correct geometry and capacity.

Even when I don't access the second IDE disk (not configured through the 
BIOS) only containing user data the error occures.



Reproducible: Always
Steps to Reproduce:
1. I start installation and follow the step by step instructions
   (keyboard, mouse etc)
2. Partition disks
3. Select packages to install
4. When I get to the step where the installer first tries to access
   the disk (I assume), the error occurs every time.

Actual Results:  I get the error message:

type read: Operation not permitted
pdf: 13Xlib: unexpected async reply (sequence 0xef0a)

I then get the standard error messager "You may safely reboot the system". 
That's it - no more, no less. No error messages on any of the other 
virtual consoles.

Expected Results:  The installer should start to format the partitions and 
copy the selected packages. This never happens.

The computer:
Digital Celebris 6180
- Pentium Pro 180 MHz
- Intel FX chip set (I believe)
- 128 MB ram
- 1 IDE disk configured in the BIOS (2GB containing the system)
- 1 IDE disk not configured in the BIOS (45 GB with user data)
- 1 IDE cd player
- Matrox Millennium graphics adapter
- Intel Ether Express 10/100 network adapter

The computer with the exact same hardware has had RedHat 6.x and 7.0 and 
also Mandrake 6.x and 7.x installed without problems. It's currently 
running Mdk 7.2.
Comment 1 maynard_lag 2001-04-25 11:20:31 EDT
This is similar to the problem that I am having and similar to the system I'm 
having them on. Check out Bug #: 37442
Comment 2 Michael Fulbright 2001-04-25 11:27:28 EDT
Could you try a text mode install please (type 'text' at the install boot prompt)?
Comment 3 Thomas Bjorseth 2001-04-25 14:25:04 EDT
Specification of installation types I have tried (automatically or typed at the 
installation selection screen):

- graphical (default)
- text
- expert
- expert text

I have also tried the different "usage installs" (workstation, server and 
custom) as well. No matter what I try, I get the "type read: Operation not 
permitted. pdf: 13Xlib: unexpected async reply (sequence 0xef0a) error"
Comment 4 Brent Fox 2001-04-25 14:41:30 EDT
Can you check the md5sum of the iso images and make sure that they are ok?
Comment 5 Thomas Bjorseth 2001-04-26 06:37:00 EDT
I deleted the ISO images after creating the CDs, but I downloaded them again 
today (from Sunsite in Norway) with no success. After the initial step-by-step 
keyboard, mouse, partitioning and package selection, the installer stops again. 
The installation was an expert graphical install.

The error on virtual console 1 this time is:
type read: Operation not permitted
pdf: 15Xlib: unexpected async reply (sequence 0x220cb)

A minor change from the previous error, but the same result in the end. No 
other error messages on any of the other virtual consoles. The X console 
appears to be running (the mouse is responding), and the CD spins up as the 
copying is about to begin. If I don't look at VC1, everything appear to be 
normal, the copying just never starts...

One more thing: I haven't deleted or created any partitions, but are using the 
same as I had on Mdk 7.2 (/boot, /, /var, /home, swap and /data). I select to 
format all but one partition (the /data partition), but I never see the 
installer do any actual disk formatting.
Comment 6 Thomas Bjorseth 2001-04-26 07:49:34 EDT
New attempt:

I removed all partitions except the /data partition, to remove any problems 
related to incompatible partitions (can't see why this should happen, though). 
New partitions were made with Disk Druid.

- Booted from my newly created RH 7.1 CD and selected text install.
- Followed the instructions to repartition drive
- Selected the packages I wanted
- Poof! Messages (scattered across the screen):
   - type read: operation not permitted
   - pdf: 16install exited abnormally
   - sending termination signals...done
   - disabling swap...
   - unmounting filesystems...
   - /mnt/runtime
   - /mnt/source umount failed ()
   - /dev/pts
   - /dev/proc
   - You may safely reboot your system

The only "abnormality" I can see on one of the VCs are these two lines just 
before the RAID personalities are registered:

   <7>ISO9660 extension: RRIP_1991A
   <4>Unable to identify CD-ROM format.
Comment 7 Brent Fox 2001-04-26 11:15:54 EDT
Hmm...I have never seen anything similar to this.  What are you using to burn
the cd's?  It looks like the kernel doesn't recognize the disc as a valid cdrom.
Comment 8 Thomas Bjorseth 2001-04-26 15:51:49 EDT
I was beginning to suspect something like this. The PC and BIOS must recognize 
the CD as it is able to boot from it, but the kernel may be unable to detect 
the file system (or other parameters necessary to access the CD).

Both CDs I have tried have been burned with Nero Burning Rom, as all the Linux 
CDs I have burned the last two years or so. The only thing I do that is not 
100% documented and correct, is that I change the .ISO extension to .NRG to 
have Nero recognize the file format (and auto-start by double-clicking the file 
name in Windows Explorer). This has never been an issue earlier, and I can't 
see why is suddenly should be unless there have been changes to the format the 
ISOs are made in (compatibility reasons or similar). Their FAQ page show how to 
burn ISO images, and the parameters mentioned there are the same as I am asked 
to confirm when I rename the ISO to NRG and double-click the file name.

I can test ISO images burned on another PC next week, and these are 100% tested 
and used to install RH 7.1 on another computer (but not by me). I won't be back 
at work until Wednesday next week, so no testing can be done until that time.
Comment 9 Thomas Bjorseth 2001-04-26 15:52:35 EDT
I was beginning to suspect something like this. The PC and BIOS must recognize 
the CD as it is able to boot from it, but the kernel may be unable to detect 
the file system (or other parameters necessary to access the CD).

Both CDs I have tried have been burned with Nero Burning Rom, as all the Linux 
CDs I have burned the last two years or so. The only thing I do that is not 
100% documented and correct, is that I change the .ISO extension to .NRG to 
have Nero recognize the file format (and auto-start by double-clicking the file 
name in Windows Explorer). This has never been an issue earlier, and I can't 
see why is suddenly should be unless there have been changes to the format the 
ISOs are made in (compatibility reasons or similar). Their FAQ page show how to 
burn ISO images, and the parameters mentioned there are the same as I am asked 
to confirm when I rename the ISO to NRG and double-click the file name.

I can test ISO images burned on another PC next week, and these are 100% tested 
and used to install RH 7.1 on another computer (but not by me). I won't be back 
at work until Wednesday next week, so no testing can be done until that time.
Comment 10 Brent Fox 2001-04-26 16:14:10 EDT
If that doesn't work, try making a boot floppy from the boot.img in the /images/
directory on the cd.  Boot off of that, and then select CDROM as the
installation type.  To allow more room for drivers on the boot image, we have
started using a 2.88 MB boot image for the cd.  Some motherboard bioses don't
support this properly, and they have to boot off the floppy to kick off the
install.

Putting this bug in "Needinfo" state until you get another chance to test this.
 Thanks for working with us on this issue.
Comment 11 Craig Franklin 2001-04-26 23:13:01 EDT
I am having a very similar problem.  Everything appears to work until the end of
formating.  The installer outputs a string of error messages and then shuts
down.  Generally, during a text installation, the first message is:

python header.c : 511 : headerLoad : Assertion 'rdlen == dl' failed.
 
During a gui install the first message is:

..Xserver started successfully 
libpng error : Extra compressed data

I downloaded the iso image and burned it with cdrecord.  The same way I did for
6.2 and 7.0.  I don't specifically remember checking the MD5SUM on all of the
images, but I did mount them and they looked good. 

I have two computers with the same motherboard and CPU.  I only have this
problem with one of the machines (the same set of CDs).   I began swapping
hardware from the good machine to the bad machine.  Video card, mouse, keyboard,
monitor ...  I could not fix the problem.  I quit out of frustration and
installed 7.0.

Now that I have cooled off ...  I wish I would have removed the kernel parameter
'hdd=ide-scsi'.  Although it is far fetched, the cdrom was the one thing I
didn't swap.  I believe this is a new install option in 7.1.  

Am I crazy?  I won't have time to retry it for a couple of days at least.  My
CDROM is a creative labs CDR4224 (based on a JVC XR-W4080).
Comment 12 Craig Franklin 2001-04-28 01:29:41 EDT
Bad CD.  It worked on one system, because I didn't install the exact same rpms. 
I will be more careful in the future.
Comment 13 Need Real Name 2001-05-01 19:54:32 EDT
I have verified this bug on 3 seperate Celebris GL 6180 systems. My CD images 
were MD5SUM verified.

This bug should be reopened. I believe that craig franklin's problem was 
different.

The Celebris GL 6180 systems are Pentium Pro based systems. The motherboard is 
a Digital Equipment (now CPQ) MB that uses the following Intel chips:

- SB82442FX
- SB82441FX
- SB82371SB


Comment 14 Need Real Name 2001-05-01 21:00:20 EDT
Red Hat version 7.0 runs and installs fine on the same systems.
Comment 15 Brent Fox 2001-05-02 13:10:47 EDT
adamski, have you tried booting off the boot.img floppy as described above?
Does that help?
Comment 16 Need Real Name 2001-05-02 13:44:27 EDT
Yes, I did and it also failed. I tried booting from CD, dos/autoboot, and 
floppy (boot.img) all with the similar results.

Comment 17 Need Real Name 2001-05-02 14:08:58 EDT
As Thomas indicated it fails at the Installing Packages screen without even a 
single package being loaded. It seems that prior to installing any of the 
packages that the installer creates and formats its partitions just prior to 
loading any packages.

I have verified that the partitions have not actually been written to the disk 
by the failure point. Neither the Auto Partition Option or Disk Druid selected 
partitions are created by the point of failure.

Comment 18 Need Real Name 2001-05-02 14:36:36 EDT
As Thomas indicated it fails at the Installing Packages screen without even a 
single package being loaded. It seems that prior to installing any of the 
packages that the installer creates and formats its partitions just prior to 
loading any packages.

I have verified that the partitions have not actually been written to the disk 
by the failure point. Neither the Auto Partition Option or Disk Druid selected 
partitions are created by the point of failure.

Comment 19 Brent Fox 2001-05-02 15:16:40 EDT
adamski, do you have a SCSI cdrom drive?
Comment 20 Need Real Name 2001-05-02 15:55:10 EDT
I tried installing with the following combinations.

IDE  CD +  IDE HD
IDE  CD + SCSI HD
SCSI CD + SCSI HD

All failed in the same manner. During the pure SCSI test, I neglected to 
disable the IDE controller in the BIOS.

- Joe
Comment 21 Brent Fox 2001-05-02 16:04:12 EDT
Joe-
  Try booting with 'linux ide=nodma'.  Does this help?
Comment 22 Need Real Name 2001-05-02 16:19:14 EDT
The IDE CD + IDE HD test was a special configuration that I tested. My default 
config is IDE CD + SCSI HD.

I just tried boot: linux ide=nodma

Still the same thing.

- Joe



Comment 23 Need Real Name 2001-05-03 19:30:52 EDT
Current status: NEEDINFO? What info is needed.

I did try to boot with 'linux ide=nodma' it did not help. My configuration at 
the time was IDE CD (on Secondary IDE Master) and SCSI HD (2940UW ID 0).

If additional information is necessary please make it known, so that someone 
might be able to provide it.

Thanks.
Comment 24 Thomas Bjorseth 2001-05-04 03:23:00 EDT
Latest results:
I have downloaded new ISOs (twice) and tried to install (at least five or six 
times with different parameters), but to no avail. It doesn't matter if I boot 
from the boot.img floppy or CD. I even tried to install from the "RedHat with 
XFS" CD (both CD and floppy boot) but with the same results.

It doesn't matter if I enable or disable the on-board network (DC2114x) and 
sound (Crystal?) cards.

When I try to create a bootable floppy based on the oldcdrom.img, I can't seem 
to do that. I have tried to create this floppy from two different CDs on two 
different PCs, but when I boot from the floppy I just get an "No operating 
System" message. I have re-confirmed that booting from other floppies works, 
just to be on the safe side (no loose cables etc).

Now that more than one person has confirmed this situation with close to 
identical hardware, I can't help thinking that there's something weird with the 
Digital Celebris 6xxx motherboards.

If you need any more information regarding hardware or software, let me (and 
Joe) know so we can supply you with whe necessary details.
Comment 25 Thomas Bjorseth 2001-05-04 04:15:37 EDT
I just tried three network installs. I created a floppy from the bootnet.img 
file and booted optimistically from it. One attempt with the CD configured in 
the BIOS, one without, one with the physically CD disconnected.

After the usual step-by-stepping through keyboard, mouse, network and 
partitions, I get the error message mentioned several (but this time with "pdf: 
19..." instead of "pdf:13..." or "pdf:14...". The installer accesses the FTP 
server (sunsite.uio.no) to get the package information, so the network is up 
and running bu the time of the abnormal exit.

The funny thing is that on VC4 I get some error messages saying "<6>cdrom: open 
failed" during the last few installer steps until the installer exits. This 
happens during the two installation attempts where the CD is physically 
attached. Why should the installer crash or exit when trying to access a CD-
player during network install? I can't fine a good explanation for this.

My CD drive is a standard Compaq IDE/ATAPI player, and it is working properly 
in all other Linux distros. The installer detects the CD as hdb, and this 
should be correct (slave on first IDE channel).
Comment 26 Brent Fox 2001-05-09 16:25:47 EDT
Alan, does this sound like a kernel problem to you?  All of these people are
seeing the problem on Digital Celebris motherboards.
Comment 27 Alan Cox 2001-05-09 16:57:47 EDT
type read: Operation not permitted
 pdf: 13Xlib: unexpected async reply (sequence 0xef0a)

This is an Xlib error indicating someone did operations without honouring the X
locking/threading rules. An example of that is doing a fork and having both
tasks then continue to use X.

One other way this could occur is BIOS misreporting of memory. Do the install
with the option mem=64M on a 128Mb box. If that then installs we can explore the
memory table on the box and verify the problem
Comment 28 Thomas Bjorseth 2001-05-10 02:22:38 EDT
I just tried to install using "text mem=64M" but to no avail. Still the same 
old "pdf: 14Xlib" error. I can see the installer just reporting 64M of memory, 
so I know the parameter was honoured.

Being an old computer, it can't boot from a bootdisk created with the 
oldcdrom.img boot image. I guess this is due to the disk being 2.88 MB in size, 
but feel free to correct me if I'm wrong.
Comment 29 Alan Cox 2001-05-10 06:55:33 EDT
Ok I am running out of ideas. What I really dont understand is how we got Xlib
error messages when running text mode installs.
Comment 30 Thomas Bjorseth 2001-05-10 07:26:06 EDT
I have wondered about the Xlib-error in text mode myself, but am in no way 
capable of describing what happens and why. I just figured that you used some 
of the functions offered by this library...

If there is a clever way to get all the info from the different VCs onto a 
floppy, I can mail the output to you. Maybe you can find something that I'm too 
blind to see (after all, you probably know what you are looking for).

The things that puzzle me so far during the install (to sum things up a little):
- The partitions are not written do disk (J. Adamski pointed this out, I can
  verify this).
- After detecting the display adapter, no attempt is made to detect resolution
  or refresh rates. This was done in previous versions of the installer, right?
- No monitor need to be selected. The installer jumps to package selection.
- The Xlib 13/14/19 error in text mode.

Maybe you should get hold of a Digital Celebis 6xxx (6150/6180/6200) yourself, 
to get to the bottom of this? Feel free to visit me at work the next time 
you're in Norway. ;-)
Comment 31 Brent Fox 2001-05-14 17:48:17 EDT
We don't have any Digital Celebris systems in the test lab...I don't know how to
get one other than Ebay.  I hate to close this as 'Won't fix', but I don't know
what else to do...
Comment 32 Need Real Name 2001-05-22 14:29:05 EDT
I experienced exactly this today on a Digital Venturis GL 6200.
Even tried doing a kickstart install ... same thing.
Got PhoenixBios 4.05 . Anyone got upgrades for this BIOS ?
Comment 33 Thomas Bjorseth 2001-05-22 15:49:41 EDT
What about attacking the problem from a different angle? So far, it seem like 
everyone have been trying to identify the installer bug by analyzing error 
messages, our feedback and mysterious references to Xlib.

Why not look at the installer itself and figure out what changed from the RH7.0 
installer to the v7.1 installer (at least the text versions should  be pretty 
similar, I figure)? At least three different persons verified that v7.0 
installed without this problem. What changes were made to the installer that 
make the v7.1 installer fail? If i get the time tomorrow, I might try to 
install 7.1 with a 7.0 boot disk just to se what happens (I assume a 
crash/hang/other failure, but I won't know until I try)...
Comment 34 Brent Fox 2001-05-22 16:30:44 EDT
Well, 7.1 uses a 2.4 kernel for the boot disk, and 7.0 used a 2.2 kernel, so you
can expect severe breakage by mismatching the boot disks and the cd's.  But it
should be fun.  :)

Comment 35 Brent Fox 2001-08-22 11:57:15 EDT
*** Bug 51168 has been marked as a duplicate of this bug. ***
Comment 36 Thomas Bjorseth 2001-08-22 13:13:20 EDT
If you want a Celebris PPro 180/200 I might be able to get you a stripped down 
computer (only casing and motherboard) if you are willing o pay for transport 
(from Norway - probably expensive). With Digital being one of the big ones in 
the past, it shouldn't be impossible to get hold of one of these babies over 
there as well for little or no money. Any donors?

I really want my PC upgraded to RH 7.1, if only so for the fun of it. I really 
think my PC would get a much higher self esteem by running the latest k3wL 
stuff like the newer and better PCs... ;-)
Comment 37 Alan Cox 2001-08-22 13:23:01 EDT
I've actually been keeping the odd look out for them on ebay, but with no
success. Even then its not clear that the problem is easily (or at all) curable.

Comment 38 Brent Fox 2001-08-27 15:21:06 EDT
*** Bug 52222 has been marked as a duplicate of this bug. ***
Comment 39 Brent Fox 2001-08-28 14:15:46 EDT
*** Bug 49271 has been marked as a duplicate of this bug. ***
Comment 40 Brent Fox 2001-09-25 15:45:15 EDT
*** Bug 53990 has been marked as a duplicate of this bug. ***
Comment 41 Brent Fox 2001-10-30 16:47:53 EST
We finally have the hardware to test this issue thanks to Mark Seger from
Compaq.  He loaned us a P2 266MHz Celebris.  

Assigning to msw since he says he knows how to fix the problem.  It seems to lie
in the isys.smpAvailable() call.
Comment 42 Need Real Name 2001-11-05 06:10:48 EST
Looks like I'm among friends here...I've just encountered the same problem. And 
yes, it's also an old Digital model - Celebris GL 6200, PPro 200Mhz, 160MB, 
BIOS v1.04 (tried to flash to 1.09, but fails).

Very eager to hear if/when msw fixes the problem.

Alternatively, anyone know if RH 7.2 installs successfully on these Digital 
machines?

Cheers,
Brad
Comment 43 Need Real Name 2001-11-05 09:02:17 EST
RedHat 7.2 has the same problem as 7.1 (I know, I tried)
Comment 44 William Keyser 2001-11-23 06:49:05 EST
FYI I had the same problem with my old Celebris 6200 but I have managed to 
bypass it by first installing 6.2 and then upgrading to 7.2. You might want to 
try it out if you disparately need the new features in 7.2.

Of course this does not explain WHY you can't do a direct install, but at least 
it will get you running.

cheers,
william

PS thanks to Thomas for pointing me to this bug (I was going nuts trying to 
figure out what I was doing wrong)
Comment 45 Alan Cox 2001-12-11 11:03:54 EST
Ok firstly. we have successful installs of RH 7.2 on the Celebris boxes (I know
because someone with one filed a different bug 8))

Secondly I managed to talk Celebris stuff over with someone afflicted by one who
had done some working out what actually worked. He reported that he needed

APM disabled (our boot apm=off option may be enough but that doesnt stop the 
16bit boot up APM calls)

A 1999 or later BIOS

We have a pattern of Celebris reports so its not a one off machine funny IMHO.
Comment 46 Seth Lerman 2002-01-20 00:05:48 EST
Looking to see if this issue has been resolved as of yet.  Last update I see is 
from over a month ago.  I just came into possession of 6 of these machines and 
I would like to make use of them using RH 7.2

Thank you...
Comment 47 Jeremy Katz 2002-03-26 19:15:41 EST
There is an update disk available at
ftp://people.redhat.com/bfox/7.2-celebris-quickfix.img to fix this problem.

Download this file and dd it to a floppy.  Then boot the 7.2 installer with the
'linux updates' command.  Insert the updates floppy when prompted.  Does this
fix the problem?

*** This bug has been marked as a duplicate of 55486 ***

Note You need to log in before you can comment on or make changes to this bug.