Bug 402321 - [ml_IN] Wrong combinations used for the conjunct 'ന്പ'
[ml_IN] Wrong combinations used for the conjunct 'ന്പ'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lohit-fonts (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Rahul Bhalerao
Fedora Extras Quality Assurance
: i18n
: 247452 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 02:29 EST by Ani Peter
Modified: 2016-07-31 21:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 18:40:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot for the conjunct combination (94.69 KB, image/png)
2008-01-10 04:24 EST, Ani Peter
no flags Details
patch for Lohit-Malayalam.sfd (40.48 KB, patch)
2008-01-22 08:14 EST, Rahul Bhalerao
no flags Details | Diff
fixed ttf file (53.44 KB, application/x-font-ttf)
2008-01-22 08:17 EST, Rahul Bhalerao
no flags Details

  None (edit)
Description Ani Peter 2007-11-28 02:29:53 EST
Description of problem:

In lohit-malayalam font,  0D28  + 0D4D + 0D2A  (key 'V', key 'D', key 'H'  on 
malayalam inscript keyboard)  gives the conjunct  ' ന്പ ' . But instead of 0D28
(key 'V'), it  must be 0D2E  (key 'C'). Hence the correct combination is  0D2E +
0D4D + 0D2A   (type key 'C', key 'D', key 'H'  on  malayalam inscript
keyboard)which must give the conjunct ന്പ.

Version-Release number of selected component (if applicable):

How reproducible:

Always

Steps to Reproduce:

1.Open gedit/kedit.
2.Type unicode 0D28, 0D4D, 0D2A (or type key 'V', key 'D', key 'H' respectively
using Malayalam Inscript).
3.Result   is    ന്പ.
  
Actual results:

1.Open gedit/kedit.
2.Type unicodes  0D28, 0D4D, 0D2A (or type key 'V', key 'D', key 'H'
respectively using Malayalam Inscript).
3.Result   is    ന്പ.

Expected results:

1.Open gedit/kedit.
2.Type unicodes  0D2E, 0D4D, 0D2A (or type key 'C', key 'D', key 'H'
respectively using Malayalam Inscript).
3.Result  must be    ന്പ.

Additional info:
Comment 1 A S Alam 2007-12-13 05:23:48 EST
package:
fonts-malayalam-2.1.5-3.fc8
Comment 2 Ani Peter 2008-01-04 01:14:23 EST
Appreciate if you could let me know the status of this bug as this has to be
fixed immediately before next release.

This is a very basic but very critical bug and hence must be fixed urgently.

Thanks
Ani
Comment 3 Ani Peter 2008-01-10 04:24:27 EST
Created attachment 291250 [details]
Screen shot for the conjunct combination
Comment 4 Rahul Bhalerao 2008-01-22 08:14:48 EST
Created attachment 292506 [details]
patch for Lohit-Malayalam.sfd

This patch fixes the ligature rule in the .sfd file.
Comment 5 Rahul Bhalerao 2008-01-22 08:17:34 EST
Created attachment 292507 [details]
fixed ttf file

Ani, you may test this font file before I build it for fedora.
Comment 6 Ani Peter 2008-01-23 05:59:51 EST
Rahul,

This is working fine now. have test the attached new font

Thanks
Ani
Comment 7 Rahul Bhalerao 2008-01-23 13:15:23 EST
*** Bug 247452 has been marked as a duplicate of this bug. ***
Comment 8 Rahul Bhalerao 2008-01-25 07:03:57 EST
Fixed in lohit-fonts-malayalam-2.1.8-1.fc9.
Comment 9 Bug Zapper 2008-05-14 00:01:54 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Tony Fu 2008-09-09 23:16:31 EDT
requested by Jens Petersen (#27995)
Comment 11 Jens Petersen 2009-05-27 18:40:46 EDT
Closing - please reopen if there should still be any problem.

Note You need to log in before you can comment on or make changes to this bug.