Bug 402331 - [ml_IN] Wrong combinations used for conjunct 'ന്‍റ'
[ml_IN] Wrong combinations used for conjunct 'ന്‍റ'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lohit-fonts (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Rahul Bhalerao
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks: 431029
  Show dependency treegraph
 
Reported: 2007-11-28 02:40 EST by Ani Peter
Modified: 2016-07-31 21:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 18:40:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot for the conjunct combination (91.55 KB, image/png)
2008-01-10 04:20 EST, Ani Peter
no flags Details
patch for Lohit-Malayalam.sfd (687 bytes, patch)
2008-01-22 08:41 EST, Rahul Bhalerao
no flags Details | Diff
fixed ttf file (53.44 KB, application/x-font-ttf)
2008-01-22 08:43 EST, Rahul Bhalerao
no flags Details
Screenshot of the glyph of the conjunct (57.57 KB, image/png)
2008-01-23 06:22 EST, Ani Peter
no flags Details
patch for Lohit-Malayalam.sfd (441 bytes, patch)
2008-01-23 08:17 EST, Rahul Bhalerao
no flags Details | Diff
fixed ttf file (53.19 KB, application/x-font-ttf)
2008-01-23 08:17 EST, Rahul Bhalerao
no flags Details

  None (edit)
Description Ani Peter 2007-11-28 02:40:37 EST
Description of problem:

In lohit-malayalam font,  0D28 + 0D4D + 200D + 0D31 (key 'V', key 'D', key ']'
and  key ' shift J'  on  malayalam inscript keyboard)  gives the conjunct  ' 
ന്‍റ ' . But  the correct combination is  0D28 + 0D4D + 0D31   (type key 'V', key
'D'  and  key ' shift J'  on  malayalam inscript keyboard) which must give the
conjunct  ന്‍റ.

Version-Release number of selected component (if applicable):

How reproducible:

Always

Steps to Reproduce:

1.Open gedit/kedit.
2.Type unicode 0D28, 0D4D, 200D , 0D31(or  type  key 'V', key 'D', key ']' and 
key ' shift J'  respectively using Malayalam Inscript).
3.Result   is    ന്‍റ.
  
Actual results:

1.Open gedit/kedit.
2.Type unicode 0D28, 0D4D, 200D , 0D31(or  type  key 'V', key 'D', key ']' and 
key ' shift J'  respectively using Malayalam Inscript).
3.Result   is    ന്‍റ.

Expected results:

1.Open gedit/kedit.
2.Type unicodes  0D28 + 0D4D + 0D31  (or type key 'V', key 'D'  and  key ' shift
J'   respectively using Malayalam Inscript).
3.Result   must be    ന്‍റ.


Additional info:
Comment 1 A S Alam 2007-12-14 01:28:27 EST
fonts-malayalam-2.1.5-3.fc8
Comment 2 Ani Peter 2008-01-04 01:14:13 EST
Appreciate if you could let me know the status of this bug as this has to be
fixed immediately before next release.

This is a very basic but very critical bug and hence must be fixed urgently.

Thanks
Ani
Comment 3 Ani Peter 2008-01-04 01:14:42 EST
Appreciate if you could let me know the status of this bug as this has to be
fixed immediately before next release.

This is a very basic but very critical bug and hence must be fixed urgently.

Thanks
Ani
Comment 4 Rahul Bhalerao 2008-01-10 02:17:22 EST
Ani,this appears to be working fine in f8. Can you please confirm the problem?
Comment 5 Ani Peter 2008-01-10 04:20:25 EST
Created attachment 291249 [details]
Screen shot for the conjunct combination
Comment 6 Ani Peter 2008-01-22 03:20:43 EST
Rahul, we had a personal discussion on this bug last week. Is the issue clear
for you or do you still have any doubts?

Thanks
Ani
Comment 7 Rahul Bhalerao 2008-01-22 07:43:15 EST
Ani, thanks for the concern. The problem is absolutely clear to me. It also has
a relation the  other bug about chillaksharam right now.
Comment 8 Rahul Bhalerao 2008-01-22 08:41:54 EST
Created attachment 292509 [details]
patch for Lohit-Malayalam.sfd

This patch fixes the ligature rule in the .sfd file.
Comment 9 Rahul Bhalerao 2008-01-22 08:44:00 EST
Created attachment 292510 [details]
fixed ttf file

Ani, can you please test this font file before I build it for fedora?
Comment 10 Ani Peter 2008-01-23 06:10:11 EST
Rahul ,

I still find this is not fixed completely. Now the result is just the key
sequence when 0D28 + 0D4D +  0D31 is used.

Problem : 0D28 + 0D4D + 200D + 0D31 has to be used for getting the conjunct.

Expected result: 0D28 + 0D4D +  0D31 must give the desired conjunct.

Please have a look on the screenshot attached on Comment #5 

Let me know if any more queries.

Thanks
Ani
Comment 11 Ani Peter 2008-01-23 06:22:12 EST
Created attachment 292624 [details]
Screenshot of the glyph of the conjunct
Comment 12 Ani Peter 2008-01-23 06:23:47 EST
Rahul ,

I still find this is not fixed completely. Now the result is just the key
sequence when 0D28 + 0D4D +  0D31 is used.

Problem : 0D28 + 0D4D + 200D + 0D31 has to be used for getting the conjunct.

Expected result: 0D28 + 0D4D +  0D31 must give the desired conjunct.

Please have a look on the screenshot attached on Comment #5 

Let me know if any more queries.

Thanks
Ani
Comment 13 Ani Peter 2008-01-23 06:25:48 EST
Please ignore the comment #12 as its a repetition of comment #10. Instead please
have a look in the follwing:

Rahul,

One more thing I would like to mention is that, now as the chillu is not working
anywhere, currently 0D28 + 0D4D + 200D + 0D31 is also not giving the conjunct. I
have already showed you the glyph of the conjunct in the font file. have
attached the same as in comment #11

Thanks
Ani
Comment 14 Rahul Bhalerao 2008-01-23 08:08:06 EST
Ani, from the screenshot in comment #5 attached by you, I assume you do not want
the conjunct to be formed for 0D28 + 0D4D + 200D + 0D31?
Comment 15 Rahul Bhalerao 2008-01-23 08:17:00 EST
Created attachment 292633 [details]
patch for Lohit-Malayalam.sfd

This patch fixes the ligature rule in sfd file.
Comment 16 Rahul Bhalerao 2008-01-23 08:17:46 EST
Created attachment 292634 [details]
fixed ttf file

Ani, can you please test this font file now?
Comment 17 Ani Peter 2008-01-23 23:39:54 EST
Rahul,

Yes, its working fine. Good job.

Thanks
Ani
Comment 18 Rahul Bhalerao 2008-01-25 07:04:17 EST
Fixed in lohit-fonts-malayalam-2.1.8-1.fc9.
Comment 19 Bug Zapper 2008-05-14 00:02:10 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 20 Tony Fu 2008-09-09 23:16:35 EDT
requested by Jens Petersen (#27995)
Comment 21 Jens Petersen 2009-05-27 18:40:48 EDT
Closing - please reopen if there should still be any problem.

Note You need to log in before you can comment on or make changes to this bug.