Bug 431029 - [ml_IN] Wrong combinations used for conjunct 'ന്‍റ'
[ml_IN] Wrong combinations used for conjunct 'ന്‍റ'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: i18n
Depends On: 402331
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-31 04:01 EST by Ani Peter
Modified: 2016-07-31 21:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 03:23:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for 0D28 + 0D4D + 0D31 (special case) (62.34 KB, image/png)
2008-01-31 04:21 EST, Ani Peter
no flags Details

  None (edit)
Description Ani Peter 2008-01-31 04:01:04 EST
+++ This bug was initially created as a clone of Bug #402331 +++

Description of problem:

In lohit-malayalam font,  0D28 + 0D4D + 200D + 0D31 (key 'V', key 'D', key ']'
and  key ' shift J'  on  malayalam inscript keyboard)  gives the conjunct  ' 
ന്‍റ ' . But  the correct combination is  0D28 + 0D4D + 0D31   (type key 'V', key
'D'  and  key ' shift J'  on  malayalam inscript keyboard) which must give the
conjunct  ന്‍റ.

Version-Release number of selected component (if applicable):

How reproducible:

Always

Steps to Reproduce:

1.Open gedit/kedit.
2.Type unicode 0D28, 0D4D, 200D , 0D31(or  type  key 'V', key 'D', key ']' and 
key ' shift J'  respectively using Malayalam Inscript).
3.Result   is    ന്‍റ.
  
Actual results:

1.Open gedit/kedit.
2.Type unicode 0D28, 0D4D, 200D , 0D31(or  type  key 'V', key 'D', key ']' and 
key ' shift J'  respectively using Malayalam Inscript).
3.Result   is    ന്‍റ.

Expected results:

1.Open gedit/kedit.
2.Type unicodes  0D28 + 0D4D + 0D31  (or type key 'V', key 'D'  and  key ' shift
J'   respectively using Malayalam Inscript).
3.Result   must be    ന്‍റ.


Additional info:

-- Additional comment from aalam@redhat.com on 2007-12-14 01:28 EST --
fonts-malayalam-2.1.5-3.fc8

-- Additional comment from apeter@redhat.com on 2008-01-04 01:14 EST --
Appreciate if you could let me know the status of this bug as this has to be
fixed immediately before next release.

This is a very basic but very critical bug and hence must be fixed urgently.

Thanks
Ani

-- Additional comment from apeter@redhat.com on 2008-01-04 01:14 EST --
Appreciate if you could let me know the status of this bug as this has to be
fixed immediately before next release.

This is a very basic but very critical bug and hence must be fixed urgently.

Thanks
Ani

-- Additional comment from rbhalera@redhat.com on 2008-01-10 02:17 EST --
Ani,this appears to be working fine in f8. Can you please confirm the problem?

-- Additional comment from apeter@redhat.com on 2008-01-10 04:20 EST --
Created an attachment (id=291249)
Screen shot for the conjunct combination


-- Additional comment from apeter@redhat.com on 2008-01-22 03:20 EST --
Rahul, we had a personal discussion on this bug last week. Is the issue clear
for you or do you still have any doubts?

Thanks
Ani

-- Additional comment from rbhalera@redhat.com on 2008-01-22 07:43 EST --
Ani, thanks for the concern. The problem is absolutely clear to me. It also has
a relation the  other bug about chillaksharam right now.

-- Additional comment from rbhalera@redhat.com on 2008-01-22 08:41 EST --
Created an attachment (id=292509)
patch for Lohit-Malayalam.sfd

This patch fixes the ligature rule in the .sfd file.

-- Additional comment from rbhalera@redhat.com on 2008-01-22 08:44 EST --
Created an attachment (id=292510)
fixed ttf file

Ani, can you please test this font file before I build it for fedora?

-- Additional comment from apeter@redhat.com on 2008-01-23 06:10 EST --
Rahul ,

I still find this is not fixed completely. Now the result is just the key
sequence when 0D28 + 0D4D +  0D31 is used.

Problem : 0D28 + 0D4D + 200D + 0D31 has to be used for getting the conjunct.

Expected result: 0D28 + 0D4D +  0D31 must give the desired conjunct.

Please have a look on the screenshot attached on Comment #5 

Let me know if any more queries.

Thanks
Ani


-- Additional comment from apeter@redhat.com on 2008-01-23 06:22 EST --
Created an attachment (id=292624)
Screenshot of the glyph of the conjunct


-- Additional comment from apeter@redhat.com on 2008-01-23 06:23 EST --
Rahul ,

I still find this is not fixed completely. Now the result is just the key
sequence when 0D28 + 0D4D +  0D31 is used.

Problem : 0D28 + 0D4D + 200D + 0D31 has to be used for getting the conjunct.

Expected result: 0D28 + 0D4D +  0D31 must give the desired conjunct.

Please have a look on the screenshot attached on Comment #5 

Let me know if any more queries.

Thanks
Ani

-- Additional comment from apeter@redhat.com on 2008-01-23 06:25 EST --
Please ignore the comment #12 as its a repetition of comment #10. Instead please
have a look in the follwing:

Rahul,

One more thing I would like to mention is that, now as the chillu is not working
anywhere, currently 0D28 + 0D4D + 200D + 0D31 is also not giving the conjunct. I
have already showed you the glyph of the conjunct in the font file. have
attached the same as in comment #11

Thanks
Ani

-- Additional comment from rbhalera@redhat.com on 2008-01-23 08:08 EST --
Ani, from the screenshot in comment #5 attached by you, I assume you do not want
the conjunct to be formed for 0D28 + 0D4D + 200D + 0D31?

-- Additional comment from rbhalera@redhat.com on 2008-01-23 08:17 EST --
Created an attachment (id=292633)
patch for Lohit-Malayalam.sfd

This patch fixes the ligature rule in sfd file.

-- Additional comment from rbhalera@redhat.com on 2008-01-23 08:17 EST --
Created an attachment (id=292634)
fixed ttf file

Ani, can you please test this font file now?

-- Additional comment from apeter@redhat.com on 2008-01-23 23:39 EST --
Rahul,

Yes, its working fine. Good job.

Thanks
Ani

-- Additional comment from rbhalera@redhat.com on 2008-01-25 07:04 EST --
Fixed in lohit-fonts-malayalam-2.1.8-1.fc9.
Comment 1 Ani Peter 2008-01-31 04:20:47 EST
Hi Caolon,

This is a special case where 0D28 + 0D4D + 0D31 gives a special glpyh. Have
included this in test case too. Will provide you the test case number once its
available on batsman. screenshot attached.

Currently, this is fixed in pango, fonts-malayalam and working perfect with gedit.

Thanks
Ani
Comment 2 Ani Peter 2008-01-31 04:21:53 EST
Created attachment 293558 [details]
Screenshot for 0D28 + 0D4D + 0D31 (special case)
Comment 3 Rahul Bhalerao 2008-01-31 05:03:30 EST
Caolon,

I believe this is not an ICU bug. The bug was fixed in font (#402331) and no
modifications in pango were required to make it work on pango. So I guess there
should not be any modifications in ICU as well. If at all the same font is not
working on ICU, I think its because of the special issue of 0x0D31, which is
fixed in pango and filed for ICU on #424661.
Thanks.
Comment 5 Caolan McNamara 2008-01-31 10:32:51 EST
Reverted the hack that we had in place in icu to get the original results for
the rest of the something + 0d4d + 0d31 ones that have now been changed. So
should be good in icu-3.8.1-4.fc9. 

The same hack for the something + 0d4d + 0d30 test-cases to get the right
results remains, which does sort of me dubious about the hack in icu as pango
remains "broken" on those test-cases.
Comment 6 Ani Peter 2008-02-04 01:09:40 EST
Hi Caolon,

Working perfect in icu-3.8.1-4.fc9. Tested and confirmed.

Thanks
Ani
Comment 7 Ani Peter 2008-02-04 01:11:17 EST
oops.. my apologies for writing your name wrong Caolan.

Best regards
Ani
Comment 8 Caolan McNamara 2008-02-04 03:23:45 EST
sounds good

Note You need to log in before you can comment on or make changes to this bug.