This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 402551 - ps2pdf exit with /invalidfileaccess error
ps2pdf exit with /invalidfileaccess error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 402691 (view as bug list)
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-11-28 06:31 EST by CHIKAMA Masaki
Modified: 2007-12-20 14:52 EST (History)
1 user (show)

See Also:
Fixed In Version: 8.61-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 14:52:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description CHIKAMA Masaki 2007-11-28 06:31:05 EST
Description of problem:
The cidfmap provided by fonts-japanese has an absolute path to
TrueType font. (/usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf etc)
But the directory /usr/share/fonts/sazanami-fonts-mincho/ is not
one of permitted directory. This leads p2spdf to find 
sazanami-mincho.ttf failaure.

Version-Release number of selected component (if applicable):
ghostscript-8.60-5.fc8, but currently can't reproduce because of 
Bug #402481 and Bug #402501


How reproducible:
always

Steps to Reproduce:
1. ps2pdf test-euc.ps 
(please pickup test-euc.ps from here 
https://bugzilla.redhat.com/attachment.cgi?id=116741)
2.
3.
  
Actual results:
Exit with this error.

Error: /invalidfileaccess in /findfont
Operand stack:
   GothicBBB-Medium-EUC-H
Execution stack:

Expected results:
produce test-euc.pdf

Additional info:
Here is Workaround.

GS_LIB=/usr/share/fonts/sazanami-fonts-gothic:/usr/share/fonts/sazanami-fonts-mincho
 ps2pdf test-euc.ps
Comment 1 CHIKAMA Masaki 2007-11-28 07:18:22 EST
Proper workaround.
ps2pdf -dNOSAFER test-euc.ps
Comment 2 Tim Waugh 2007-11-28 08:20:54 EST
Or alternatively, perhaps ghostscript could be compiled with /usr/share/fonts in
the fontpath.
Comment 3 Fedora Update System 2007-11-28 20:32:19 EST
ghostscript-8.61-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'
Comment 4 CHIKAMA Masaki 2007-11-29 05:48:13 EST
Thank you. 
With ghostscript-8.61-1.fc8, ps2pdf works without -dNOSAFER.

Please close this bug.
Comment 5 Akira TAGOH 2007-11-29 06:34:53 EST
*** Bug 402691 has been marked as a duplicate of this bug. ***
Comment 6 Hans de Goede 2007-11-29 16:52:38 EST
I'm seeing this too, when building libtheora for -devel, as libtheora's docs
building uses ghostscript, see:
http://koji.fedoraproject.org/koji/getfile?taskID=266202&name=build.log
Comment 7 CHIKAMA Masaki 2007-11-29 21:09:16 EST
(In reply to comment #6)
> I'm seeing this too, when building libtheora for -devel, as libtheora's docs
> building uses ghostscript, see:
> http://koji.fedoraproject.org/koji/getfile?taskID=266202&name=build.log

Now cidfmap reads cidfmap.{ja|ko|zn_CN|zn_TW}.
So you have to install fonts-japanese, fonts-korean, fonts-chineses
to execute gs. Fedora8 installs them by default, but It's not good to 
force to install them for building packages. I don't have good idea.
Comment 8 Hans de Goede 2007-11-30 03:25:12 EST
(In reply to comment #7)
> Now cidfmap reads cidfmap.{ja|ko|zn_CN|zn_TW}.
> So you have to install fonts-japanese, fonts-korean, fonts-chineses
> to execute gs. Fedora8 installs them by default, but It's not good to 
> force to install them for building packages. I don't have good idea.

Nasty, I'll just add BuildRequires on those font packages as a workaround for
now. Let me know when I can remove them again.
Comment 9 Tim Waugh 2007-11-30 07:06:01 EST
This should be fixed in rawhide now (ghostscript-6.51-5.fc9).
Comment 10 Tim Waugh 2007-11-30 07:06:16 EST
Er.. 8.61-5.fc9
Comment 11 Hans de Goede 2007-11-30 07:26:43 EST
Ok,

I'll fire another libtheora build (without requires on the font packages) when
I'm back home (and have access to my private-key / ssl certificates).

I'll let you know how that goes.

Comment 12 Hans de Goede 2007-11-30 15:21:50 EST
libtheora (without any additional BuildRequires) builds fine now.
Comment 13 Fedora Update System 2007-12-03 06:38:31 EST
ghostscript-8.61-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'
Comment 14 Fedora Update System 2007-12-12 14:52:30 EST
ghostscript-8.61-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'
Comment 15 Fedora Update System 2007-12-15 12:49:16 EST
ghostscript-8.61-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ghostscript'
Comment 16 Fedora Update System 2007-12-20 14:52:52 EST
ghostscript-8.61-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.