Bug 402691 - Directory of sazanami font in cidfmap.ja is not permiited path by ghostscript CID font substitiotion
Directory of sazanami font in cidfmap.ja is not permiited path by ghostscript...
Status: CLOSED DUPLICATE of bug 402551
Product: Fedora
Classification: Fedora
Component: fonts-japanese (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 08:29 EST by CHIKAMA Masaki
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 06:34:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description CHIKAMA Masaki 2007-11-28 08:29:49 EST
Description of problem:
The fonts-japanese provides cidfmap.ja. It contains below.

/usr/share/fonts/sazanami-fonts-gothic/sazanami-gothic.ttf
/usr/share/fonts/sazanami-fonts-mincho/sazanami-mincho.ttf

But if using -dSAFER, the directory containing the font file must
be on one of the permitted paths.

Niether /usr/share/fonts/sazanami-fonts-gothic/ nor
/usr/share/fonts/sazanami-fonts-mincho is permitted path.

This cause BUG #402551. (ps2pdf doesn't work)
I don't know which should fix it.

Version-Release number of selected component (if applicable):
fonts-japanese-0.20061016-12.fc8
Comment 1 CHIKAMA Masaki 2007-11-28 08:31:57 EST
Sorry. Missing information.
>But if using -dSAFER,
This is for ghostscript argument.
Comment 2 Akira TAGOH 2007-11-28 19:37:22 EST
Since you've been filing a bug against fonts-japanese, what do you suggest to
get this fixed then?
Comment 3 CHIKAMA Masaki 2007-11-28 20:02:14 EST
I thought there was some more generic way to handle CID font substitution.
Becase there will come soon VLgothic font and replace default gothic font.  

This bug was handled and fixed by ghostscript package.
Please close this bug.
Comment 4 Akira TAGOH 2007-11-29 06:34:52 EST

*** This bug has been marked as a duplicate of 402551 ***

Note You need to log in before you can comment on or make changes to this bug.