Bug 402591 - ruby-gnome2 (gtkmozembed) doesn't compile with xulrunner (gecko-libs 1.9)
ruby-gnome2 (gtkmozembed) doesn't compile with xulrunner (gecko-libs 1.9)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ruby-gnome2 (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Allisson Azevedo
Fedora Extras Quality Assurance
:
: 408361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 07:41 EST by Martin Stransky
Modified: 2008-12-11 22:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-11 22:44:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a minimal patch, doesn't compile yet (2.84 KB, patch)
2007-11-28 07:41 EST, Martin Stransky
no flags Details | Diff

  None (edit)
Description Martin Stransky 2007-11-28 07:41:43 EST
Description of problem:

I've tried to build $SUBJ against xulrunner (gecko-libs 1.9) but w/o success.
(see http://fedoraproject.org/wiki/Releases/FeatureXULRunner).

I created some minimal patch (attached below) but the package uses some function
what are not exported from the latest gecko-libs (1.9):

/* enum types */
#define GTK_TYPE_MOZ_EMBED_PROGRESS_FLAGS \
             (gtk_moz_embed_progress_flags_get_type())
#define GTK_TYPE_MOZ_EMBED_STATUS_ENUMS \
             (gtk_moz_embed_status_enums_get_type())
#define GTK_TYPE_MOZ_EMBED_RELOAD_FLAGS \
             (gtk_moz_embed_reload_flags_get_type())
#define GTK_TYPE_MOZ_EMBED_CHROME_FLAGS \
             (gtk_moz_embed_chrome_flags_get_type())

GtkType      gtk_moz_embed_progress_flags_get_type (void);
GtkType      gtk_moz_embed_status_enums_get_type (void);
GtkType      gtk_moz_embed_reload_flags_get_type (void);
GtkType      gtk_moz_embed_chrome_flags_get_type (void);

I can hardly imagine if it's a bug or feature and if we need to add them to the
latest gecko or if there's any other way.

(Anyway, there's an another api change, gtk_moz_embed_set_path is used now
instead of the old gtk_moz_embed_set_comp_path)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Martin Stransky 2007-11-28 07:41:43 EST
Created attachment 271221 [details]
a minimal patch, doesn't compile yet
Comment 2 Alex Lancaster 2007-12-03 02:47:17 EST
*** Bug 408361 has been marked as a duplicate of this bug. ***
Comment 3 Alex Lancaster 2007-12-03 02:49:04 EST
From bug #408361, here is what I currently get on a koji rebuild:

ruby-gnome2 doesn't rebuild against the latest xulrunner in rawhide:
1.9-0.beta1.3.fc9.
This is the error:

xulrunner-gtkmozembed is found.
checking for gtk+-2.0... yes
checking for xulrunner-gtkmozembed... yes
checking for G_PLATFORM_WIN32... no
checking for main() in -lgtkembedmoz... no
*** .././gtkmozembed/extconf.rb failed ***

Task list and build.log here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=270823
http://koji.fedoraproject.org/koji/getfile?taskID=270823&name=build.log

Comment 4 Martin Stransky 2007-12-03 03:19:36 EST
You have to use the attached minimal patch. gtkembedmoz.so is no more provided
by xulrunner, link against xul.so.
Comment 5 Alex Lancaster 2007-12-28 02:51:53 EST
Attempted to apply patch to rawhide spec, still have problems (as would probably
be expected if patch is incomplete, but reporting anyway) some of which may not
be xulrunner-related:

http://koji.fedoraproject.org/koji/taskinfo?taskID=311898
Comment 8 Mamoru TASAKA 2008-01-17 11:13:51 EST
The newest ruby-gnome2 again doesn't build with newest xulrunner...

When will xulrunner get frozen?
Comment 9 Mamoru TASAKA 2008-01-17 12:54:03 EST
Well, fixed by adding BR: gecko-devel-unstable.
Comment 10 Bug Zapper 2008-05-14 00:02:28 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.