Bug 4026 - comsat does not operate properly
comsat does not operate properly
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: biff (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
: 4974 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-14 06:06 EDT by mdharm
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-08 10:14:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mdharm 1999-07-14 06:06:00 EDT
The version of comsat shipped with RedHat 6.0 was compiled
on a system with a different #define for _PATH_MAILDIR --
the shipped version was compiled with "/var/mail" when it
should be "/var/spool/mail".

Downloading the src.rpm and recompiling will fix that
problem.

Also, this version of comsat needs to be patched to allow
for the new devpts filesystem.  The patch is as follows
(this may need reformatting after the cut/paste):

--- comsat.c.orig       Mon May 19 18:37:50 1997
+++ comsat.c    Wed Jul 14 02:59:20 1999
@@ -203,15 +203,6 @@

        snprintf(tty, sizeof(tty), "%s%s", _PATH_DEV, line);

-       /*
-        * Um. This will barf on any scheme involving ttys
in subdirectories.
-        */
-       if (strchr(line, '/')) {
-               /* A slash is an attempt to break
security... */
-               syslog(LOG_AUTH | LOG_NOTICE, "'/' in \"%
s\"", tty);
-               return;
-       }
-
        if (stat(tty, &stb) || !(stb.st_mode & S_IEXEC)) {
                dsyslog(LOG_DEBUG, "%s: wrong mode on %s",
name, tty);
                return;
Comment 1 Jeff Johnson 1999-07-28 11:27:59 EDT
Fixed in comsat-0.10-23. Thanks for the patch.
Comment 2 Stepan Kasal 1999-09-08 04:08:59 EDT
The /dev/pts fix (as found in rawride) may not work (even for you).
And if it worked it would allow terminals like pts/../../etc/passwd
which may hurt the system a bit ;-)
I'm going to mail a patch.
Comment 3 Stepan Kasal 1999-09-08 04:23:59 EDT
The /dev/pts fix (as found in rawride) may not work (even for you).
And if it worked it would allow terminals like pts/../../etc/passwd
which may hurt the system a bit ;-)
I'm going to mail a patch.
Comment 4 Stepan Kasal 1999-09-08 04:35:59 EDT
The <A
HREF="http://developer.redhat.com/bugzilla/data/maildir/4026/1">mail</
A> I've sent
contains a patch to be applied to the _rawhide_ version of SRPM.
Comment 5 Jeff Johnson 1999-09-08 08:03:59 EDT
*** Bug 4974 has been marked as a duplicate of this bug. ***

I'd like to re-open bug #4026 but don't know how to do it.
Thus I send a new bug report.
I downloaded the rawhide version -- it doesn't work.
If it worked it'd be insecure.
Comment 6 Stepan Kasal 1999-09-08 09:32:59 EDT
So quick!  GREAT!!!     And thank you for your work!
Comment 7 Jeff Johnson 1999-09-08 10:14:59 EDT
Fixed in comsat-0.15-1. Thanks for noticing!

Note You need to log in before you can comment on or make changes to this bug.