Bug 402991 - yum metadata groupupdate checksum broken
Summary: yum metadata groupupdate checksum broken
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 8
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 345051 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-28 15:30 UTC by Trevor Cordes
Modified: 2014-01-21 23:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 15:39:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Trevor Cordes 2007-11-28 15:30:34 UTC
Description of problem:
Something broke the F8 groupupdate yum checksums.  Can't yum groupupdate Base on
any F8 box.  I tried all the steps google suggest for this error.  This bug has
been reproduced on 3 boxes, one of which ran groupupdate ok just the other day.

Version-Release number of selected component (if applicable):
yum-3.2.7-1.fc8

How reproducible:
always, 3 boxes tested so far

Steps to Reproduce:
1. yum clean all
2. yum groupupdate Base
3.
  
Actual results:
Loading mirror speeds from cached hostfile
comps-f8.xml              100% |=========================| 1.2 MB    00:01     
http://www.muug.mb.ca/pub/fedora/linux/updates/8/i386/repodata/comps-f8.xml:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
comps-f8.xml              100% |=========================| 1.2 MB    00:01     
http://mirrors.reflected.net/fedora/linux/updates/8/i386/repodata/comps-f8.xml:
[Errno -1] Metadata file does not match checksum
Trying other mirror.
comps-f8.xml              100% |=========================| 1.2 MB    00:01     
http://gulus.usherbrooke.ca/pub/distro/fedora/linux/updates/8/i386/repodata/comps-f8.xml:
[Errno -1] Metadata file does not match checksum
Trying other mirror.

Expected results:
yum should update without checksum errors

Additional info:
yum update appears to run fine, it's just the groupupdate that fails.  Tried
with and without yum-fastestmirror.  Tried clearing all proxy caches.  Tried
flushing data/metadata many times.

Comment 1 Jesse Keating 2007-11-28 15:39:54 UTC
THere was a corrupted comps file in the repo.  This was corrected yesterday, if
your mirror is up to date you should no longer be seeing this issue.

Comment 2 Seth Vidal 2007-12-07 03:36:05 UTC
*** Bug 345051 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.