Bug 403381 - 'NoneType' object has no attribute 'gridWrappedWindow' when attempting to save an exception log in text mode
'NoneType' object has no attribute 'gridWrappedWindow' when attempting to sav...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-28 14:37 EST by Lubomir Kundrak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 17:02:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubomir Kundrak 2007-11-28 14:37:31 EST
The following happens when I try to save an exception log in text mode:

+++ This bug was initially created as a clone of Bug #396851 +++

...

The output is so ugly, because I was unable to save an exception log, as the
following happened when I hit 'Save:'

              Traceback (most recent call last):                                
  File "/usr/bin/anaconda", line 945, in <module>elects   |  <F12> next screen
    handleException(anaconda, sys.exc_info())
  File "/usr/lib/anaconda/exception.py", line 445, in handleException
    runSaveDialog(anaconda, "/tmp/anacdump.txt")
  File "/usr/lib/anaconda/exception.py", line 329, in runSaveDialog
    saveWin.run()
  File "/usr/lib/anaconda/text.py", line 229, in run
    result = toplevel.run()
  File "/usr/lib/python2.5/site-packages/snack.py", line 666, in run
    self.create(x, y)
  File "/usr/lib/python2.5/site-packages/snack.py", line 662, in create
    self.screen.gridWrappedWindow(self, self.title, x, y)
AttributeError: 'NoneType' object has no attribute 'gridWrappedWindow'
install exited abnormally [1/1]

-- Additional comment from clumens@redhat.com on 2007-11-28 13:33 EST --
This should be fixed in the next build of anaconda.  Please file the bug about
the exception dialog in text mode separately.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.