Bug 403861 - Firefox should offer icedtea-plugin installation
Firefox should offer icedtea-plugin installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-11-28 23:57 EST by petrosyan
Modified: 2008-02-15 08:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 22:39:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Firefox plugin finder service. (18.80 KB, image/png)
2007-11-28 23:57 EST, petrosyan
no flags Details
failure to install icedtea plugin (15.92 KB, image/png)
2008-01-26 13:20 EST, petrosyan
no flags Details

  None (edit)
Description petrosyan 2007-11-28 23:57:30 EST
Description of problem:
After installing Fedora 8 from live media java plugin is not installed by
default. Firefox plugin finder service fails to find a java plugin but presents
a "Manual Installation" link which takes you to
http://java.com/en/download/index.jsp and offers to install non-open source Sun
Java 6 run time environment. Instead Firefox should install
java-1.7.0-icedtea-plugin from Fedora's yum repository.

Version-Release number of selected component (if applicable):
firefox-2.0.0.9-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 8 from live media.
2. Go to a site with java plugin.
3. Click on "Install Missing Plugins..."
  
Actual results:
Firefox fails to find java plugins and suggest one to install Sun's non-open
source Java 6 plugin.

Expected results:
Firefox should find the latest java-1.7 icedtea java plugin from Fedora's
repository and offer to install it.
Comment 1 petrosyan 2007-11-28 23:57:30 EST
Created attachment 272171 [details]
Firefox plugin finder service.
Comment 2 petrosyan 2008-01-26 13:19:41 EST
this bug is still present in firefox-3.0-0.beta2.12.nightly20080121.fc9.i386
Comment 3 petrosyan 2008-01-26 13:20:33 EST
Created attachment 293060 [details]
failure to install icedtea plugin
Comment 4 Christopher Aillon 2008-02-14 22:39:17 EST
The icedtea plugin really should simply be installed by default.... While that's
not exactly what this bug is about, it is going to have to do until Fedora
implements its own plugin finding service (which needs to be done on our
website, not in firefox the package).

Matej: please make sure a bug is filed to get icedtea's plugin installed by
default it isn't.

Also file a generic bug about implementing our own plugin finder service and
mark this dependent on it.

This isn't going to happen for F8 or F9 though, and any real solution would have
to be more generic, so marking this WONTFIX and matej will post two other bugs
soon: 1 will resolve this for the short term, and the other for the longer term.
Comment 5 Matěj Cepl 2008-02-15 08:25:12 EST
(In reply to comment #4)
> Matej: please make sure a bug is filed to get icedtea's plugin installed by
> default it isn't.

bug 432951
 
> Also file a generic bug about implementing our own plugin finder service and
> mark this dependent on it.

bug 432957 and there seems to be many pronouns in your sentence, so I am not
sure which bug you want to make dependent on which.

Note You need to log in before you can comment on or make changes to this bug.