Bug 432951 - install java-1.7.0-icedtea-plugin per default
install java-1.7.0-icedtea-plugin per default
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 07:11 EST by Matěj Cepl
Modified: 2014-01-21 18:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-13 07:55:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2008-02-15 07:11:20 EST
Description of problem:
See bug 403861 comment 4 -- could we get java*icedtea-plugin whenever we have
firefox installed, please?

Steps to Reproduce:
1.install Fedora and select group containing firefox
2.
3.
  
Actual results:
Java applets don't work and we are not able to install well java out of the web

Expected results:
Java applet should just work

Additional info:
Comment 1 Bill Nottingham 2008-02-15 10:42:24 EST
Thomas - opinions?
Comment 2 Thomas Fitzsimmons 2008-02-15 11:13:46 EST
The plugin is installed by default in a Fedora 8 install.  Here's the relevant
section of comps-f8.xml.in:

  <group>
    <id>java</id>
    <_name>Java</_name>
    <_description>Support for running programs written in the Java programming
language.</_description>
    <default>true</default>
    <uservisible>false</uservisible>
    <packagelist>
      <packagereq type="mandatory">java-1.5.0-gcj</packagereq>
      <packagereq type="mandatory">libgcj</packagereq>
      <packagereq type="default">java-1.7.0-icedtea</packagereq>
      <packagereq type="default">java-1.7.0-icedtea-plugin</packagereq>
    </packagelist>
  </group>

We tested this during the Fedora 8 cycle to be sure the plugin was installed by
default.  We didn't test the Live Media installation scenario though.  Do Live
Media spins use the same comps.xml?
Comment 3 Jeremy Katz 2008-02-15 11:54:43 EST
Same comps file, but we don't install the java group due to space constraints. 
If we want to add it, we have to find a corresponding amount of stuff to remove.
Comment 4 Sergio Monteiro Basto 2008-05-01 01:00:03 EDT
IMO, what mcepl@redhat.com means, is install RPM of java-1.7.0-icedtea-plugin,
don't install by itself Java Plugin in firefox , 
Instead we have a README file.
/usr/share/doc/java-1.7.0-icedtea-plugin-1.7.0.0/README.plugin

IMHO , it should install automatically  
Comment 5 Thomas Fitzsimmons 2008-05-01 11:28:58 EDT
java-1.6.0-openjdk-plugin and java-1.6.0-openjdk are installed by default on the
Fedora 9 DVD.  I wish the same were true for the LiveCD since I consider the
Java plugin an important component of a base desktop system.

Only those two packages would be needed -- 30MB in total.  Where is the list of
LiveCD groups that do get installed?  I'd like to find some corresponding stuff
to remove.
Comment 6 Bug Zapper 2008-05-14 01:13:04 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jeremy Katz 2008-06-11 11:56:58 EDT
LiveCD kickstart configs can be grabbed from livecd-tools git
  git clone git://git.fedorahosted.org/git/livecd

And then see under configs/.  I really don't see anything obvious that could be
removed to be able to add another 30 megs of stuff though
Comment 8 Bill Nottingham 2008-09-10 18:33:21 EDT
Reassigning.
Comment 9 Jeroen van Meeuwen 2008-10-13 07:55:24 EDT
Can't fix without a decision on what to remove from the Live Media in favour of icedtea. Please reopen if you see something eligible for deletion worth at least 30M in the kickstarts at

http://git.fedorahosted.org/git/spin-kickstarts.git

Note You need to log in before you can comment on or make changes to this bug.