Bug 404251 - Directory /sys/module/nousb/parameters has entry with zero-length name
Directory /sys/module/nousb/parameters has entry with zero-length name
Status: CLOSED DUPLICATE of bug 367351
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 06:17 EST by Dmitry Antipov
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 09:48:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry Antipov 2007-11-29 06:17:11 EST
Being sure that sysfs is mounted, go to /sys/module/nousb/parameters and run the
following program from it:

#include <stdio.h>
#include <string.h>
#include <dirent.h>

int main (int argc, char *argv[])
{
  DIR *d;
  struct dirent *dp;

  d = opendir (".");
  while ((dp = readdir (d)))
    printf ("'%s' %d\n", dp->d_name, strlen (dp->d_name));
  closedir (d);
  
  return 0;
}

The output is:

'.' 1
'..' 2
'' 0

The output of 'ls -lai' is:

ls: cannot access : No such file or directory
total 0
164 -????????? ? ?    ?    ?            ? 
163 drwxr-xr-x 2 root root 0 Nov 28 21:10 .
162 drwxr-xr-x 3 root root 0 Nov 28 21:10 ..

It looks like  /sys/module/nousb/parameters  contains invalid inode, which is
probably a bug somewhere in sysfs.

It was observed by running updatedb with default /etc/updatedb.conf - if /sys is
not in PRUNEPATHS, updatedb aborts with the message

updatedb: src/updatedb.c:730: scan_cwd: Assertion `name_size > 1' failed.
Comment 1 Chuck Ebbert 2007-11-29 09:48:11 EST

*** This bug has been marked as a duplicate of 367351 ***

Note You need to log in before you can comment on or make changes to this bug.