Bug 404271 - Galeon doesn't compile with XULRunner (gecko-libs 1.9)
Galeon doesn't compile with XULRunner (gecko-libs 1.9)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
: 434058 (view as bug list)
Depends On:
Blocks: gcc43rebuildfail
  Show dependency treegraph
 
Reported: 2007-11-29 06:33 EST by Martin Stransky
Modified: 2013-01-09 23:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-05 09:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firts minimal patch (40.72 KB, patch)
2007-12-03 10:11 EST, Martin Stransky
no flags Details | Diff

  None (edit)
Description Martin Stransky 2007-11-29 06:33:30 EST
Description of problem:

Galeon fails to compile against XUL Runner (gecko-libs 1.9).

XULRunner will be a gecko-lib provider in Fedora 9 (instead of Firefox) and all
gecko-based applications should use it. (see
http://fedoraproject.org/wiki/Releases/FeatureXULRunner)
Comment 1 Denis Leroy 2007-11-29 10:48:51 EST
Upstream (Philip Langdale) promised to take a crack at it :-)
Comment 2 Martin Stransky 2007-11-29 10:57:31 EST
That's great. I'm juts trying compile it at least but the patch is ~ 30KB big
and still growing :)
Comment 3 Denis Leroy 2007-12-03 05:31:19 EST
From Philip Langdale:

"1.9 is still [not usable] as far as I can tell. You can't
write a password manager without hacking the mozilla build to export
the nsIPassword interface. There are some misc small problems (and
apparently a whole set of NSS dialogs has disappeared) but the
big one is a change in how the string classes are exported. I'm not
sure how to tackle that just yet."

So don't throw away your 30K patch just yet :-)
Comment 4 Martin Stransky 2007-12-03 05:41:40 EST
> "1.9 is still [not usable] as far as I can tell. You can't
> write a password manager without hacking the mozilla build to export
> the nsIPassword interface. 

Yes, that's right, fedora xulrunner doesn't export it now.

> There are some misc small problems (and
> apparently a whole set of NSS dialogs has disappeared)

It looks like the NSS dialogs are still present but the callback structure has
been changed. Could be related to nss 3.12, I hope it will be fixed with the
stable nss version.

> but the
> big one is a change in how the string classes are exported. I'm not
> sure how to tackle that just yet."

This is relative small problem. Strings are quite well documented at
http://developer.mozilla.org/en/docs/Migrating_from_Internal_Linkage_to_Frozen_Linkage

and the biggest problem I hit is missing nsEscape.h.
Comment 5 Martin Stransky 2007-12-03 10:11:42 EST
Created attachment 275751 [details]
firts minimal patch

With this patch, galeon compiles and runs (at web pages are loaded and rendered
:)) Some parts need to be polished / updated but I think it's a good start.
Comment 6 Alex Lancaster 2008-02-19 04:29:58 EST
galeon now fails to rebuild against recent xulrunner:

http://koji.fedoraproject.org/koji/taskinfo?taskID=440902

I tried update the BuildRequires: gecko-devel -> gecko-devel-unstable as per
epiphany package, but that appears to not be sufficient.

The list of xulrunner packages that have slipped back into the "failed rebuild"
in http://fedoraproject.org/wiki/Releases/FeatureXULRunner since
December/January is alarming.
Comment 7 Matěj Cepl 2008-02-28 10:56:58 EST
I don't know whether this bug should be assigned to the current assignee or
reporter ;-), but certainly there is nothing to bug triage here.
Comment 8 Denis Leroy 2008-02-28 11:27:39 EST
I won't have time to work on this for at least another week unfortunately, and
even that my experience with Mozilla code is limited...
Comment 9 Martin Stransky 2008-02-28 12:12:00 EST
*** Bug 434058 has been marked as a duplicate of this bug. ***
Comment 10 Jan ONDREJ 2008-03-14 17:00:21 EDT
Same problem after upgrading to galeon-2.0.5. :(
Comment 11 Denis Leroy 2008-04-05 09:05:59 EDT
I updated the patch for 2.0.5, it now compiles on F-9.

However, galeon is still completely unusable for me: all fonts have gigantic
sizes and images appear distorted, much the same as epiphany. I'll do some BZ
research before opening another bug.
Comment 12 Denis Leroy 2008-04-08 17:19:22 EDT
For the record: the font size problem is a virtual machine related problem,
where the VM doesn't report the screen physical size properly. Unfortunately
about:config is broken so it's hard to fix galeon's behavior in that scenario.

On a non-VM system, galeon works good! There are still some glitches, but
reasonably minor things that will get ironed out over time.

Note You need to log in before you can comment on or make changes to this bug.