Bug 404691 - Anaconda loader received SIGABRT when after network was configured
Anaconda loader received SIGABRT when after network was configured
Status: CLOSED DUPLICATE of bug 378641
Product: Fedora
Classification: Fedora
Component: libdhcp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-29 11:56 EST by Lubomir Kundrak
Modified: 2008-01-03 23:17 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 23:17:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tty3 (21.91 KB, image/png)
2007-11-29 11:58 EST, Lubomir Kundrak
no flags Details

  None (edit)
Description Lubomir Kundrak 2007-11-29 11:56:10 EST
Description of problem:

loader received SIGABRT!  Backtrace:                                           
[0x401ade]
[0x5251a0]
[0x5843e5]
[0x525880]
[0x53ede5]
[0x53e5e4]
[0x56e63d]
[0x471b09]
[0x4734ea]
[0x469e21]
[0x471526]
[0x4187e1]
[0x41aaf2]
[0x41b95b]
[0x41ff93]
[0x40383d]
[0x516ce9]
[0x4001e9]
install exited abnormally [1/1] 

Version-Release number of selected component (if applicable):

anaconda-11.4.0.3

Booted from this image in QEMU/KVM:

http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/images/boot.iso
from 29-Nov-2007 06:18 (9.7M), (24baacfb3e4a9bf93123572f99907db9).

Steps to Reproduce:

Boot off the CD, get to IP configuration step either by choosi some network
installation method or adding "telnet" to command line, etc.

Additional info:

Screenshots of other consoles will follow.
Comment 1 Lubomir Kundrak 2007-11-29 11:58:31 EST
Created attachment 273061 [details]
tty3
Comment 2 Chris Lumens 2007-11-29 14:33:24 EST
For my future reference:

0x401ade        /usr/src/debug/anaconda-11.4.0.3/loader2/loader.c:1456
0x5251a0        /usr/src/debug/anaconda-11.4.0.3/stubs/unicode-lite.c:28
0x5843e5        /usr/src/debug/anaconda-11.4.0.3/stubs/unicode-lite.c:28
0x525880        /usr/src/debug/anaconda-11.4.0.3/stubs/unicode-lite.c:28
0x53ede5        /usr/src/debug/anaconda-11.4.0.3/stubs/unicode-lite.c:28
0x53e5e4        /usr/src/debug/anaconda-11.4.0.3/stubs/unicode-lite.c:28
0x56e63d        /usr/src/debug/anaconda-11.4.0.3/stubs/unicode-lite.c:28
0x471b09        ??:0
0x4734ea        ??:0
0x469e21        ??:0
0x471526        ??:0
0x4187e1        /usr/src/debug/anaconda-11.4.0.3/loader2/net.c:1397
0x41aaf2        /usr/src/debug/anaconda-11.4.0.3/loader2/net.c:590
0x41b95b        /usr/src/debug/anaconda-11.4.0.3/loader2/net.c:1931
0x41ff93        /usr/src/debug/anaconda-11.4.0.3/loader2/telnetd.c:238
0x40383d        /usr/src/debug/anaconda-11.4.0.3/loader2/loader.c:1708
0x516ce9        /usr/src/debug/anaconda-11.4.0.3/stubs/unicode-lite.c:28
0x4001e9        ??:0
Comment 3 Chris Lumens 2007-11-29 14:42:01 EST
Since the last call in net.c there is pumpSetupInterface, this looks to be a
problem in the libdhcp code getting something it's not expecting.
Comment 4 Lubomir Kundrak 2007-11-30 06:26:25 EST
I wonder if it would be possible to get gdbserver into rawhide builds of stage1,
so issues like this could be conveniently looked into.
Comment 5 Lubomir Kundrak 2007-11-30 11:52:48 EST
Also reproducible in 11.4.0.4 boot.iso, x86_64 only, not i386.
Comment 6 David Cantrell 2008-01-03 23:17:47 EST

*** This bug has been marked as a duplicate of 378641 ***

Note You need to log in before you can comment on or make changes to this bug.