Bug 378641 - SIGABRT when trying to get an IP address in loader
SIGABRT when trying to get an IP address in loader
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
: 390611 404691 418181 426624 428227 (view as bug list)
Depends On:
Blocks: F9Alpha
  Show dependency treegraph
 
Reported: 2007-11-12 14:54 EST by Jesse Keating
Modified: 2013-01-09 21:42 EST (History)
9 users (show)

See Also:
Fixed In Version: dhcp-4.0.0-6.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 17:08:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of traceback (700.39 KB, image/jpeg)
2008-01-04 11:27 EST, Jesse Keating
no flags Details
tail of install logs showing SIGABRT (11.38 KB, text/plain)
2008-01-23 17:14 EST, Bill Peck
no flags Details

  None (edit)
Description Jesse Keating 2007-11-12 14:54:57 EST
Booting rescue.iso and choosing a network install method.  Unchecked ipv6, and
hit OK at network screen.  Got SIGABRT.

401afe
5251f0
584435
5258d0
53ee35
53e634
56e68d
471b39
47351a
469e51
471556
418821
41ac9f
402d9b
516d39
4001e9
Comment 1 David Cantrell 2007-11-12 15:18:42 EST
I need the anaconda debuginfo package for the tree you booted in order to debug
this.
Comment 3 David Cantrell 2008-01-03 23:08:54 EST
*** Bug 418181 has been marked as a duplicate of this bug. ***
Comment 4 David Cantrell 2008-01-03 23:10:47 EST
Fixed in libdhcp-1.99.4.  The libnl API changed a bit.  The anaconda-11.4.0.15-1
build is linked with libdhcp-1.99.4, so it should be working fine.  I've tested
here and all seems well.
Comment 5 David Cantrell 2008-01-03 23:17:27 EST
*** Bug 390611 has been marked as a duplicate of this bug. ***
Comment 6 David Cantrell 2008-01-03 23:17:48 EST
*** Bug 404691 has been marked as a duplicate of this bug. ***
Comment 7 David Cantrell 2008-01-03 23:18:20 EST
*** Bug 426624 has been marked as a duplicate of this bug. ***
Comment 8 Jesse Keating 2008-01-04 11:26:56 EST
I'm re-opening this.  It seems to still be happening on x86_64.  I'm attaching a
photo of the traceback (which is useful now!)  
Comment 9 Jesse Keating 2008-01-04 11:27:50 EST
Created attachment 290851 [details]
Photo of traceback
Comment 10 Jesse Keating 2008-01-04 13:28:55 EST
Confirmed that this only happens on x86_64.  i386 gets past this (and tracebacks
somewhere else).
Comment 11 Chris Wright 2008-01-09 18:22:02 EST
Still happening here w/ today's rawhide (Jan 9), with same back trace that
jkeating reported:

loader received SIGABRT!  Backtrace:                                           
/sbin/loader(loaderSegvHandler+0x7e)[0x409ace]
/lib64/libc.so.6[0x2aaaacd5d000]
/lib64/libc.so.6(gsignal+0x35)[0x2aaaacd5cf95]
/lib64/libc.so.6(abort+0x110)[0x2aaaacd5ea40]
/lib64/libc.so.6[0x2aaaacda4fac]
/lib64/libc.so.6(cfree+0x27)[0x2aaaacda4777]
/lib64/libc.so.6[0x2aaaace012ee]
/lib64/libc.so.6(tdestroy+0x38)[0x2aaaace013d8]
/lib64/libdhcp-1.99.so.1(dhcpv4_lease_free+0x5b)[0x2aaaab91a5ab]
/lib64/libdhcp-1.99.so.1(dhcpv4_control_free+0x1a)[0x2aaaab91c03a]
/lib64/libdhcp-1.99.so.1(dhcp_nic_free+0x11)[0x2aaaab91db31]
/lib64/libdhcp-1.99.so.1(pumpSetupInterface+0x66)[0x2aaaab925416]
/sbin/loader(configureNetwork+0x11)[0x41ab31]
/sbin/loader(readNetConfig+0x53f)[0x41cfaf]
/sbin/loader(main+0xade)[0x40adce]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x2aaaacd492b4]
/sbin/loader[0x4081f9]
install exited abnormally [1/1]
Comment 12 David Cantrell 2008-01-10 19:25:26 EST
*** Bug 428227 has been marked as a duplicate of this bug. ***
Comment 13 David Cantrell 2008-01-14 20:16:47 EST
Fixed this in rawhide in libdhcp-1.99.6-1.fc9.  Building new packages now.
Comment 14 Bill Peck 2008-01-16 17:57:19 EST
Still failing with rawhide-20080116 which has libdhcp-1.99.6-1.fc9.src.rpm.

Logs follow for i386 now.

loader received SIGSEGV!  Backtrace:                                           
/sbin/loader(loaderSegvHandler+0xa0)[0x8050060]
[0x12f420]
/lib/libc.so.6(fclose+0x1d)[0x54fbbd]
/lib/libdhcp4client-4.0.so.0(end_iface_scan+0x25)[0x3b4975]
/lib/libdhcp4client-4.0.so.0(discover_interfaces+0x2b7)[0x3b5e47]
/lib/libdhcp4client-4.0.so.0(dhcpv4_client+0x111f)[0x3a57df]
/lib/libdhcp-1.99.so.1(do_dhcpv4+0x3c)[0x32dbbc]
/lib/libdhcp-1.99.so.1[0x32f975]
/lib/libdhcp-1.99.so.1(dhcp_nic+0x3a)[0x32feea]
/lib/libdhcp-1.99.so.1(pumpDhcpClassRun+0x127)[0x337ca7]
/sbin/loader(doDhcp+0x12a)[0x8062c1a]
/sbin/loader(configureTCPIP+0x9b8)[0x80653d8]
/sbin/loader(readNetConfig+0x3bd)[0x8065aed]
/sbin/loader(main+0xd9a)[0x805175a]
/lib/libc.so.6(__libc_start_main+0xe0)[0x5094a0]
/sbin/loader[0x804e121]
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /proc done
        /dev/pts done
        /sys done
you may safely reboot your system


loader received SIGABRT!  Backtrace:                                           
/sbin/loader(loaderSegvHandler+0xa0)[0x8050060]
[0x12f420]
/lib/libc.so.6(gsignal+0x46)[0x51da66]
/lib/libc.so.6(abort+0x101)[0x51f421]
/lib/libc.so.6[0x5658a5]
/lib/libc.so.6(cfree+0x35)[0x5650b5]
/lib/libdhcp4client-4.0.so.0(dfree+0x26)[0x3e5966]
/lib/libdhcp4client-4.0.so.0(script_init+0x46)[0x3a2126]
/lib/libdhcp4client-4.0.so.0(bind_lease+0x5a)[0x3a37da]
/lib/libdhcp4client-4.0.so.0(state_selecting+0xca)[0x3a400a]
/lib/libdhcp4client-4.0.so.0(process_outstanding_timeouts+0xf8)[0x3b6a98]
/lib/libdhcp4client-4.0.so.0(dhcpv4_client+0x1777)[0x3a5e37]
/lib/libdhcp-1.99.so.1(do_dhcpv4+0x3c)[0x32dbbc]
/lib/libdhcp-1.99.so.1[0x32f975]
/lib/libdhcp-1.99.so.1(dhcp_nic+0x3a)[0x32feea]
/lib/libdhcp-1.99.so.1(pumpDhcpClassRun+0x127)[0x337ca7]
/sbin/loader(doDhcp+0x12a)[0x8062c1a]
/sbin/loader(configureTCPIP+0x9b8)[0x80653d8]
/sbin/loader(readNetConfig+0x3bd)[0x8065aed]
/sbin/loader(main+0xd9a)[0x805175a]
/lib/libc.so.6(__libc_start_main+0xe0)[0x5094a0]
/sbin/loader[0x804e121]
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /proc done
        /dev/pts done
        /sys done
you may safely reboot your system
Comment 15 John Poelstra 2008-01-22 13:30:50 EST
According to bpeck, tested against rawhide-20080122-Default and still broken
Comment 16 Will Woods 2008-01-23 11:02:30 EST
How's bpeck triggering the bug? especially on i386? rawhide-20080122 works fine
for me.
Comment 17 Bill Peck 2008-01-23 11:15:43 EST
I'm doing an nfs install with dhcp.
Comment 18 Will Woods 2008-01-23 11:34:57 EST
"ip=dhcp ipv6=auto" as kernel boot args? or requesting dhcp interactively in loader?
Comment 19 Michal Jaegermann 2008-01-23 16:44:47 EST
Worksforme with 2008-01-22 images.  With everything available over
NFS and network interfaces configured via dhcp from _within_ anaconda
I can use those images at least to reach a shell prompt while
booting "rescue".
Comment 20 Bill Peck 2008-01-23 17:14:34 EST
Created attachment 292703 [details]
tail of install logs showing SIGABRT

parameters passeed via pxe are console and ks.
kickstart file has network --device eth0 --bootproto dhcp

One thing to note is I can see anaconda pulling the kickstart file from the
server via http.  Its after it pulls the kickstart file that this blows up.  So
its definitely kickstart related.

I have had some other systems proceed past this point but they blow up at
different points.  I've filed BZ's on them as well.  The only way I can get a
successful install is to disable selinux or not specify it in the kickstart
Comment 21 Will Woods 2008-01-23 17:50:09 EST
That trace runs through getFileFromUrl, so (in theory) you're done with DHCP and
you've got an IP at this point. 

So, yes, it's a SIGABRT in loader, but this is a different bug.
Comment 22 Jesse Keating 2008-01-28 17:08:14 EST
This should be fixed with dhcp-4.0.0-6.fc9, which is tagged for the beta.

Note You need to log in before you can comment on or make changes to this bug.