Bug 40530 - 5 and 10-packs are upfront billing
5 and 10-packs are upfront billing
Status: CLOSED DUPLICATE of bug 40285
Product: Red Hat Web Site
Classification: Red Hat
Component: New Store (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cameron Prince
wbirkhea
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 08:00 EDT by Jay Turner
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-17 14:25:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Turner 2001-05-14 08:00:38 EDT
Description of Problem:
5 and 10-packs for RHN subscriptions are supposed to be billed upfront for
the annual subscription (according to Billy Marshall) therefore we need to
make this change in IC

How Reproducible:
Always

Steps to Reproduce:
1. Log into http://bmantest.meridian.redhat.com/cgi-bin/store
2. Click on Red Hat Network in the left-hand column
3. Click "Buy" on the 5-pack
4. Accept the EULA
5. $59.95 product gets added to the cart

Actual Results:
Get $59.95 product added to the cart.

Expected Results:
Should get $719.40 product added to the cart (12 * $59.95)

Additional Information:
In addition to making this change for the 5-packs, going to have to do the
same for 10-packs.  Also, in addition to making this change in IC, we are
going to have to modify the receipt to reflect just what the user is being
charged for.  This again calls for the custom RHN receipt to message to the
user that this is an annual commitment and they are being charged upfront
for the annual subscription.
Comment 1 David Totten 2001-05-14 09:36:02 EDT
Shouldn't we also let the customer know that all money is paid up front for
those products? I mean if I were to place that in my cart, and I saw that it's
price was $59.95, and all of a sudden I am getting charged $719.40.

I guess what I am trying to say here is that we need to let them know before the
receipt page.
Comment 2 Jay Turner 2001-05-14 11:44:35 EDT
That's exactly what this bug says.  The expected result is that $719.40 gets
added to the cart.  The message about the receipt needing a content change is
listed as an afterthought.
Comment 3 David Totten 2001-05-15 15:26:54 EDT
Just for a paper trail, I have looked into this, and will perhaps require a
couple of columns added to the rh_product table (or another one).

We will need to know the following
1) Is this an "upfront" payment type?
2) How frequently the payments would have been made? (daily, monthly, yearly)

With that, we could then calculate how much the customer needs to be charged.
Again, these are just notes, and comments are welcome :)
Comment 4 Jay Turner 2001-05-17 14:25:11 EDT
Actually, I think that this has become more complicated after a discussion with
Rich Crandall.  According to him, the $59.95 and $99.00 prices are actually per
server for the year.  So, the way that this is being handled in the internal
store currently is that the reps are putting quantity 5 of the 5-packs (for the
5 machines)  The reason for this is so that the contracts get created correctly
on the backside.

So, don't know the best way to deal with this, as I don't think that we can tell
IC to translate that 1 5-pack is really 5 of that item number.
Comment 5 Cameron Prince 2001-06-07 20:22:51 EDT

*** This bug has been marked as a duplicate of 40285 ***

Note You need to log in before you can comment on or make changes to this bug.