This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 40535 - installer crashes during package installation
installer crashes during package installation
Status: CLOSED DUPLICATE of bug 23248
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 08:52 EDT by Brian LaValley
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-14 11:14:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian LaValley 2001-05-14 08:52:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win98; I)

Description of problem:
During instalation of 7.0 using anaconda update RHBA-2000-084 The installer hangs during package installation and reports and anaconda 
dump.

How reproducible:
Always

Steps to Reproduce:
1.Run install with RHBA-2000-084 anaconda update
2.
3.
	

Actual Results:  Here is the text of the anaconda dump.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/tmp/updates/todo.py", line 1491, in doInstall
    self.fstab.mountFilesystems (self.instPath)
  File "/tmp/updates/fstab.py", line 710, in mountFilesystems
    iutil.mkdirChain(instPath + mntpoint)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 193, in mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 17] File exists: '/mnt/sysimage'

Local variables in innermost frame:
which: 3
dir: /mnt/sysimage/boot
elements: ['', 'mnt', 'sysimage', 'boot']
path: /mnt/sysimage

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Additional info:

This machine previously ran RH6.2 and a upgrade to 7.0 was attempted in the past, but the new install of 7.0 is being performed to get Gnome 
support.
Comment 1 Brent Fox 2001-05-14 11:14:46 EDT

*** This bug has been marked as a duplicate of 23248 ***

Note You need to log in before you can comment on or make changes to this bug.