Bug 23248 - Anaconda 7.0.1 crashed during install
Anaconda 7.0.1 crashed during install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 22988 23057 40535 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-03 16:13 EST by Ryan Cresawn
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 19:25:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Cresawn 2001-01-03 16:13:20 EST
When installing Red Hat Linux 7.0 the installer crashed while formatting
the hard drive on an AMD Athlon 800 MHz.

Traceback (innermost last):
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line
20, in run
  rc = self.todo.doInstall ()
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1472, in
doInstall
  self.fstab.mountFileststems (self.instPath)
 File "fstab.py", line 710, in mountFilesystems
  iutil.mkdirChain(instPath + mntpoint)
 File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 193, in
mkdirChain
  os.mkdir(path, 0755)
OSError: [Errno 17] File exists: '/mnt/sysimage'
Comment 1 Michael Fulbright 2001-01-03 18:05:35 EST
Would you please give step by step instructions on how to reproduce this problem?
Comment 2 Michael Fulbright 2001-01-03 18:19:06 EST
*** Bug 23057 has been marked as a duplicate of this bug. ***
Comment 3 Michael Fulbright 2001-01-03 18:36:03 EST
*** Bug 22988 has been marked as a duplicate of this bug. ***
Comment 4 Ryan Cresawn 2001-01-03 19:25:25 EST
Boot from CDROM.  Select English.  Select "Generic 104-key PC".  Select Next.
Select "2 Button Mouse (PS/2)".  Select Next.  Select Next to pass the intro.
Select "Custom System".  Select Next.  Select Next to enter Disk Druid.  Add
partitions.

/boot     hda1 54 MB
/         hda5 3004 MB
<Swap>    hda6 517 MB
/mnt/hda7 hda7 4479 MB

Select Next.  Select all partitions to be formatted and select "Check for bad
blocks while formatting".  I believe checking for bad blocks is related to the
bug I reported.  Select Next.  Unselect "Create boot disk".  Select Next.  Enter
network information.  Select Next.  Select "System clock uses UTC".  Select
Next.  Enter root password and then create a user account.  Select Next.  Accept
defaults for "Authentication Configuration" screen by selecting Next.  Scroll
down to the bottom of the window and select "Everything".  Select Next.  Monitor
detected so select Next.  Select "Customize X Configuration" and "Use Graphical
Login".  Select Next.  Select "1152x864" for "32Bits per Pixel".  Select Next.
Select Next to begin installation.

Formatting / filesystem...
Formatting /boot filesystem...
Formatting /mnt/hda7 filesystem...

This is where it brings up the message I typed in the bug report.  I should also
mention that it doesn't appear to be consistent because when typing these
instructions I found that it worked fine but it failed several times earlier.
Comment 5 Ryan Cresawn 2001-01-07 10:48:33 EST
I now believe this bug was caused by a flaky memory card.  I replaced the card
and installed RH 7 without any problems.  The system has been very stable ever
since.
Comment 6 Brent Fox 2001-05-14 11:14:41 EDT
*** Bug 40535 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.