Bug 40553 - Experiencing problems downloading stage2.img from any FTP mirror site which may or may not be leading to my problem using the hard drive upgrade procedure. Procedure reports error message just after scanning files on hard drive.
Experiencing problems downloading stage2.img from any FTP mirror site which m...
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Any mirror FTP site that provides the
Depends On:
  Show dependency treegraph
Reported: 2001-05-14 10:29 EDT by Rick Hoffman
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-14 11:08:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rick Hoffman 2001-05-14 10:29:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win98; U)

Description of problem:
I have read the instructions for upgrading RH from the hard drive over and over and over.  My simple impression is this:

Copy from mirror FTP sites all files from the RPMS and base directories onto the hard drive under the directory path called RedHat/RPMS and 
RedHat/base, respectively.  Create installer bootdisk by copying boot.img from the images directory onto a floppy disk.  Then just simply run 
the installer to do a hard-drive upgrade.  Am I interpreting these instructions correctly?

I have downloaded EVERY single file from these sites (some 840MB over some 870 files).  There is one file that I consistently am having a 
problem downloading.  It is by far the largest file of them all.  According to every mirror site I have tried it is around 87MB.  The file is found in 
the base directories and is called "stage2.img".  Every downloading method I have tried has unsuccessfully downloaded 87MB of this file.  

How reproducible:

Steps to Reproduce:
1.  I have been using Windows98 in my attempts to download this file.
2.  I have tried right clicking on file name and "save link as" as one method of downloading
3.  I have tried using the NetZip download demon program as another method.

Actual Results:  During the download the progress reporting is skewed.  The downloading methods either don't show the correct percentage of 
the file size already downloaded OR the time remaining is wrong OR both.  For instance, I am trying to download this file as I write this 
message.  The download started 30 minutes ago.  27 of the 87MB has completed.  The download program is reporting there is over 12 hours 
left to completion.  That is totally wrong.  Another attempt with another downloading method was stuck on reporting the download at 24% 
complete for over 20 MB of the process.  Suddenly it jumped up to 52%!!!!  Another time, for instance, the download just stopped and 
timed out.  Another time, for instance, the download hit 100% and 87MB!!!  Halleluyah!!!  The only problem is the process didn't quit.  It kept on 
downloading!!  The time remaing was being reported at over 104 HOURS!!!  I cancelled the process after it had reportedly downloaded over 
90MB.  The file was saved and its size was only 26MB !!!!!!  The last two attempts I have made to download this file just stopped after 
downloading ~56MB and the process timed out.

What is going on with this file!!!  What in the hell am I doing wrong????

The closest thing that I have found in bugzilla to my problem is a response to bug # 21413 made in November of last year..  

"It looks like the /RedHat/base directory wasn't properly copied onto your hard drive image."

This bug # is still posted as NEW???  What do you mean by "[not] properly copied"??  Also what do you mean by "hard drive image"??

Expected Results:  Successful download.  The file should be saved into a directory where it reports a filesize of ~87MB.  Until I get this file 
successfully downloaded and into the /RedHat/base directory any attempts at running the install program seems futile OR IS IT?

Additional info:

My system has a Celeron 300 cpu with 48MB ram and 6GB HD.  I am separating the HD into the following partitioning scheme:

device        size(MB)        mount point
hdb2             22                 /boot
hdb3            118                swap
hdb5            103                /
hdb6           1550               /home
hdb7            376                /opt
hdb8            191                /tmp
hdb9            981                /usr
hdb10          693                /usr/local
hdb11          789                /usr/src
hdb12          413                /var
Comment 1 Brent Fox 2001-05-14 11:08:31 EDT
I'm not familiar with Windows FTP clients (at least not in a few years), so I
don't know what is going on with your FTP client.  The stage2.img file is
89438208 bytes in size, so if the file isn't that exact size, then the installer
is not going to work.  There's nothing special about that file that would cause
FTP clients to mess up...it's just like every other binary file except that it's
rather large in size.  Are you sure that the FTP client is set to binary
transfer mode?
I would recommend that you download 7.1 and try a hard drive install with it. 
We have changed the hard drive install method for 7.1 since people seemed to
have trouble with the old way.  What you do now is download the cd ISO images to
a partition on your hard drive, just like you would if you were going to burn a
cd.  Instead of burning the cd, though, you boot the computer with the boot.img
floppy and select "Hard Drive".  The installer will find the ISOs on the hard
drive and do the install that way.

I'm sorry that you are having trouble downloading Red Hat Linux, but I'm going
to close this bug since it seems be problem lies somewhere between the FTP site,
Windows, and the FTP client.  Feel free to post back to this bug report,
however, and I'll try to help you in any way that I can.  

Note You need to log in before you can comment on or make changes to this bug.