Bug 405721 - Kernels after kernel-2.6.24-0.42.rc3.git1.fc9 fail to boot
Kernels after kernel-2.6.24-0.42.rc3.git1.fc9 fail to boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 05:12 EST by Kjartan Maraas
Modified: 2007-12-10 15:44 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 15:44:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2007-11-30 05:12:18 EST
Description of problem:

from -43 on it fails hangs after the TSC: clocksource installed message

This is a HP Compaq nc6400 laptop

The TSC related messages from a normal boot with the -42 kernel are:

checking TSC synchronization [CPU#0 -> CPU#1]: passed.
...
Marking TSC unstable due to: TSC halts in idle.

And I'm booting with the following extra boot parameter:
pci=assign-busses after seeing a suggestion to use this in dmesg earlier.

[root@localhost kmaraas]# cat /proc/cpuinfo 
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz
stepping        : 6
cpu MHz         : 1000.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc
arch_perfmon pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3662.16
clflush size    : 64

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 CPU         T5600  @ 1.83GHz
stepping        : 6
cpu MHz         : 1000.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc
arch_perfmon pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3657.51
clflush size    : 64

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 shrek-m 2007-11-30 05:55:16 EST
not exactly the same but my macmini freezes at different points since 0.43.rc3
core duo: Genuine Intel(R) CPU   T2300  @ 1.66GHz

no freeze <= kernel-2.6.24-0.42.rc3.git1.fc9.i686.rpm


the freezes are with these kernels:
kernel-2.6.24-0.43.rc3.git1.fc9.i686.rpm
kernel-2.6.24-0.45.rc3.git1.fc9.i686.rpm
kernel-2.6.24-0.55.rc3.git3.fc9.i686.rpm
kernel-2.6.24-0.56.rc3.git3.fc9.i686.rpm
kernel-2.6.24-0.57.rc3.git4.fc9.i686.rpm


my macmini freezes here:

the first freeze without "acpi=off" "noisapnp"
----
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
checking if image is initramfs...  it is
----/----

the second freeze with "acpi=off" without "noisapnp"
----
after isapnp cards scanning
----/----

the third freeze with "acpi=off noisapnp"
----
Red Hat nash version 6.0.19 starting
----/----


kernel boot command line:
http://www.kernel.org/pub/linux/kernel/people/gregkh/lkn/lkn_pdf/ch09.pdf
Comment 2 shrek-m 2007-11-30 14:59:12 EST
you can add
kernel-2.6.24-0.59.rc3.git5.fc9.i686.rpm
to the freeze-list.
Comment 3 Eamon Walsh 2007-11-30 16:18:57 EST
Dell Optiplex 745, 100% reproducible hang after "TSC: clocksource installed" on
versions:

kernel-2.6.24-0.43.rc3.git1.fc9
kernel-2.6.24-0.55.rc3.git3.fc9

processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 15
model name	: Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz
stepping	: 6
cpu MHz		: 2392.323
cache size	: 4096 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon
pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips	: 4788.64
clflush size	: 64

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 15
model name	: Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz
stepping	: 6
cpu MHz		: 2392.323
cache size	: 4096 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36
clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon
pebs bts pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips	: 4784.50
clflush size	: 64
Comment 4 Kjartan Maraas 2007-11-30 16:35:17 EST
I see the same hang on a plain 2.6.24-rc3 kernel so it's not fedora specific at
least.
Comment 6 Josh Boyer 2007-12-03 22:22:09 EST
This kernel boots for me:

kernel-2.6.24-0.66.rc3.git7.fc9
Comment 7 Josh Boyer 2007-12-03 22:24:41 EST
You might have hit bug 407281 here.  See if the above kernel boots for you
Comment 8 Dave Jones 2007-12-10 15:44:49 EST
sounds like the gcc bug.

Note You need to log in before you can comment on or make changes to this bug.