Bug 405741 - Crackling sound with T61
Crackling sound with T61
Status: CLOSED DUPLICATE of bug 433495
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-30 05:20 EST by Zdenek Kabelac
Modified: 2008-04-26 22:03 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-26 22:03:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2007-11-30 05:20:53 EST
Description of problem:

With 2.6.24 kernel I get very ugly crackling sound from my T61 with recent
kernel (2.6.23 is running just find - no sound problems.
Even when I remove pcspkr (which is also now a good source of such cracklings)

Oh - and btw - why CONFIG_ACPI_VIDEO is not set ?
I do not get brightness control interface in /proc


Version-Release number of selected component (if applicable):
2.6.24-0.55.rc3.git3.fc9

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
clean sound 

Additional info:
Comment 1 Zdenek Kabelac 2007-12-11 11:43:14 EST
Hi

Well I've moved myself to vanilla kernel -  latest fedora kernel:

vmlinuz-2.6.24-0.80.rc4.git6.fc9

doesn't play the sound at all - the volume move bar in gnome is basicaly
enable/disabling sound at various points (at least from the cracling I could
hear in the headphones)

I guess some patch from the fedora patch set is heavily broken....

Comment 2 Zdenek Kabelac 2008-01-07 08:38:07 EST
My update for this report: 2.6.24-0.136.rc6.git12.fc9 

Sound with this kernel looks better (even thought the pcspkr module is better
rmmod-ed)  - at least  with OSS and volume setting everything seems to be just fine.

(yet with pulseaudio it is another horrible story...)
Comment 3 Zdenek Kabelac 2008-01-18 10:00:13 EST
Hello another update on this issue - the problem appears to be with the power
saving.

with setting 0  here: /sys/module/snd_hda_intel/parameters/power_save
the sound is clean&clear

with setting 10 (which is default with fedora kernel) I do hear the crackling in
the sound i.e. before the mp3 song gets played (with
Comment 4 Chuck Ebbert 2008-01-18 16:53:20 EST
Kernel default is 5 in rawhide and 0 in Fedora 8. Maybe we need to disable it by
default and let users enable it at their own risk...
Comment 5 Zdenek Kabelac 2008-04-25 05:10:41 EDT
Bug could be probably closed - the problem is up to the user if he wants power
saving or not. Could be selected by this options line in /etc/modprobe.conf

options snd-hda-intel index=0 model=thinkpad power_save=0

I assume there is no way to make this power saving 'click-free' as even with
muted sound the audio click when it's in power_save mode :(

Comment 6 Chuck Ebbert 2008-04-26 22:03:55 EDT
Powersave is now off by default.

Closing as dup of the newer bug since that's the one in the changelog.


*** This bug has been marked as a duplicate of 433495 ***

Note You need to log in before you can comment on or make changes to this bug.