This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 433495 - snd_hda_intel, doesn't recognise device
snd_hda_intel, doesn't recognise device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 405741 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-19 12:15 EST by Kevin DeKorte
Modified: 2009-04-03 10:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-31 22:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Run of alsa-info.sh when sound doesn't work (26.54 KB, text/plain)
2008-03-04 08:06 EST, Kevin DeKorte
no flags Details
Output of alsa-info.sh after upgrading alsa drivers to 1.0.16 (28.22 KB, text/plain)
2008-03-04 08:06 EST, Kevin DeKorte
no flags Details

  None (edit)
Description Kevin DeKorte 2008-02-19 12:15:43 EST
Description of problem:
snd_hda_intel, doesn;t find correct sound outputs on sound card

Version-Release number of selected component (if applicable):
kernel-2.6.24.1-31.fc9.x86_64 or greater fails
kernel-2.6.23.15-137.fc8.x86_64 (installed on rawhide, works fine)

How reproducible:
100%

Steps to Reproduce:
1. install kernel-2.6.24.1-31.fc9.x86_64 or greater
2.
3.
  
Actual results:
Sound pops only, no other audio

Expected results:
System audio system working.

Additional info:

ALSA sound/pci/hda/hda_intel.c:1792: chipset global capabilities = 0x4401
ALSA sound/pci/hda/hda_intel.c:744: codec_mask = 0x3
hda_codec: Unknown model for ALC883, trying auto-probe from BIOS...
ALSA sound/pci/hda/hda_codec.c:2854: autoconfig: line_outs=4 (0x14/0x15/0x16/0x1
7/0x0)
ALSA sound/pci/hda/hda_codec.c:2858:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2862:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
ALSA sound/pci/hda/hda_codec.c:2863:    mono: mono_out=0x0
ALSA sound/pci/hda/hda_codec.c:2871:    inputs: mic=0x18, fmic=0x19, line=0x1a, 
fline=0x0, cd=0x0, aux=0x0
ALSA sound/pci/hda/hda_generic.c:678: hda_generic: no proper input path found
ALSA sound/pci/hda/hda_generic.c:426: hda_generic: no proper output path found
ALSA sound/pci/hda/hda_generic.c:1021: hda_generic: no PCM found
ALSA sound/pci/hda/hda_codec.c:1070: Cannot find slave Headphone Playback Volume
, skipped
ALSA sound/pci/hda/hda_codec.c:1070: Cannot find slave Speaker Playback Volume, 
skipped
ALSA sound/pci/hda/hda_codec.c:1070: Cannot find slave Mono Playback Volume, ski
pped
ALSA sound/pci/hda/hda_codec.c:1070: Cannot find slave Line-Out Playback Volume,
 skipped
ALSA sound/pci/hda/hda_codec.c:1070: Cannot find slave Speaker Playback Switch, 
skipped
ALSA sound/pci/hda/hda_codec.c:1070: Cannot find slave Mono Playback Switch, ski
pped


00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller
(rev 02)
	Subsystem: ASUSTeK Computer Inc. Unknown device 829f
	Flags: bus master, fast devsel, latency 0, IRQ 22
	Memory at fe7f4000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel


setting model=asus in modprobe.conf does not help.
Comment 1 Kevin DeKorte 2008-02-21 08:30:04 EST
Problem is still present in kernel-2.6.25-0.54.rc2.fc9.x86_64

Tried to compile Alsa 1.0.16 drivers and replace the ones in the kernel, but the
drivers won't compile on rawhide, compiler is more picky.
Comment 2 Kevin DeKorte 2008-02-23 19:04:30 EST
kernel-2.6.25-0.64.rc2.git5.fc9.x86_64 exhibits same problem
Comment 3 Kevin DeKorte 2008-02-25 11:36:03 EST
kernel-2.6.25-0.65.rc2.git7.fc9.x86_64 also exhibits the same problem. However,
I found that if I upgraded alsa-drv from 1.0.16rc2 to 1.0.16 the problem with
the audio was fixed. I did have to make some simple patches to alsa-drv 1.0.16
(commenting out comparisons to current->fs->root)

So please upgrade alsa-drv in kernel to 1.0.16

I did have to set model=asus-dig2 in modprobe.conf to make sure alsa was using
the right model driver for my card.
Comment 4 Kevin DeKorte 2008-02-27 11:21:16 EST
kernel-2.6.25-0.69.rc3.git1.fc9.x86_64 exhibits same problem. 

Again upgrading Alsa to 1.0.16 final fixes the problem of the sound card not
working. Is anyone even reading this report?
Comment 5 Dave Jones 2008-02-27 12:52:04 EST
yes, there are just a lot more bugs than there are people to work on them
unfortunately.  I'll forward this on to the upstream alsa developers.

thanks for taking the time to debug this as far as you have, it's very helpful.
Comment 6 Kevin DeKorte 2008-03-03 08:05:11 EST
Just an FYI, but 2.6.25-0.82.rc3.git2.fc9 still has broken sound still. Again
upgrading alsa to 1.0.16 final fixes it.
Comment 7 Chuck Ebbert 2008-03-03 12:25:52 EST
rc3-git2 had the latest round of ALSA updates applied, too:

commit c0f4133b8f70769bc8dda977feb9a29109d6ccca
Merge: 99642e2... 0d9ac27...
Author: Linus Torvalds <torvalds@woody.linux-foundation.org>
Date:   Fri Feb 29 08:44:00 2008 -0800

    Merge git://git.kernel.org/pub/scm/linux/kernel/git/tiwai/alsa-fix-2.6
Comment 8 Kevin DeKorte 2008-03-03 12:51:42 EST
Chuck, is there any additional info you would like me to provide?

I found this tool to be quite helpful

http://hg.alsa-project.org/alsa/raw-file/e167861901c7/alsa-info.sh

Might want to see if that is still reporting alsa-drv version 1.0.16rc2 or 1.0.16

Comment 9 Kevin DeKorte 2008-03-03 12:56:45 EST
This is what alsa-info looks like when the driver is working correctly.

http://pastebin.ca/926351
Comment 10 Kevin DeKorte 2008-03-04 08:05:32 EST
I just booted into the new kernel (2.6.25-0.87.rc3.git4.fc9) and since the sound
didn't work in it either. I thought I would run alsa-info.sh before I installed
the known working drivers and after. The main thing I found in this is that the
broken kernel is still reporting an alsa version of 1.0.16rc2 for the alsa-drv
portion. Alsa-drver final was released on 2-06 and rc2 was released on 1-29.
Anyway we can get the final release of the driver pushed into the mainline
kernel. At least before Fedora freezes start to happen.
Comment 11 Kevin DeKorte 2008-03-04 08:06:09 EST
Created attachment 296733 [details]
Run of alsa-info.sh when sound doesn't work
Comment 12 Kevin DeKorte 2008-03-04 08:06:53 EST
Created attachment 296734 [details]
Output of alsa-info.sh after upgrading alsa drivers to 1.0.16
Comment 13 Kevin DeKorte 2008-03-11 09:34:53 EDT
Status update: Still broken in kernel-2.6.25-0.105.rc5.fc9.x86_64, same fix
still works.

Apparently the fix is in the -mm tree. Don't know why it hasn't been merged in.
Comment 14 Kevin DeKorte 2008-03-25 10:16:58 EDT
Status update: Still broken in kernel-2.6.25-0.150.rc6.git7.fc9.i686, same fix
still works.

Had to switch my machine from 64bit to 32bit for other reasons
Comment 15 Kevin DeKorte 2008-03-27 08:58:49 EDT
kernel-2.6.25-0.161.rc7.fc9.i686

Based on a tip from the Fedora Test mailing list I set 

options snd-hda-intel index=0 model=asus-dig2 power_save=0

in /etc/modprobe.conf prior to this, I did not have power_save=0 in the file
after adding that the sound card worked properly. So I also recommend that this
be a default setting for the snd-hda-intel driver.
Comment 16 Chuck Ebbert 2008-03-31 22:17:20 EDT
Changed the default to 0 (disabled.)
Comment 17 Thorsten Leemhuis 2008-04-01 01:11:09 EDT
(In reply to comment #16)
> Changed the default to 0 (disabled.)

FWIW, I strongly dislike this fix. Alsa's power_save mode can save quite an
amount of power and thus my notebook's battery can last a bit longer. So I think
there is more then one problem report needed to justify disabling power_save for
everyone. Especially if a real fix seems to be in -mm and alsa 1.0.16
Comment 18 Chuck Ebbert 2008-04-18 18:27:43 EDT
Kevin, when you built the ALSA modules yourself, what values did you set for
CONFIG_SND_HDA_POWER_SAVE and CONFIG_SND_HDA_POWER_SAVE_DEFAULT?
Comment 19 Kevin DeKorte 2008-04-18 19:10:27 EDT
Whatever the defaults are...

This is the command I used to compile...

./configure --prefix=/usr --with-cards=hda-intel --with-sequencer=yes

So maybe off is default?
Comment 20 Chuck Ebbert 2008-04-26 22:03:26 EDT
(In reply to comment #17)
> (In reply to comment #16)
> > Changed the default to 0 (disabled.)
> 
> FWIW, I strongly dislike this fix. Alsa's power_save mode can save quite an
> amount of power and thus my notebook's battery can last a bit longer. So I think
> there is more then one problem report needed to justify disabling power_save for
> everyone. Especially if a real fix seems to be in -mm and alsa 1.0.16

It's not disabled, just off by default. You can enable it by adding:

   power_save=1

to the module options for snd_hda_intel.
Comment 21 Chuck Ebbert 2008-04-26 22:03:56 EDT
*** Bug 405741 has been marked as a duplicate of this bug. ***
Comment 22 Eric Sandeen 2009-02-04 11:44:10 EST
Just a note - I've re-enabled the HDA powersave (at 5s) in rawhide, it'd be great to get some feedback on how this is working at this point.
Comment 23 Kevin DeKorte 2009-02-04 11:55:33 EST
I'm currently running Fedora 10, can I just install the kernel from rawhide? Or is there other stuff I would need to install. I just don't want to pull in too much of rawhide.
Comment 24 Eric Sandeen 2009-02-04 12:09:35 EST
You could just test it on your current kernel by:
echo 5 > /sys/module/snd_hda_intel/parameters/power_save

-Eric
Comment 25 Thorsten Leemhuis 2009-02-04 12:25:36 EST
FYI, I'm running 2.6.29-0.6.rc3.fc10.x86_64 since a few days with "options snd-hda-intel power_save=1" in modprobe.d/audio and it works really well (Dell Latitude D630, GM965)
Comment 26 Eric Sandeen 2009-04-03 10:54:39 EDT
Since this bug was originally about device recognition, and is now closed, if people could put information regarding pop/click & powersave problems in this driver over in bug 493972.

Thanks,
-Eric

Note You need to log in before you can comment on or make changes to this bug.