Bug 40578 - RFE: Please add Voodoo 2 driver + Glide2
RFE: Please add Voodoo 2 driver + Glide2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 52284 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 15:08 EDT by Alan Cox
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-30 03:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2001-05-14 15:08:23 EDT
The Glide2 library + glide module appear not to be shipped even on power
tools
Comment 1 Mike A. Harris 2001-05-14 23:20:12 EDT
Yeppers..  I'll probably add it to the 4.1.0 packaging, as I'd like to
improve support for any/all video hardware as much as possible.  I think
I've opened an RFE on this to remind me already..  I don't have a Voodoo II
to test with though so it wasn't high priority.  I'll likely scarf the
support from someone else's packaging to avoid duplication of effort.
Comment 2 Mike A. Harris 2001-05-14 23:56:58 EDT
Just checked and couldn't find any RFE.. Guess it was just a note to
self in the spec file...  I've changed the summary to RFE.

Thanks.
Comment 3 Mike A. Harris 2001-08-08 09:22:03 EDT
Didn't happen yet.. deferring for future release.
Comment 4 Mike A. Harris 2001-08-22 11:30:01 EDT
*** Bug 52284 has been marked as a duplicate of this bug. ***
Comment 5 Mike A. Harris 2002-05-30 03:34:06 EDT
Due to the small number of people in the userbase who have Voodoo or
Voodoo 2 hardware, and the likely smaller number of those that would
actually use this feature if we were to implement it, and also the
existing headaches with trying to get Glide3 to deal with new GNU
autotools every release, as well as new compiler, etc. I think that
adding the Glide2 would create more maintenance work for me than the
benefit of having this would provide to the small number of users
that would use it.

So I've decided to not include the glide driver and Glide2.
Comment 6 Alan Cox 2002-05-30 07:58:53 EDT
Ok. Fortunately the Mandrake XFree packages work on Red Hat
Comment 7 Mike A. Harris 2002-05-30 17:33:52 EDT
Another thing you could do, is just grab the actual glide_drv.o driver
file from Mandrake, and install the Glide2 package.  Then make a directory
called /usr/local/XFree86/modules  and drop glide_drv.o in there, and
add to your X config:

    ModulePath "/usr/local/XFree86/modules"
    ModulePath "/usr/X11R6/lib/modules"

Modules located in the custom local path will override those in the standard
XFree86 path.  That way you can use our RPM packages rather than Mandrake's
rather stock unpatched packages.  It also has the benefit that when you
upgrade XFree86 to a new release, your glide module will not be overwritten,
and it should just keep on working.  Even if you upgrade to a new version
of XFree86, older modules _should_ still work (so the claim goes).

If you do try this, please let me know how it goes.  I've used the above
various times for testing things and it has worked ok, but I'm curious as
to how it works for someone else.

Take care.


Note You need to log in before you can comment on or make changes to this bug.