Bug 40584 - Sun JDK breaks (not really ODBC)
Sun JDK breaks (not really ODBC)
Status: CLOSED DUPLICATE of bug 27090
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-14 16:52 EDT by Gabriel Schulhof
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-14 16:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Schulhof 2001-05-14 16:52:13 EDT
Description of Problem:
Sun JDK no longer works out of the box.
It cannot find /usr/bin/cut (No problem: ln -s /bin/cut /usr/bin/cut)
However, There are many errors loading various shared libraries, and
simply adding ${prefix}/bin/java to PATH and running it, causes java to hang.

How Reproducible:
Easily.

Steps to Reproduce:
1. Download jdk-1_3_0_02 from Sun
2. execute downloaded file (produces an RPM)
3. rpm -ivh <the rpm>
4. ln -s /bin/cut /usr/bin/cut (<- already a workaround)
4. /usr/java/jdk-1_3_0_02/bin/java
             ^^^^^^^^^^^^
                  |
                  +---- if I remember correctly
5. ... (hangs)

Actual Results:
(hangs)

Expected Results:
Run java class

Additional Information:
JDK worked jut fine in 7.0 without the need for any intervention (beyond,
optionally, adding the JDK bin directory to ones path).  Now, in 7.1, it
doesn't work at all.
Comment 1 Trond Eivind Glomsrxd 2001-05-14 17:01:51 EDT
I suggest you read the release notes - there is a bug in JDK (it makes
assumptions which are no longer valid). IBM has a version available with a
workaround.

*** This bug has been marked as a duplicate of 27090 ***

Note You need to log in before you can comment on or make changes to this bug.