This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 405911 - Anaconda fails to configure iSCSI initiator
Anaconda fails to configure iSCSI initiator
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2007-11-30 09:44 EST by Lubomir Kundrak
Modified: 2008-01-16 15:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 15:24:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tty4? (7.60 KB, image/png)
2007-11-30 09:47 EST, Lubomir Kundrak
no flags Details
tty3? (23.93 KB, image/png)
2007-11-30 09:51 EST, Lubomir Kundrak
no flags Details
The anaconda exception log (258.62 KB, text/plain)
2007-11-30 10:00 EST, Lubomir Kundrak
no flags Details

  None (edit)
Description Lubomir Kundrak 2007-11-30 09:44:19 EST
Description of problem:

Anaconda fails to configure iSCSI initiator to connect to my iSCSI target. I
attach screenshots.

Version-Release number of selected component (if applicable):

anaconda-11.4.0.3-1 with with partedUtils.py fix.

Steps to Reproduce:
1. Advanced storage configuration
2. add iSCSI target

Actual results:

"InitiatorAlias= is required"

Additional info:

It would be very nice, if the iSCSI target address could be entered as DNS name,
not only IP address. I this is just too small change to have a feature report on
its own, or isn't it?
Comment 1 Lubomir Kundrak 2007-11-30 09:44:19 EST
Created attachment 273841 [details]
(accidentelly attached, ignore)
Comment 2 Lubomir Kundrak 2007-11-30 09:47:56 EST
Created attachment 273861 [details]
tty4?
Comment 4 Lubomir Kundrak 2007-11-30 09:51:18 EST
Created attachment 273891 [details]
tty3?
Comment 5 Lubomir Kundrak 2007-11-30 10:00:30 EST
Created attachment 273911 [details]
The anaconda exception log

I attach it just now, I had some trouble getting it off the machine (bug
#405951, bug #405921)
Comment 6 Lubomir Kundrak 2007-11-30 11:35:46 EST
While the exception in the log above has been fixed, iSCSI still can not be
configured. InitiatorAlias is apparently not needed, iscsiadm [*] complains
about configuration error. If I copy the iscsid.conf I use from my workstation
(about the same one that came with the package), iscsiadm no longer complains,
but still it doesn't list the targets. iscsid keeps complaining about not
knowing anything about UID 0, which resembles bug #405921.

[*] iscsiadm --mode discovery --type sendtargets --portal 172.31.2.246
Comment 7 Lubomir Kundrak 2007-12-10 15:05:58 EST
After bug #405921 was resolved, symptoms changed, but iSCSI is still unusable.

Now the initiator can not be configured due to another reason -- lack of crc32c
kernel module. Anaconda should insmod crc32c before attempting to configure the
initiator. See #208607 for more details.
Comment 8 Lubomir Kundrak 2008-01-14 03:41:48 EST
Ping on this. Anything I can do to help resolve the issue?
Comment 9 Chris Lumens 2008-01-16 15:24:57 EST
We weren't even including the module in the images to begin with.  This should
be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.