Bug 40650 - vncviewer -fullscreen does not kbd input under KDE
vncviewer -fullscreen does not kbd input under KDE
Status: CLOSED DUPLICATE of bug 63853
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-05-15 02:00 EDT by Aleksey Nogin
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-06-29 14:08:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2001-05-15 02:00:53 EDT
Description of Problem:

When I run "vnc -fullscreen" from under KDE, the VNC would not get keyboard
input (mouse still works fine).

How Reproducible:
 - Under KDE - always. In particular, all four possible settings of window
focus behaviour produce the same result.
 - Under Gnome this problem does not occur.
 - If I first start vncviewer in a window and than go to fullscreen mode
using the menu (through F8), the problem does not occur.

Steps to Reproduce:
1. Start a KDE session
2. Start a VNC session
3. Start a vncviwer -fullscreen under your KDE session

Actual Results:

All keyboard input goes to the window that used to have focus before
vncviewer was started, even though the mouse works fine.

Expected Results:

Both mouse and keyboard events go to vncviwer

Additional Information:
  In case it matters, I am running XFree v4 with a XkbLayout "ru"
(actually, a modification of "ru").
Comment 1 Tim Waugh 2001-05-15 06:54:56 EDT
I see this too, about 50% of the time.  At first glance, this looks like a 
kwin bug.
Comment 2 Aleksey Nogin 2002-01-03 12:51:39 EST
I still see this with 7.2, 100% of the time. Pretty annoying...
Comment 3 Aleksey Nogin 2002-06-29 14:08:47 EDT
Dup of bug 63853?
Comment 4 Tim Waugh 2002-07-03 11:16:50 EDT
I think so. 

*** This bug has been marked as a duplicate of 63853 ***

Note You need to log in before you can comment on or make changes to this bug.