Bug 63853 - fullscreen problems
fullscreen problems
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: vnc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 40650 (view as bug list)
Depends On:
Blocks: 66890 79579
  Show dependency treegraph
 
Reported: 2002-04-19 12:36 EDT by Tim Waugh
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-09 07:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Peter Estrand's fix (904 bytes, patch)
2002-04-19 12:37 EDT, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2002-04-19 12:36:38 EDT
There are various fullscreen problems.
Comment 1 Tim Waugh 2002-04-19 12:37:07 EDT
Created attachment 54625 [details]
Peter Estrand's fix
Comment 2 Tim Waugh 2002-04-23 09:23:18 EDT
Fixed in 3.3.3r2-29.
Comment 3 Aleksey Nogin 2002-06-29 14:08:06 EDT
Two questions:

Is bug 40650 a dup of this one?

Is bug 66890 (xscreensaver fails to grab keyboard when VNC is running
fullscreen) caused by this patch?
Comment 4 Tim Waugh 2002-07-03 11:16:46 EDT
*** Bug 40650 has been marked as a duplicate of this bug. ***
Comment 5 Aleksey Nogin 2002-07-04 15:06:10 EDT
According to bug 66890, this patch was removed... 

Is there some way of fixing this w/o causing bug 66890? May be fix the WMs that
cause it?
Comment 6 Tim Waugh 2002-07-04 15:51:31 EDT
As Peter Estrand says in the link at bug #66890, basically we don't know. 
 
The main fullscreen problem that this bug was originally about when I opened 
it was that fullscreen plain didn't work at all---all keyboard events get 
lost.  That _should_ still be fixed in 3.3.3r2-34. 
 
There is another minor issue to do with when the resolutions are different and 
the placement of the cursor, which is easily worked around (put the cursor in 
the right place!). 
 
Changing state to modified until fullscreen is verified to actually work in 
3.3.3r2-34.
Comment 7 Aleksey Nogin 2002-07-06 14:43:59 EDT
I've installed 3.3.3r2-34 on Red Hat 7.2 + all updates (e.g. kdebase-2.2.2-1 and
xscreensaver-3.33-4). Now -fullscreen works properly  and xscreensaver locks
properly when VNC is running fullscreen. Thanks so much for fixing this!

Haven't yet tried using it on a newer system though...
Comment 8 Aleksey Nogin 2002-07-06 21:40:55 EDT
Even with vnc-3.3.3r2-34 there is still one fullscreen-related problem left
(should I report it in a separate bug?). If the VNC screen size is bigger than
the local screen size,then in fullscreen mode I can not scroll down (e.g. by 
trying to go past the lower end of the screen) until I switch to windowed mode
and then back to fullscreen. And even if I start in windowed mode, I still have
to go thorough switching 3 times ( -> fullscreen -> windowed -> fullscreen)
before I am able to scroll down. Scrolling down in the windowed mode and
scrolling right in both modes works OK. All of this is still on 7.2+updates.
Comment 9 Tim Waugh 2002-12-23 04:35:16 EST
Does this still happen with vnc-3.3.3r2-43?
Comment 10 Tim Waugh 2003-01-09 07:39:12 EST
Can't reproduce this in vnc-3.3.3r2-43; starting viewer with -fullscreen works.

Note You need to log in before you can comment on or make changes to this bug.