Bug 40657 - Bad multibyte chars in japanese .po-file
Summary: Bad multibyte chars in japanese .po-file
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gettext
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-15 10:40 UTC by Enrico Scholz
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-05-31 12:38:22 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2001-05-15 10:40:47 UTC
[lynx-2.8.4-12.src.rpm]

Description of Problem:

lynx can not be rebuilt because msgfmt fails on po/ja.po.


Steps to Reproduce:
1. LANG=C rpm --rebuild lynx-2.8.4-12.src.rpm


Actual Results:
...
file=./`echo ja | sed 's,.*/,,'`.gmo \
  && rm -f $file && PATH=../src:$PATH /usr/bin/msgfmt -o $file ja.po
ja.po:568: invalid multibyte sequence
ja.po:569: end-of-line within string
...
ja.po:3906: end-of-line within string
too many errors, aborting
make[1]: *** [ja.gmo] Error 1


Additional Information:
	
$ rpm -q gettext glibc
gettext-0.10.37-2
glibc-2.2.2-10

$LINGUAS is unset

Comment 1 Bernhard Rosenkraenzer 2001-05-31 07:46:36 UTC
This compiled with an older gettext... Did gettext switch to a different 
encoding?


Comment 2 Enrico Scholz 2001-05-31 09:06:16 UTC
Bug #40656 tells some details and a possible  workaround
(OLD_PO_FILE_INPUT=yes).

Comment 3 Trond Eivind Glomsrxd 2001-05-31 12:37:25 UTC
That can't be blindly used, since I don't know ow a proper way to identify
whether or not the format is old or new... I'm still waiting on feedback from
the Japanese office on how to do that.

Comment 4 Trond Eivind Glomsrxd 2001-06-04 14:01:25 UTC
OK, we're going for the OLD_PO_FILE_INPUT.


Note You need to log in before you can comment on or make changes to this bug.