Bug 407251 - SELinux seems to be reporint gdm has a leaked file descriptor
SELinux seems to be reporint gdm has a leaked file descriptor
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 413401 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-01 06:57 EST by Daniel Walsh
Modified: 2008-03-10 20:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 09:57:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Walsh 2007-12-01 06:57:19 EST
Description of problem:

type=AVC msg=audit(1196509401.288:20): avc:  denied  { search } for  pid=2806
comm="dbus-daemon" name="gdm" dev=dm-0 ino=3211273
scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=dir

Which would indicate SELinux needs this rule.

allow xdm_dbusd_t xdm_var_lib_t:dir search;

Which means the dbus-daemon being execed from gdm is search through /var/lib/gdm
 for something.  I am guessing this is a open file that gdm is using.  gdm seems
to work fine without this access.

rpm -q selinux-policy gdm
selinux-policy-3.2.1-1.fc9
gdm-2.21.2-0.2007.11.20.2.fc9
Comment 1 jmccann 2008-03-07 18:39:25 EST
Are you still seeing this in rawhide?
Comment 2 jmccann 2008-03-07 18:40:44 EST
*** Bug 413401 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.