Bug 413401 - SELinux is preventing /bin/dbus-daemon (xdm_dbusd_t) "search" to (xdm_var_lib_t).
Summary: SELinux is preventing /bin/dbus-daemon (xdm_dbusd_t) "search" to (xdm_var_lib...
Status: CLOSED DUPLICATE of bug 407251
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-06 04:33 UTC by Jim Cornette
Modified: 2008-03-07 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 23:40:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dbus search error for SELinux (2.33 KB, text/plain)
2007-12-06 04:33 UTC, Jim Cornette
no flags Details

Description Jim Cornette 2007-12-06 04:33:47 UTC
Description of problem:

After finally being able to login via gdm, I get this dbus error.

Version-Release number of selected component (if applicable):
dbus-1.1.2-9.fc9

How reproducible:

Login runlevel 5 with gdm as manager and launching gnome. Check troubleshooter
browser for SELinux errors.

Steps to Reproduce:
1. boot using kernel-2.6.23.8-63.fc8
2. boot to runlevel 5
3. login to gnome via gdm
  
Actual results:
Get this error repeatable three boot sessions

Expected results:

Not to have errors related to packages and security labels.
Additional info:

Refer to attachment.

Comment 1 Jim Cornette 2007-12-06 04:33:47 UTC
Created attachment 279181 [details]
dbus search error for SELinux

Comment 2 David Zeuthen 2007-12-06 05:05:24 UTC
Please remember to file SELinux policy problems against SELinux.

Comment 3 Daniel Walsh 2007-12-06 15:35:05 UTC
Well actually I believe this is a problem of a leaked file descriptor and should
be filed against gdm.

I don't believe dbus needs access to gdm private data.

Comment 4 Jim Cornette 2007-12-22 04:53:58 UTC
Problem still present with selinux-policy-3.2.5-3.fc9

Raw Audit Messages :avc: denied { search } for comm=dbus-daemon dev=sda6 egid=42
euid=42 exe=/bin/dbus-daemon exit=-13 fsgid=42 fsuid=42 gid=42 items=0 name=gdm
pid=2435 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 sgid=42
subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 suid=42 tclass=dir
tcontext=system_u:object_r:xdm_var_lib_t:s0 tty=(none) uid=42 

Comment 5 Jim Cornette 2008-01-04 00:23:27 UTC
problem still exists. selinux-policy-3.2.5-7.fc9

Comment 6 jmccann 2008-03-07 23:40:43 UTC

*** This bug has been marked as a duplicate of 407251 ***


Note You need to log in before you can comment on or make changes to this bug.