Bug 407461 - Pirut leaves hanging process after botched quit and locks RPM datbase
Pirut leaves hanging process after botched quit and locks RPM datbase
Status: CLOSED DUPLICATE of bug 359201
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-01 13:39 EST by John William
Modified: 2007-12-04 16:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 16:45:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John William 2007-12-01 13:39:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071126 Fedora/2.0.0.10-1.fc8 Firefox/2.0.0.10

Description of problem:
When running pirut, if packages are selected and the user tries to quit the program, a dialog box comes up asking "Software selected and not installed.  Would you like to finish installing or quit anyway, losing all package selections?". Selecting "Don't quit" closes the main window and asks the same thing again. Answering "Don't quit" a second time closes pirut and leaves it's process hanging, which locks the RPM database.

Version-Release number of selected component (if applicable):
pirut-1.3.25-2.fc8

How reproducible:
Always


Steps to Reproduce:
1. Open pirut.
2. Go to Search tab.
3. Type in a package that is not installed.
4. Select the check box next to the package to install it.
5. Select File -> Quit
6. Answer "Don't quit".
7. Answer "Don't quit" again.
8. Notice that pirut is still running, without a GUI and has locked the RPM database.

Actual Results:
The pirut GUI closed and the program is still locking the RPM database with no way for the user to exit other than "kill -9".

Expected Results:
When answering "Don't quit" on the first dialog, pirut should not close down. If pirut really does need to close, it should quit cleanly.

Additional info:
Comment 1 Jeremy Katz 2007-12-04 16:45:27 EST

*** This bug has been marked as a duplicate of 359201 ***

Note You need to log in before you can comment on or make changes to this bug.