Bug 40809 - printconf doesn't work properly with LJ4L
printconf doesn't work properly with LJ4L
Status: CLOSED DUPLICATE of bug 55547
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-15 22:03 EDT by Jes Sorensen
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-16 05:48:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/alchemist/namespace/printconf/local.adl (681 bytes, application/octet-stream)
2002-01-14 13:57 EST, chris
no flags Details

  None (edit)
Description Jes Sorensen 2001-05-15 22:03:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4-ac8 i686; en-US; rv:0.9)
Gecko/20010507

Description of problem:
Hi

I have an HP LJ4L (tiny little HP PCL laser printer) which I have been
trying to configure with printconf-gui. In the printer option menu I can
choose between 75, 150 and 300 dpi (I pick 300).

However when I try to print something it looks like the ghostscript
is trying to print in 600 dpi as the image is doubled in size and
only half makes it to the paper.

When looking at /var/spool/lpd/lp/lpq.0 after printing I can see
that the size set is in fact 600dpi:

Printer: lp@savage
 Queue: no printable jobs in queue
 Status: IF filter 'mf_wrapper' filter msg -
'/usr/share/printconf/foomatic/mfomatic: printer def file ljet4-230377.foo'
at 20:49:12.274
 Status: IF filter 'mf_wrapper' filter msg - 'prepending: <</PageSize[612
792]/ImagingBBox null>>setpagedevice' at 20:49:12.284
 Status: IF filter 'mf_wrapper' filter msg - 'prepending:
<</HWResolution[600 600]>>setpagedevice' at 20:49:12.285

I have looked everywhere but I just cannot find the place where the
600 dpi is sent. 

Anyway it looks like your printer scripts do not pass the correct
string to the underlying scripts used by ghostscript.

Jes


How reproducible:
Always

Steps to Reproduce:
1.read description please
2.
3.
	

Additional info:
Comment 1 Tim Waugh 2002-01-10 07:29:24 EST
Do you still have this problem?  If so, can you please attach 
/etc/alchemist/namespace/printconf/local.adl?  Thanks.
Comment 2 Tim Waugh 2002-01-10 07:50:12 EST
This has similarities to bug #55547.
Comment 3 Tim Waugh 2002-01-14 02:58:48 EST
Apparently fixed in 7.2.
Comment 4 chris 2002-01-14 13:53:39 EST
Sadly not.  Quite the reverse here, in fact: it worked fine for me under RH7.1
(i.e. LaserJet 4L using the ljet4 driver), but the problem *started* happening
when I upgraded to RH7.2.

I'll attach my /etc/alchemist/namespace/printconf/local.adl as requested, in
case it helps.
Comment 5 chris 2002-01-14 13:57:05 EST
Created attachment 42414 [details]
/etc/alchemist/namespace/printconf/local.adl
Comment 6 Tim Waugh 2002-01-14 15:39:01 EST
But is this a separate issue to that in bug #55547?  I see that you've added a 
comment there..
Comment 7 chris 2002-01-16 05:42:42 EST
Sorry, I should have made that explicit.  No, it's not a separate issue (at
least, I was interpreting both bug reports to be referring to the same issue).

Just to be completely clear, what I'm getting here is that the image ends up
being doubled in size (in both x and y dimensions), and as a result only the
top-left corner ends up on the page, covering all of it.

Thanks a lot.
Comment 8 Tim Waugh 2002-01-16 05:50:09 EST
Okay.  Well, the original bug that this was about is closed.  Please follow-up 
to bug #55547 for future discussions about it.  I'll mark this as a duplicate 
so that I can find the local.adl file again.


*** This bug has been marked as a duplicate of 55547 ***

Note You need to log in before you can comment on or make changes to this bug.