Bug 408461 - openoffice.org impress crash while creating new presentation
openoffice.org impress crash while creating new presentation
Status: CLOSED DUPLICATE of bug 363301
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2007-12-03 04:47 EST by Marek Mahut
Modified: 2007-12-03 07:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-03 07:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
backtrace info (8.20 KB, text/plain)
2007-12-03 04:49 EST, Marek Mahut
no flags Details

  None (edit)
Description Marek Mahut 2007-12-03 04:47:07 EST
Description of problem:

OpenOffice.org impress when I'm trying to create a new presentation.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Run OOo impress 
2. At presnetation wizard, click next
3. Select "Dark blue with orange" :) next
4. "Wipe right" as effect, when selecting this effect OO crashes
Actual results:

OOo crashes.

Expected results:

Customer is happy to make his nice presentation.

Additional info:

Will attach logs in a second.
Comment 1 Marek Mahut 2007-12-03 04:49:18 EST
Created attachment 275521 [details]
backtrace info
Comment 2 Caolan McNamara 2007-12-03 05:17:55 EST
Could you tell me what the output of xdpyinfo | grep RENDER is ? If there is no
output at all, i.e. no XRender extension then this is likely to be #363301
Comment 3 Marek Mahut 2007-12-03 05:27:52 EST
Hello Caolan,

  [mmahut@mmahut ~]$ xdpyinfo | grep RENDER
  [mmahut@mmahut ~]$ 
Comment 4 Caolan McNamara 2007-12-03 05:51:12 EST
Not quite the same then as that other issue, though it is clearly something to
do with the cairo canvas. I'd like to know what X driver is in use, seems
missing from the report. What is the output of 

grep drivers /var/log/Xorg.0.log

caolanm->jnavrati: Can you see this problem on your RHEL-5 setup ?, maybe the
bit depth of 16 is important to reproduce this.

It would be interesting if someone who can reproduce this could try the proposed
2.3.0 RHEL-5.2 rpms at /mnt/redhat/brewroot/packages/openoffice.org/2.3.0/6.2.el5
to see if that will make any difference

Comment 5 Marek Mahut 2007-12-03 06:21:00 EST
It's occurring on my vmware virtual desktop.

   [mmahut@mmahut ~]$ grep drivers /var/log/Xorg.0.log
   (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
   [mmahut@mmahut ~]$ 

I'm downloading these rpms, I will let you know soon.
Comment 6 Caolan McNamara 2007-12-03 07:03:59 EST
Nah, hold it. Comment #5 is what I expected to see instead of Comment #3. If,
from the perspective of OOo being run inside vmware there is no RENDER extension
then this is bug 363301.

A workaround is to launch might be to e.g. launch oowriter and toggle off
"tools->options->view->use hardware acceleration"
and then try to repeat the original steps.

*** This bug has been marked as a duplicate of 363301 ***

Note You need to log in before you can comment on or make changes to this bug.