Bug 363301 - [fix available] ooimpress crashes when receiving NULL return from XRenderFindStandardFormat
[fix available] ooimpress crashes when receiving NULL return from XRenderFind...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openoffice.org (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: David Tardon
desktop-bugs@redhat.com
: Desktop
: 408461 445102 450839 469609 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-01 23:06 EDT by Xiaohong Wang
Modified: 2009-01-20 21:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 21:21:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backtrace (3.39 KB, text/plain)
2007-11-13 10:03 EST, Jan Navratil
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 84049 None None None Never

  None (edit)
Description Xiaohong Wang 2007-11-01 23:06:10 EDT
Description of problem:


Version-Release number of selected component (if applicable):
RHEL5.1-Client-20071017.0 with openoffice.org-*-2.0.4-5.4.24


How reproducible:


Steps to Reproduce:

Machine 1:
1.Full install RHEL5.1-Client-20071017.0
2.Run vncserver in terminal and provide a password
#vncserver
2.Uncomment two lines in ~/.vnc/xstartup 
 unset SESSION_MANAGER
 exec /etc/X11/xinit/xinitrc
3.Re-run vncserver in terminal, new remote desktop is generated
e.g. dhcp-0-127.pek.redhat.com:2

Machine 2:
1. Open remote desktop
# vncview dhcp-0-127.pek.redhat.com:2
2. Open a presentation by ooimpress
3. press F5 key for Slide Show
  

Actual results:
ooimpress got crashed

==========
(I)    x.org loaded video driver of...
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-14.el5-x86_64 libgcj-4.1.2-14.el5-i386
(V)    kernel is: Linux 2.6.18-53.el5xen #1 SMP Wed Oct 10 16:48:44 EDT 2007
x86_64 x86_64 x86_64
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.0.4-5.4.24-x86_64
(VII)  depth of root window:    16 planes
(VIII) accessibility is: false
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0xaf4c36c8: /usr/lib64/openoffice.org2.0/program/libuno_sal.so.3 + 0x366c8
0xaf4c414b: /usr/lib64/openoffice.org2.0/program/libuno_sal.so.3 + 0x3714b
0xace420a0: /lib64/libc.so.6 + 0x300a0
0xcda6df18: /usr/lib64/openoffice.org2.0/program/cairocanvas.uno.so + 0x3bf18
0xcda6ea28: /usr/lib64/openoffice.org2.0/program/cairocanvas.uno.so + 0x3ca28
0xcda6f721: /usr/lib64/openoffice.org2.0/program/cairocanvas.uno.so + 0x3d721
0xaf025783: /usr/lib64/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x47783
(cppu::OSingleFactoryHelper::createInstanceWithArgumentsAndContext(com::sun::star::uno::Sequence<com::sun::star::uno::Any>
const&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0x183)
0xaf0258ef: /usr/lib64/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x478ef
(cppu::OFactoryComponentHelper::createInstanceWithArgumentsAndContext(com::sun::star::uno::Sequence<com::sun::star::uno::Any>
const&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0xef)
0xaf027438: /usr/lib64/openoffice.org2.0/program/libuno_cppuhelpergcc3.so.3 +
0x49438
(cppu::ORegistryFactoryHelper::createInstanceWithArgumentsAndContext(com::sun::star::uno::Sequence<com::sun::star::uno::Any>
const&, com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext>
const&) + 0xd8)
0xcd82c954: /usr/lib64/openoffice.org2.0/program/canvasfactory.uno.so + 0x3954
0xcd82e01c: /usr/lib64/openoffice.org2.0/program/canvasfactory.uno.so + 0x501c
0xcd82e3d5: /usr/lib64/openoffice.org2.0/program/canvasfactory.uno.so + 0x53d5
0xcd82c66c: /usr/lib64/openoffice.org2.0/program/canvasfactory.uno.so + 0x366c
0xad3f4d76: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x292d76
(Window::GetCanvas() const + 0x5b6)
0xb3f9b27b: /usr/lib64/openoffice.org2.0/program/libcppcanvas680lx.so + 0x2227b
(cppcanvas::VCLFactory::createSpriteCanvas(Window const&) const + 0x2b)
0xab396ac2: /usr/lib64/openoffice.org2.0/program/libsd680lx.so + 0x472ac2
0xab388861: /usr/lib64/openoffice.org2.0/program/libsd680lx.so + 0x464861
0xab3894fa: /usr/lib64/openoffice.org2.0/program/libsd680lx.so + 0x4654fa
0xab37c07c: /usr/lib64/openoffice.org2.0/program/libsd680lx.so + 0x45807c
0xab0eb7e8: /usr/lib64/openoffice.org2.0/program/libsd680lx.so + 0x1c77e8
0xab0eba2e: /usr/lib64/openoffice.org2.0/program/libsd680lx.so + 0x1c7a2e
0xab0d2c97: /usr/lib64/openoffice.org2.0/program/libsd680lx.so + 0x1aec97
0xb222dac6: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x29cac6
0xb222e247: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x29d247
0xb225a472: /usr/lib64/openoffice.org2.0/program/libsfx680lx.so + 0x2c9472
0xad3fcae1: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0x29aae1
0xbe179cd7: /usr/lib64/openoffice.org2.0/program/libvclplug_gen680lx.so +
0x57cd7 (SalDisplay::DispatchInternalEvent() + 0xb7)
0xbdcb2fe6: /usr/lib64/openoffice.org2.0/program/libvclplug_gtk680lx.so + 0x15fe6
0xb7020f44: /lib64/libglib-2.0.so.0 + 0x2cf44 (g_main_context_dispatch + 0x1b4)
0xb7023d7d: /lib64/libglib-2.0.so.0 + 0x2fd7d
0xb70242ae: /lib64/libglib-2.0.so.0 + 0x302ae (g_main_context_iteration + 0x6e)
0xbdcb4a0b: /usr/lib64/openoffice.org2.0/program/libvclplug_gtk680lx.so + 0x17a0b
0xad22af41: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0xc8f41
(Application::Yield(bool) + 0x51)
0xad22afda: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0xc8fda
(Application::Execute() + 0x2a)
0xaacf1be5: /usr/lib64/openoffice.org2.0/program/libsoffice.so + 0x2bbe5
(desktop::Desktop::Main() + 0x15a5)
0xad2306a9: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0xce6a9
0xad230795: /usr/lib64/openoffice.org2.0/program/libvcl680lx.so + 0xce795
(SVMain() + 0x25)
0xaace4c06: /usr/lib64/openoffice.org2.0/program/libsoffice.so + 0x1ec06
(sal_main + 0x46)
0xace2f8a4: /lib64/libc.so.6 + 0x1d8a4 (__libc_start_main + 0xf4)
0x400619: /usr/lib64/openoffice.org2.0/program/simpress.bin + 0x619
...end stackreport details ...
...start sample ldd details ...
	libuno_sal.so.3 => /usr/lib64/openoffice.org2.0/program/libuno_sal.so.3
(0x00002aaaaaccd000)
	libuno_salhelpergcc3.so.3 =>
/usr/lib64/openoffice.org2.0/program/libuno_salhelpergcc3.so.3 (0x00002aaaab0c2000)
	libstore.so.3 => /usr/lib64/openoffice.org2.0/program/libstore.so.3
(0x00002aaaab2c6000)
	libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaab511000)
	libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaab715000)
	libstlport_gcc.so => /usr/lib64/openoffice.org2.0/program/libstlport_gcc.so
(0x00002aaaab92f000)
	libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaabc0c000)
	libm.so.6 => /lib64/libm.so.6 (0x00002aaaabf0c000)
	libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaaac18f000)
	libc.so.6 => /lib64/libc.so.6 (0x00002aaaac39e000)
	libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aaaac6ee000)
	/lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
...end sample ldd details ...


Expected results:


Additional info:
Comment 1 Caolan McNamara 2007-11-02 05:23:15 EDT
Are you able to test my 2.3.0 RHEL5.2 candidate and see if it is fixed in that
release ? i.e. the x86_64 rpms at
/mnt/redhat/brewroot/packages/openoffice.org/2.3.0/6.2.el5

I don't see the problem myself with 2.3.0 when I try the above
Comment 2 Caolan McNamara 2007-11-08 09:11:42 EST
caolanm->jnavrati: I don't guess you can reproduce this one ?
Comment 3 Jan Navratil 2007-11-08 09:15:17 EST
It works for me fine.
Comment 4 Caolan McNamara 2007-11-13 08:13:06 EST
jnavrati can reproduce it still with with the 5.2 candidate on RHEL-5 after all.
So reassigning.

we need the output when openoffice.org-debugedit is installed of

gdb /usrl/lib64/openoffice.org/program/simpress.bin
(gdb) run -impress
get it to crash
(gdb) bt

Comment 5 Caolan McNamara 2007-11-13 09:04:38 EST
You never know, might be depth related or something, xdpyinfo for the vnc
display might be useful information too
Comment 6 Jan Navratil 2007-11-13 10:03:16 EST
Created attachment 256921 [details]
backtrace
Comment 7 Caolan McNamara 2007-11-13 10:22:32 EST
oky doky, in gdb ...

(gdb) print pFormat

is it null, i.e. under vnc do we get a NULL pFormat for XRenderFindStandardFormat ?
Comment 8 Jan Navratil 2007-11-13 10:26:19 EST
->caolanm: yes, it is NULL.
Comment 9 Caolan McNamara 2007-11-13 10:37:55 EST
"Well there's your problem then", he drawls indicating the large hammer embedded
in the patients skull.

So, how'll we fix it. Maybe we just don't really have RENDER under vnc and we
should cut it off far before we get to here and so disallow using the cairo
canvas in that case avoiding the whole problem, so...

can we get xdpyinfo output from the 5.1 remote desktop is what we need to see if
that's the case.
Comment 10 Caolan McNamara 2007-12-03 07:04:00 EST
*** Bug 408461 has been marked as a duplicate of this bug. ***
Comment 11 Caolan McNamara 2008-05-04 13:23:22 EDT
*** Bug 445102 has been marked as a duplicate of this bug. ***
Comment 13 Caolan McNamara 2008-05-11 05:10:27 EDT
fix available is accurate as in "development team has a fix for this" i.e. we
provided a patch upstream in http://www.openoffice.org/issues/show_bug.cgi?id=84049

But not as in "we have a set of RHEL-5.X rpms built with it integrated for
users". We'd need the other ? changed to + to do anything about it in a RHEL
Comment 14 RHEL Product and Program Management 2008-06-02 16:29:21 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 15 Caolan McNamara 2008-06-12 04:15:44 EDT
*** Bug 450839 has been marked as a duplicate of this bug. ***
Comment 16 Caolan McNamara 2008-07-15 04:55:37 EDT
checked in, will be in >= 2.3.0-6.7
Comment 19 Caolan McNamara 2008-11-03 04:01:19 EST
*** Bug 469609 has been marked as a duplicate of this bug. ***
Comment 21 errata-xmlrpc 2009-01-20 21:21:36 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0121.html

Note You need to log in before you can comment on or make changes to this bug.