Bug 408511 - nautilus-sendto does not find pidgins icq users (patch included)
nautilus-sendto does not find pidgins icq users (patch included)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nautilus-sendto (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 394991 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 05:22 EST by drago01
Modified: 2008-01-11 17:27 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.12-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:08:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix the icq protocol name (654 bytes, patch)
2007-12-03 05:22 EST, drago01
no flags Details | Diff
spec file patch (1.11 KB, patch)
2007-12-03 05:24 EST, drago01
no flags Details | Diff
new patch (1.88 KB, patch)
2007-12-03 14:28 EST, drago01
no flags Details | Diff

  None (edit)
Description drago01 2007-12-03 05:22:24 EST
Description of problem:
nautilus-sendto does not work with icq because it uses "prpl-oscar" as a name
for the icq protocol but this is the old gaim name. Pidgin uses "prpl-icq" for
this. I changed this, rebuilt the rpm and now it displays the online buddys just
fine (before not at all).
Comment 1 drago01 2007-12-03 05:22:24 EST
Created attachment 275591 [details]
patch to fix the icq protocol name
Comment 2 drago01 2007-12-03 05:24:55 EST
Created attachment 275611 [details]
spec file patch

Here is a patch against the spec file.
If its ok I also can commit the patches to cvs and build the fixed package.
Comment 3 drago01 2007-12-03 14:28:13 EST
Created attachment 276021 [details]
new patch

The old patch breaks aim and uses the wrong icons this one should work better.
Comment 4 Bastien Nocera 2007-12-28 18:52:17 EST
Where's the upstream bug?

Adel committed your patch, but didn't get the OK from anyone in this bug, or
acknowledgement from upstream that the patch was correct. Poor manners.
Comment 5 Adel Gadllah 2007-12-28 19:36:11 EST
(In reply to comment #4)
> Where's the upstream bug?
I have not filled one because I thought it was not not necessary because fedora
maintainer = upstream maintainer (correct me if I am wrong).

> Adel committed your patch, but didn't get the OK from anyone in this bug, or
> acknowledgement from upstream that the patch was correct. 

I asked Matthias Clasen on IRC and he gave me an OK so I commited the patch to
cvs  and built the packages. 

> Poor manners.

Sorry I did not intended to bypass an processes / anyone thats why I wanted an
OK from a desktop team member first (asked Matthias on IRC #fedora-desktop/
irc.gimp.net)
Comment 6 drago01 2007-12-28 19:42:00 EST
(In reply to comment #4)
> Where's the upstream bug?
> 
> Adel committed your patch

"We" are the same person I just have two bugzilla accounts one from pre fedora
packager days (which I use for simple reports) and one for packaging work.

Sorry for the confusion that I created.
Comment 7 Matthias Clasen 2007-12-28 20:03:43 EST
Bastian, I told Adel to go ahead after looking at the patch; I should have left
a comment here, I guess.
Comment 8 Matthias Clasen 2007-12-28 20:05:15 EST
I agree that an upstream bug would be in order though. 
Comment 9 drago01 2007-12-28 20:13:22 EST
Upstream bug filled: https://bugzilla.gnome.org/show_bug.cgi?id=506176
Comment 10 Fedora Update System 2008-01-02 20:30:54 EST
nautilus-sendto-0.12-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nautilus-sendto'
Comment 11 Fedora Update System 2008-01-02 20:42:41 EST
nautilus-sendto-0.12-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nautilus-sendto'
Comment 12 Adel Gadllah 2008-01-06 16:53:44 EST
*** Bug 394991 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2008-01-11 17:08:58 EST
nautilus-sendto-0.12-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2008-01-11 17:27:48 EST
nautilus-sendto-0.12-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.