Bug 408851 - git-svn needs perl-Error.noarch
git-svn needs perl-Error.noarch
Status: CLOSED DUPLICATE of bug 367861
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-03 12:04 EST by Laurent Rineau
Modified: 2013-01-10 05:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-03 13:38:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laurent Rineau 2007-12-03 12:04:25 EST
Description of problem:
On a Fedora-8 box, update-to-date :

lrineau@schtroumpf ~ $ git svn
Can't locate Error.pm in @INC (@INC 
contains: /usr/lib/perl5/site_perl/5.8.8/i38                                                                          
6-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8                                                                          .7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-mult                                                                          
i /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_per                                                                          
l/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/p                                                                          
erl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib                                                                          /perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.                                                                          
6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-mul                                                                          
ti /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/pe                                                                          
rl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_per                                                                          
l /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) 
at /usr/l                                                                          
ib/perl5/vendor_perl/5.8.8/Git.pm line 93.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/Git.pm 
lin                                                                          e 
93.
Compilation failed in require at /usr/bin/git-svn line 39.
BEGIN failed--compilation aborted at /usr/bin/git-svn line 39.
zsh: exit 2     git svn

The sub-package git-svn should have "Requires: perl-Error". 

Version-Release number of selected component (if applicable):
lrineau@schtroumpf ~ $ rpm -q git-svn
git-svn-1.5.3.4-1.fc8

How reproducible:
Remove perl-Error from your machine, then try to use "svn git".
Comment 1 Josh Boyer 2007-12-03 13:38:42 EST

*** This bug has been marked as a duplicate of 367861 ***

Note You need to log in before you can comment on or make changes to this bug.