Bug 41118 - latin1(7) manpage doesn't work
latin1(7) manpage doesn't work
Status: CLOSED DUPLICATE of bug 19555
Product: Red Hat Linux
Classification: Retired
Component: groff (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2001-05-17 13:14 EDT by Tethys
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-29 12:30:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tethys 2001-05-17 13:14:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4 i686; en-US; rv:0.9)

Description of problem:
The command "man latin1" doesn't show the latin1 man page

How reproducible:

Steps to Reproduce:
1.man latin1 | more

Actual Results:  I get the error message:

<standard input>:2: realpath on `man7/iso_8859-1.7' failed: No such file or

Expected Results:  I should get the man page!

Additional info:

The file /usr/share/man/man7/latin1.7.gz contains a .so request
for man/iso_8859_1.7, which itself contains a .so request for
man/iso_8859-1.7 (note the dash replacing the final underscore).
Changing the latin1 file to request iso_8859-1.7 directly fixes
the problem.
Comment 1 Trond Eivind Glomsrxd 2001-05-17 16:24:25 EDT
This is a bug in groff - it has problems handling indirect links to compressed
files. Your workaround works, though - added for man-pages-1.35-7
Comment 2 Michael Schwendt 2001-05-27 15:27:46 EDT
Another easier temporary work-around for Red Hat Linux 7.1 users:

cd /usr/share/man/man7
gunzip iso_8859_1.7.gz iso_8859_2.7.gz
Comment 3 Trond Eivind Glomsrxd 2001-05-29 12:30:20 EDT

*** This bug has been marked as a duplicate of 19555 ***

Note You need to log in before you can comment on or make changes to this bug.