Bug 411481 - Linksys WUSB54G USB cannot get IP address with updated kernels
Summary: Linksys WUSB54G USB cannot get IP address with updated kernels
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 8
Hardware: i686 Linux
low
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 427009
TreeView+ depends on / blocked
 
Reported: 2007-12-05 03:56 UTC by Bryan Christ
Modified: 2008-11-20 19:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-20 19:15:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output from working configuration (20.02 KB, text/plain)
2007-12-13 16:53 UTC, Bryan Christ
no flags Details
dmesg output from a non-working configuration (20.06 KB, text/plain)
2007-12-13 17:14 UTC, Bryan Christ
no flags Details
output from lsusb (2.27 KB, text/plain)
2007-12-13 17:18 UTC, Bryan Christ
no flags Details
Wireshark Capture (318.87 KB, application/octet-stream)
2008-01-04 23:32 UTC, Bryan Christ
no flags Details
dmesg (23.38 KB, text/plain)
2008-03-24 14:53 UTC, Bryan Christ
no flags Details

Description Bryan Christ 2007-12-05 03:56:49 UTC
Description of problem:

WUSB54G USB cannot get IP address with updated kernels.  Only kernel
kernel-2.6.23.1-42.fc8 works correctly.

It also does not matter whether you use the NetworkManager tool or
iwconfig/dhclient manually.

Tested the failure with kernels:
kernel-2.6.23.1-49,fc8
kernel-2.6.23.8-63.fc8

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1.  Install F8 32-bit 
2.  Plug in Linksys WUSB54G USB adapter
3.  Configure adapter with a with a 40-bit WEP key (open system)
4.  Should work.
5.  Upgrade to newer kernel via yum.
6.  Reboot.
7.  Adapter will no longer fetch an IP address
  
Actual results:


Expected results:


Additional info:

Test system is an HP Compaq dc7100 usdt

Comment 1 Pete Zaitcev 2007-12-05 16:52:05 UTC
I have an adapter but not the wireless infrastructure to test.
Please attach the dmesg output from both kernels (do not use the one in
/var/log/dmesg, capture it anew after the adapter fails to work).
The dmesg should also tell if it's p54u or rndis -- same hardware
different versions use different drivers.

Comment 2 Bryan Christ 2007-12-13 16:50:58 UTC
Retested with updates from updates-testing:

NetworkManager-0.7.0-0.6.6.svn3138.fc8
NetworkManager-gnome-0.7.0-0.6.6.svn3138.fc8
NetworkManager-glib-0.7.0-0.6.6.svn3138.fc8

kernel-2.6.23.9-85.fc8

Still no change.


Comment 3 Bryan Christ 2007-12-13 16:53:27 UTC
Created attachment 287631 [details]
dmesg output from working configuration

Comment 4 Bryan Christ 2007-12-13 17:14:04 UTC
Created attachment 287641 [details]
dmesg output from a non-working configuration

Comment 5 Bryan Christ 2007-12-13 17:18:12 UTC
Created attachment 287651 [details]
output from lsusb

Comment 6 Bryan Christ 2007-12-27 19:36:00 UTC
Zaitcev,

I thought I would mention that the adapter appears to be using the rt2x00usb
kernel module.

Comment 7 John W. Linville 2008-01-02 19:32:27 UTC
The rt2500usb driver version in -42.fc8 is months old -- the jump to -49.fc8 
was too large to easily pinpoint a likely changeset.

I'm copying the main rt2x00 developer to see if he has any insight...

Comment 8 Ivo van Doorn 2008-01-02 22:05:05 UTC
Ok, the problem has nothing to do with DHCP. Apparently the device is not 
authenticating and thus isn't even associated to the AP.

(This means this bug is a duplicate of [Bug 9388] Unable to associate rt25xx 
USB key with a WPA AP)

Could you try using wireshark on a different machine to see if the 
authentication requests are leaving the device and if there is a response for 
them from the AP?

Comment 9 John W. Linville 2008-01-03 15:11:51 UTC
Bryan, can you provide the information Ivo is requesting?

Comment 10 Bryan Christ 2008-01-04 20:45:29 UTC
Unfortunately, this is the only machine I have configured with that adapter and
Fedora 8.  I'd be glad to capture whatever information you need from the one
machine I have, but I'll need some guidance on how to use the tool to collect
the needed info.


Comment 11 John W. Linville 2008-01-04 20:54:09 UTC
The machine running wireshark can have any kind of adapter (as long as it 
supports monitoring)...does that change the picture?

Comment 12 Bryan Christ 2008-01-04 21:18:21 UTC
Oh, yes indeed.  I have a laptop that participates on the same network. 
Basically, I would just need some instructions on how to capture the information
you need with wireshark.  That is not a tool I am familiar with.

Comment 13 Ivo van Doorn 2008-01-04 22:12:25 UTC
Put the interface on your laptop in monitor mode (iwconfig wlan0 mode monitor)
start wireshark (As user with enough privileges)
Select Capture->Interfaces
Press the start button next to your interface.

On your machine with rt2500usb, start the network interface and let it attempt 
a few connections.

If all goes right you will see wireshark reporting a lot of frames, you can 
save those results to a file which you can attach to this bug report.

Comment 14 Bryan Christ 2008-01-04 23:32:15 UTC
Created attachment 290874 [details]
Wireshark Capture

Comment 15 Bryan Christ 2008-01-04 23:33:48 UTC
I tried 3 time with NetworkManager to make a connection while running Wireshark.
 The kernel on the misbehaving system is: 2.6.23.9-85



Comment 16 Ivo van Doorn 2008-01-09 21:40:49 UTC
John, please make sure you merge the patch:
rt2x00: Corectly initialize rt2500usb MAC
which I have send to the linuxwireless mailinglist today, that should resolve 
this issue.

Comment 17 Bryan Christ 2008-01-09 21:54:35 UTC
I'll be glad to test the patched kernel if someone can provide me with the rpms.

Comment 18 John W. Linville 2008-01-11 21:14:56 UTC
http://koji.fedoraproject.org/koji/buildinfo?buildID=31090

Does this help?

Comment 19 Bryan Christ 2008-01-16 21:15:53 UTC
John,

I retested with 2.6.23.13-105 from updates-testing and the problem still persists.

Comment 20 Bryan Christ 2008-02-01 18:01:16 UTC
Retested with kernel-2.6.23.14-107 and problem still persists.

Comment 21 Bryan Christ 2008-02-29 23:32:11 UTC
John,

Any news on this?

Comment 22 John W. Linville 2008-03-04 19:14:27 UTC
No, sorry -- nothing specific.  What is the latest F8 kernel you have tried?

Comment 23 John W. Linville 2008-03-13 15:13:05 UTC
The kernels here contain an update to rt2x00 version 2.1.4:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=42735

Could you give those kernels a try to see if they resolve this issue for you?

Comment 24 Bryan Christ 2008-03-13 15:54:49 UTC
John,

I will try one of these sometime between now and Monday.

Comment 25 Bryan Christ 2008-03-18 17:11:30 UTC
I tried the test kernel you mentioned and it did not resolve the problem.

Comment 26 John W. Linville 2008-03-18 17:16:16 UTC
Please post a new round of dmesg output...thanks!

Comment 27 Bryan Christ 2008-03-24 14:53:06 UTC
Created attachment 298896 [details]
dmesg

Comment 28 Bryan Christ 2008-04-25 00:32:16 UTC
Retested with 2.6.24.5-85 from updates-testing and it still does not work.

Comment 29 Bryan Christ 2008-06-05 15:27:56 UTC
I retested with 2.6.25.4-10 from the "updates-testing" repo.  The problem is
still not fixed.

Comment 30 Fedora Update System 2008-08-08 00:00:20 UTC
kernel-2.6.25.14-69.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-7128

Comment 31 Fedora Update System 2008-08-12 18:22:32 UTC
kernel-2.6.25.14-69.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 32 Bryan Christ 2008-08-12 18:30:07 UTC
John,

I haven't forgotten about this bug.  It may be several weeks before I can test this new kernel because that machine is packed in a box until our family is moved.

Bryan


Note You need to log in before you can comment on or make changes to this bug.