Bug 413611 - Missing ATI display driver in FC8
Missing ATI display driver in FC8
Status: CLOSED DUPLICATE of bug 374581
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 03:41 EST by Dagfinn Matre
Modified: 2008-04-11 15:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 15:04:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configuration file (802 bytes, text/plain)
2007-12-06 03:41 EST, Dagfinn Matre
no flags Details
xorg configuration file (802 bytes, application/octet-stream)
2008-01-22 02:38 EST, Dagfinn Matre
no flags Details
xorg 0 log file (95.19 KB, text/plain)
2008-01-22 02:39 EST, Dagfinn Matre
no flags Details
xorg 20 log file (36.18 KB, text/plain)
2008-01-22 02:40 EST, Dagfinn Matre
no flags Details
xorg 0 log file after removing xconf.org (102.13 KB, text/plain)
2008-01-22 02:53 EST, Dagfinn Matre
no flags Details

  None (edit)
Description Dagfinn Matre 2007-12-06 03:41:36 EST
Description of problem:
system-config-display returns an error msg. Neither is it possible to change
screen resolution when selecting System->Preferences->Hardware->Screen
resolution. The dialog box appears, but the pulldown menus are empty.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run system-config-display as root
2.
3.
  
Actual results:
This error message:

Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 533, in __init__
    self.state.recalc_mode()
  File "/usr/lib64/python2.5/site-packages/rhpxl/xhwstate.py", line 387, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range

Expected results:
Dialog box enabling me to change screen resolution and refresh rate

Additional info:
I have installed all updates that have been suggested by the OS. I believe the
problem is related to the OS not recognizing my graphics card, ATI Mobility
Radeon X1600. I tried to run ati-driver-installer-7-11-x86.x86_64.run, found on
ATI's homepage, but that only changed the resolution to REALLY low. 
Computer: HP Compaq nc8430 (laptop), 2GHz, 2GB
Comment 1 Dagfinn Matre 2007-12-06 03:41:36 EST
Created attachment 279481 [details]
configuration file
Comment 2 Stepan Kasal 2007-12-17 11:09:04 EST
Reassigning to the right component.
Comment 3 Matěj Cepl 2008-01-21 11:15:23 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

1) Forget ati-driver-installer, please -- it installs binary-only ATI
proprietary driver (among other things), which we cannot support and any bugs
from systems using it are hot candidates for CLOSED/CANTIFX. Please, don't use
it. Use only driver from xorg-x11-drv-ati package for your distribution. For
information how to clean your system of all proprietary stuff, please, see
http://fedoraproject.org/wiki/Xorg/3rdPartyVideoDrivers.

2) Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Dagfinn Matre 2008-01-22 02:38:52 EST
Created attachment 292472 [details]
xorg configuration file
Comment 5 Dagfinn Matre 2008-01-22 02:39:46 EST
Created attachment 292473 [details]
xorg 0 log file
Comment 6 Dagfinn Matre 2008-01-22 02:40:06 EST
Created attachment 292474 [details]
xorg 20 log file
Comment 7 Dagfinn Matre 2008-01-22 02:53:40 EST
Created attachment 292475 [details]
xorg 0 log file after removing xconf.org
Comment 8 Adam Jackson 2008-04-11 15:04:04 EDT

*** This bug has been marked as a duplicate of 374581 ***

Note You need to log in before you can comment on or make changes to this bug.