Bug 41372 - objdump (find-requires) not recognizing perlscripts
Summary: objdump (find-requires) not recognizing perlscripts
Status: CLOSED DUPLICATE of bug 22801
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-19 15:42 UTC by Dan Kelley
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-20 13:45:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Kelley 2001-05-19 15:42:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
When I do 
	rpm -bb myproject.spec
I get errors such as
	Finding  Requires: (using /usr/lib/rpm/find-requires)...
	objdump: /var/tmp/gri-root/usr/bin/gri_merge: File format not recognized
where "gri_merge" is a perlscript, recognized as such by the "find"
command.

Should I be doing something in my SPEC file to indicate the "file format"?

Thanks!



How reproducible:
Always

Steps to Reproduce:
1. rpm -bb gri.spec
2.
3.
	

Actual Results:  ...

Finding  Requires: (using /usr/lib/rpm/find-requires)...
objdump: /var/tmp/gri-root/usr/bin/gri_merge: File format not recognized

...


Expected Results:  Well, I didn't expect this warning, or error, or
whatever it is!

Additional info:

I don't think this happened before I upgraded from RH 7.0 to 7.1, but I'm
not sure.

Comment 1 Jeff Johnson 2001-05-20 13:45:08 UTC
There's nothing you have to do. The file(1) /etc/magic has changed, breaking
the find-requires logic that normally feeds only ELF binaries to objdump.
Doesn't hurt anything at all to feed perl scripts to objdump, it's just an
error message.

Comment 2 Jeff Johnson 2001-05-22 18:58:38 UTC

*** This bug has been marked as a duplicate of 22801 ***

Comment 3 Dan Kelley 2001-05-22 19:02:19 UTC
Thanks for informing me of the old (duplicate) bug.  

FYI: I can't access that bug.  It says I don't have permission to do so
(although I'm logged in at the moment).




Note You need to log in before you can comment on or make changes to this bug.