This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 414381 - tex failures when making the manual prevents rebuild of bacula
tex failures when making the manual prevents rebuild of bacula
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: latex2html (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On: 306151
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 11:53 EST by Jesse Keating
Modified: 2013-07-02 19:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 04:37:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2007-12-06 11:53:37 EST
+ make
(cd manual; make)
make[1]: Entering directory
`/builddir/build/BUILD/bacula-2.0.3/bacula-docs-2.0.3/manual'
Making version 2.0.3 (06 March 2007)
latex -interaction=batchmode bacula.tex
This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
 %&-line parsing enabled.
entering extended mode
make[1]: *** [tex] Error 1
make[1]: Leaving directory
`/builddir/build/BUILD/bacula-2.0.3/bacula-docs-2.0.3/manual'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.2375 (%build)
Comment 1 Jason Tibbitts 2008-01-03 21:30:16 EST
Did some debugging and found that this is due to the latex2html %post scriptlet
somehow failing to call texhash in such a way that html.sty becomes visible to
the rest of the tex system.

Install latex2html, note that /usr/share/texmf/ls-R doesn't include the newly
installed "html" directory.

# /usr/bin/env - /usr/bin/texhash
texhash: Skipping /etc/texmf
texhash: Skipping /usr/local/share/texmf
texhash: Skipping /usr/share/texmf
texhash: Skipping /var/lib/texmf
texhash: Done.


But a plain call to /usr/bin/texhash works:

# texhash
texhash: Updating /etc/texmf/ls-R...
texhash: Updating /usr/share/texmf/ls-R...
texhash: Updating /var/lib/texmf/ls-R...
texhash: Done.

and latex bacula.tex works.
Comment 2 Caolan McNamara 2008-01-06 07:24:50 EST
I see that e.g. jadetex has a comment about 
"used texconfig-sys rehash instead of texhash" and the change was...

 %post
-/usr/bin/env - PATH=$PATH:%{TeXdir}/bin texhash > /dev/null 2>&1
+[ -x %{_bindir}/texconfig-sys ] && %{_bindir}/texconfig-sys rehash 2> /dev/null
|| :

+%postun
+[ -x %{_bindir}/texconfig-sys ] && %{_bindir}/texconfig-sys rehash 2> /dev/null
|| :
+

Maybe this should be reassigned to latex2html then ?
Comment 3 Caolan McNamara 2008-01-06 10:16:28 EST
I'd check this in an give it a whirl except I'm not in the ACL for latex2html
Comment 4 Alex Lancaster 2008-01-07 06:47:57 EST
Hmm, with the new build of latex2html now in rawhide: 

http://koji.fedoraproject.org/koji/buildinfo?buildID=30378

bacula gets further, but fails later on:

Making developers pdfm
dvipdfm -p a4 developers.dvi
make[1]: execvp: dvipdfm: Permission denied
make[1]: *** [dvipdf] Error 127

full log at:

http://koji.fedoraproject.org/koji/getfile?taskID=330531&name=build.log

seems like dvipdfm may not have executable permissions.
Comment 5 Jindrich Novy 2008-01-08 04:25:57 EST
Strange, dvipdfm has correct executable permissions so execvp shouldn't fail here.
Comment 6 Caolan McNamara 2008-01-08 04:37:50 EST
spot has apparently now rebuilt bacula, the saga is over methinks:
http://koji.fedoraproject.org/packages/bacula/2.0.3/13.fc9/
Comment 7 Alex Lancaster 2008-01-08 05:11:02 EST
Yep, the last problem was a missing "BuildRequires: dvipdfm", seems like dvipdfm
is now a separate subpackage in texlive, whereas before it was part of the main
tetex package.

Note You need to log in before you can comment on or make changes to this bug.